[RELEASE] TP-Link Plug, Switch, and Bulb integration


#1

Version 3.5 Update
a. New App that can install either cloud or hub based devices.

b. New set of Device Drivers, one per device type. Supports automated hub or cloud installations. Also supports manual hub-based installations.

Supported Devices: 11.2418. Supports all TP-Link plugs, bulbs and switches.

11-24-2018 Update
a. Added support for HS107 (tested) and HS300 (desire confirmation).
b. Updated Node applet to correct program crash while polling.

12.12.18 Update 3.5.03. Modified Drivers to eliminate Switch states other than on/off. These may have been causing errors in some routines. Additionally, this conforms the attribute "switch" to standards.

NEW Single version, single location:

Note that the previous version will be available on GitHub until at least 1.1.19.


TP-Link Cloud connect (working)
Community Apps
FS: TP-Link HS-100 wifi outlets (qty 3)
TP-Link Cloud connect (working)
New here; Migrating from ST as soon as HE arrives!
#2

Just want to post a thanks to Dave. First for being patient enough to deal with a total noobs questions and being very patient about it. Second for jumping on board and saving me any more suffering trying to figure this out.

EDIT: Works perfectly!!


#3

THANK YOU DAVE!!! Truly appreciate your work!


#4

Wow....super excited. Thanks Dave!!


#5

I saw in the logs that devices this updated every 30 minutes. If someone manually activates it, the status will be synchronized within 30 minutes in Hubitat. However, the "refresh rate" command in the driver does not work. And if we change is parameter. The default 30 minutes refreshing will not work anymore.


#6

Thanks for the feed-back. Actually, Hubitat does not have a Capability Refresh. I added the command in the metadata to keep the ability (since the device can be controlled outside Hubitat and SmartThings).

I just test. It works per spec after changing frequency. I did find that runEvery1Minute does not work in Hubitat.


#7

With smartthings for tp-link devices. The poll function worked very well.

But in RM I do not see the tp-link for the POLL function


#8

Poll is not there (forgot need). I can add back in (where poll does a refresh). Take about 5 minutes to add. Do you want it?

UPDATE. Just updated the code on GitHub for

  1. Remove "runEvery1Minute" command which causes an error in Hubitat.
  2. Add back the exposed "poll" command.

The poll add may or may not help your RM functions. Note that Hubitat does not have the Capability Poll. So if the app is looking for capabilities, it will not work. Same is true for Capability Refresh. If this is the case, you can look for the capability switch and know that the tp-link devices have the "poll" command and you can send them!

Dave


#9

the refreshrate in the driver every 5 minutes works really well. I will not even need the RM.

Good work. Thanks you :ok_hand:


#10

Thanks for this! I completely forgot I have TP Link plugs I don't use since I couldn't see them in ST (wanted a central place to see everything). What's the best way to subscribe to any updates you make have on this down the road?


#11

Two item.

  1. The same (basically) are available in SmartThings.
  2. If significant updates are made, they will be posted in this thread AND at the top. Monitoring this thread is the best way (You could also fork from GitHub; however, still a manual process to find changes).

#12

Has anyone got this to show up in the Dashboard?


#13

I have a plug on several dashboards set as an outlet and as a switch.


#14

What did you have to do? Mine is working through Hubitat as a device, but does not appear within Dashboard as a device to add. Thanks


#15

I didn’t do anything special, that I know of. If it is showing in your device list, it should be available. When you create a dashboard or edit an existing one from the apps web page, are you able to see the plug there in the list of devices to be exposed to the dashboard? (I select all devices for each dashboard because I have a terrible memory)


#16

Too funny. All my Dashboards I had selected All Devices when I created them, Somehow, this one wasn't. Could be that I was testing the ability to chose the devices in advance to have the Dashboard auto create itself with those pre-selected device choices. Thanks for the sanity check :slight_smile:


#17

Just thought I would leave this here.
Pretty good deal on these plugs.


#18

Hi Dave (@djgutheinz ) and/or anybody else

I have a new Pi 3. Installed node.js on it; version 10.8.0
Installed the Hubitat driver, added device & filled in the correct IP addresses as required for my switch in the Hubitat environment.

I'm stuck on what to do to integrate it with the node.js server...
Can somebody provide me with a little more granular information on how to implement the TP-Link node.js side of things (I'm a Pi noob)

Thanks in advance
J


#19

OK, figured it out by myself - well, Google did!

So for those that want to follow in some footsteps:

  • I created a folder TPLINK in /home/pi
  • Copied/Saved TP-LinkHub_v2.js to this new folder created above; no modifications were made to it
  • Edited the file \etc\rc.local; you may have to change permissions on it before editing to allow it to be saved again. This is done to allow the node server to start up after a pi reboot or power outtage
  • Added the line sudo node /home/pi/TPLINK/TP-LinkHub_v2.js < /dev/null & just above the exit 0 command; saved the file

Before rebooting the Pi, test this command sudo node /home/pi/TPLINK/TP-LinkHub_v2.js < /dev/null & from a Terminal window first to ensure it doesn't give any errors; cross-check in your Hubitat setup the commands are being executed/responded to via the Logs window

Note:
Several web sites listed the command to be added to the rc.local file as
su pi -c 'node /home/pi/app.js < /dev/null &'
While this worked from a Terminal window, it always prompted me for a password, so it would never execute properly in the rc.local file upon reboot

Disclaimer:
My knowledge on the Pi and any flavour of *ix is severely limited. While I may have managed to get it to work for me, your mileage may vary. Regrettably if you run into any issues with these steps I am 99% certain I will not be able to assist.


#20

@djgutheinz

I am trying to use my newly configured Tp-Link switch in Rule Machine, specifically using the Poll command.

It does not however show up in both the device list of "Refresh and Poll" or "Poll". [Showing just Poll]
image
My understanding was 05-05-18 - Updated to remove "runEvery1Minute" and to add in "poll" command.

Any ideas?

Thanks
J