Sonos Integration with speakers on separate VLAN

I have my Sonos speakers on a separate VLAN (different than where the Hubitat Hub is). The Sonos integration does not find my speaker because of that. I have my network setup so the Sonos Apps (controller app for both Android and iOS) does find and work with the Sonos speakers (players) by having the appropriate firewall rules to allow that traffic and allowing multicast broadcast messages between the separate VLANs. As a work around I have manually setup all my speakers by creating virtual devices and setting them to the integrated Sonos driver and putting in the appropriate HEX (converted from the IP of the speaker) as the device ID.

I do believe this is possible to do as the community KASA integration allows you to input the network segments you want to app to interrogate and then it finds the devices on those networks. It would be nice if the Sonos Integration would add this same feature.


1 Like

Create a firewall rule to allow your HE hub to your SONOS VLAN.

Thanks. I have firewall rule to allow the Sonos speakers (on their VLAN) to talk to the Hubitat hub. The Hub is on the base network and is allowed to talk to the other VLANs. After much more than five minutes ... I still get this:

It's because the sonos is on a different subnet

Do this in your browser
http://yourhubip/hub/allowSubnets?thisvlansubnet,thatvlansubnet,maybethisonetoo (as in, etc all separated by commas)

1 Like

Thank you. I was not aware that was something you could do. However, it didn't change my situation. I put in my subnets, received a "allowed subnets list updated" response, rebooted the hub and the Sonos App still does not discover any speakers? After 20 minutes:

I uninstalled and re-installed the Sonos integration. No change. I also added the subnets and tried the App without rebooting (in case that command is not persistent). No change.

Sonos discovery uses multicast. Is multicast being routed/reflected between your VLANs?

Alternatively, create virtual devices, then assign the Sonos driver to them, and enter the device network ID as the IP address in hexadecimal.


Total guess, but I'd assume something is still getting blocked by your VLAN rules that is preventing the discovery process.

Try creating them manually to see if that works: Sonos Auto Discovery with Sonos Integration - #3 by ritchierich

EDIT: @aaiyar beat me by a few seconds. :wink:

1 Like

Multicast is allowed through my firewall. The Sonos apps (both Android and iOS) find and work with the speakers, so I do not believe I have a firewall issue. The Sonos Apps are on a different VLAN than the Sonos Speakers.

I have done this ... just attempting to get the integrated app itself to find the speakers, as it is intended to.


1 Like

I have sonos on a different subnet using unifi networking equipment. I had to run a multi-cast relay in order to get the multicast messages to pass to the correct subnets (in addition to firewall config). I just run a docker container with the relay to bounce the messages.

1 Like

I have a firewall rule to allow all multicast messages to pass.

where Broadcast-Addresses is

I have the mdns repeater setup for all VLANS on my EdgeRouter-4. I have separate firewall rules to allow the required TCP and UDP ports that Sonos uses to pass too.

This allows the controller (The Sonos App) to be on a different subnet than the player (speakers). The Sonos app did not find the speakers until I added this multicast firewall rule .... so I am assuming it is working and multicast in not the issue with the Hubitat integration. Maybe that is a bad assumption?


I fought with this for a long time, and it wasn’t until I set the following container up that I got it working:

I assume the edge router behaves similarly, but I’m not sure.

Thanks. I try this when I get some time to install and report back.

Well ... I installed the multicast-relay on a Raspberry Pi. I see no errors. But the Sonos integrated app still does not find any speakers?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.