[RELEASE] Echo Speaks v3 + Actions

I'm trying to set this up on a new hub and when I try to create the app on Heroku its asking for information that I dont have. Any advice?

Nevermind. When I tried to do it a second time it automatically filled in the info correctly.

Hi, I have looked and can't seem to find out how to do this? I have a web server running on my pi 3, I have copied an mp3 30 second sound into a folder called sounds. What I want to do now is be able to play this mp3 sound when I need to either in a rule or a notification. When I use Echo speaks and I try this under play track, i put in http://192.168.0.8/sounds/sound.mp3 it just says the word "sound" it does not play the 30 second track.

What am I doing wrong?

OK so wonder if anyone can help with this, I'm looking to expose the SearchAmazonMusic parameter input to a dashboard. Not a problem if not possible but I was thinking i'd like it if you could type text into a dashboard tile and hit a button which would invoke the SearchAmazonMusic string search on the assigned echo device for that room.

I.e you could type in "Highway to hell" into a text box and hit the button and it would play on the echo device for that room.

Not something that is necessary but it's one of those things I got in my head and now can't work out how to do it!

I like how you did it with a variable.
I noticed in your rule you are using presetLevel(). Are you using this to change the level that a light switch turns on to when the button is physically pressed, or does it preset the dimmer, so that it avoids the brightening and then dimming issue?
Also, where are you finding this parameter? I figured it was under Custom Action->dimmer->custom command, but I see setLevel, but not presetLevel.
How well does presetting the level work? I would like to implement this if it works well.

So that preset dimmer is for my Kasa smart dimmers, since they are WiFi, they rely on polling to detect physical presses. Due to this, I preset the brightness per mode, so that the first press in that mode is already this right brightness and does not have to wait for the polling to detect a change and then change the brightness accordingly.

This is using the custom community driver for Kasa Integration. It was a feature I adapted and requested from the dev.

1 Like

Just installed the app, and got it connected to my amazon account. When I try a speech test, I'm getting the following error in my hubitat logs:

EchoApp (v3.6.2.0) | Speech Test device with serial# (G090QU06751202Q4 was not located!!!

Any ideas what might be causing this? I selected two of the nine echos I have in the house, which the app was able to auto-determine. I did NOT enable device discovery on app setup, because I was worried my hubitat devices would be duplicated since they're mirrored in Alexa.

Thank you.

** EDIT: Looks like there was an error when adding the devices on the first pass. I updated the app and the devices were added correctly. All set! **

1 Like

Awesome stuff here, @tonesto7! Just threw you some beer money!

I had this set up years ago on SmartThings, I'm now on Hubitat now for about 2 weeks. This was a breeze to set up - the instructions are incredibly easy to follow!

I read through some of this thread, but didn't see much talk about some tricks that people are doing with this... Is there a separate thread or site with some examples?

1 Like

I just installed this app for the first time and so far I am enjoying it. I have a couple of questions I'm hoping someone can help with.

Reading back through the thread it appears there was a time in which the websocket wasn't correctly updating things in Hubitat. Is there a way to change the poll time that I am missing in the app? I have full control (play/pause/volume) through both the Hubitat built in music player and through the Sharptools controller but they aren't updating what is playing without me manually refreshing the tiles.

As an extension to that, is there any sort of functionality allowing a search field or file browser? I am currently most interested in the music player aspect here and will dive deeper into TTS notifications at a later time.

Thanks

1 Like

Morning, Since the latest Hubitat update that I applied this morning my Echo Show is flooding the logs with echo speaks last voice activity updates but they're all blank?

Doesn't seem to be affecting any of the other echo devices.... ?

@tonesto7 any ideas on why this would be?

Is no-one else having this problem? My logs have 24 hours of this in!

just checked my logs and I am not seeing what you are

Same here. Not sure what is actually happening. Not happening with every Alexa show device. Now only happening on a device that is currently switched off but was happening with an active device.

Did you find a way to stop this? The show is still flooding the logs and switching off all logging in the device settings didn't help

Not sure @tonesto7 is a available right now. Hasn’t responded here for a while. Hope all is well.

Seems to have stopped. Latest HE software(2.2.1.116) may have fixed it,

i don't have the update listed for 116 as yet, so hopefully that will fix it on rollout :slight_smile:

I'm still getting the errors with the 116 update. Doesn't seem to impact performance but it should not be tripping errors.
Hopefully @tonesto7 is okay and will respond

I am getting those empty lastVoiceActivity: logs as well, about once every minute. The weird thing is that it is only coming from one of my Echo Dots. How is it affecting everyone else? Are each of your devices logging that or only one? Hubitat version 2.2.1.116

1 Like

Have you guys recently talked to the devices that are throwing errors?

Download the Hubitat app