Our engineers have identified critical issues with ZOOZ Double Plug (MODEL ZEN25) and have been working with Zooz engineers to resolve these problems.

If you have this model and experience Z-Wave network issues, please follow below troubleshooting steps as provided by Zooz engineers:

  1. Be sure to run the latest Hubitat Elevation version
  2. Ensure that plug is included without security encryption, if it is exclude/re-include
  3. If that doesn't help, update the plug to 2.0 (if it's not already on that firmware)
  4. Make sure to disable all energy and USB reports by changing Par. 18 to value 1 (size 1 byte dec)

If all fail, please reach out to Zooz support for further assistance: https://www.support.getzooz.com/new/


I do have one. What are the critical issues if I might ask? :slight_smile:

Locked up / unresponsive Z-Wave mesh.


Okay, I haven't seen those issues as of yet. I was also curious how do I check the firmware version and if its not 2.0 would this be a good chance to try out the new firmware updater?

Just answered my own question. Its version 2.0 Didn't realize it was right in front of my face! :slight_smile:

I have 2 of them I will try to include and see how it goes.
(It seems that the common suggestion is to disable energy reports, does the HE stack have issues with devices sending energy reports, in general?)


I excluded my Zooz double plug and re-included w/no security (unchecked all boxes).

Then I used the Basic Z-Wave Tool driver to set parameter18, and verified in logs as the setting was applied and after via a parameter report. Then changed back to the built-in Zooz double-plug driver:

A few things I've found:

  1. If I hit "Configure" after returning the Zooz driver (we've always been told around here to hit configure after changing drivers) the parameter 18 is returned to a value of 4.
  2. If I change the parameter and do not hit confgure after changing the driver back to the built-in Zooz driver, after a refresh the State variables on the driver page still shows a value of 4 (below). Refresh does not update this. Presumably this may update later at some point?
  3. If I re-load the Basic Z-Wave Tool driver and do a parameter report to re-check parameter 18, it is still set to 1. So the value shown on the Device page is incorrect/old.
  4. None of the settings in the driver page Preferences section are updated to show that (according to parameter18 setting) all energy reporting is disabled.


  1. The State variable listing on the Device page does not appear to get updated (at least not right away) by the change, which could confuse folks. Makes it look like the change might not have stuck.
  2. Appears we should not hit the Config button after changing back to the Zooz double-plug driver, as that appears to change the parameter18 to 4.
  3. Can you confirm that the settings in the Preferences section can be ignored when parameter18 is set to 1? Do we need to change those settings at all?
1 Like

Guess it isn't in front of my face where did you find the firmware version on it?

At the bottom of the Device Details. Parent Device


I had five of these (v2.0 software). They caused multiple z-wave problems, busy interface, and flooding of the network with messages regardless of how I set the energy reporting. Made Hubitat almost useless. Everything started working well once I removed them. I'd stay away from the at all cost until there's a firmware fix.

1 Like

i do have one of these could that have been causing teh delay issues i saw in 2.2.4

1 Like

just checked logs. mine is working correctly only sending messages every 10 minutes for power etc. i am on f2 2.0

I literally just got on here looking for support for my ZooZ double plug. It pairs (after a bit of lag) just fine using S2 unauthenticated but does not respond to switch commands, and eventually just ends up as "Failed". I was able to update the various reporting frequencies to like 1h each and it works. It's just the switches are not able to turn on/off. It seemed to freeze up at one point (even ignoring hardware input)...

I'll try to join it without security and see if that helps. Glad to share logs, etc.

Edit - no dice joining without security (Though I have never been able to get any of my other Zooz devices added without s2). Looks like the logs did dump a bunch of "debug" data on the device though. Going to leave it out of the network for now.

1 Like

All I get for configval18 is 4 as well. I tried the Basic ZWave Tool but it didn't seem to do anything I tried the parameter report for 18 and nothing and tried putting 18-1-1 in the fields to configure it and it didn't appear to do anything. I did check and notice there was an updated version of the tool so I updated but had the same results.

When you try the parameter report don't put in a parameter value, just click on that command and you should get a full report for the device in your logs, and you'll be able to see parameter18's value in the list of parameters.

2020-12-06 16_32_10-A Zooz Double Plug

So when you put 18, 1, 1 and to set the parameter you din't see any results in your log showing paramerter 18 being set to 1 (as below)?


1 Like

So I would say it's not just the Double Plug that has issues when paired with S2 security..

The Zen 23/24 switches and dimmers seem to have this as well though maybe not to the level of stopping the mesh.

It's no issue for me as I have been pairing unsecured but others have been reporting trouble.

Note: I did try and pair S2 unauthenticated and got a ghost so maybe slightly different issue OR the Zooz engineers are doing something different (in general) with their devices than HE expects...

1 Like

Where does one see the "GetParameter" button? It isn't in my device properties.

Check this out..

It's a custom driver you temporarily replace your devices driver with and it will allow you to query and set parameters for the device. When done simply set your device back to the original driver. Very handy.