Devices don't Respond or Extremely Slow

@lewis.heidrick’s advice is good. The PC Controller is. part of the free Silicon Labs’ Simplicity Studio software, and I have the USB stick from SiLabs. But you may be able to remove them without it.

You haven’t provided screenshots of your ghost nodes, so I can only speculate based on my memory. You have to click the repair button a few times (wait about a minute between clicks, you can see the progress in the logs as hub tries to access the non-existent node) before the hub decides that the node has failed. When the node indicates FAILED, then the Remove button can be used to remove the node.

See if that helps. The USB Z-stick is guaranteed to work.

Here is a guide:

1 Like

Thanks all - this is extremely helpful. Just ordered the Z-stick. I'm sure it will come in handy regardless. Will try other methods as well. I'm sure I'll get there.

1 Like

Yea, I've used it a couple times already to update the firmware for my Inovelli switches. It's my go to device now for removing pesky devices that won't go away. If I don't get them the first try with the hub I just use the UZB-7 and save me some time.

@cjlist Did you resolve your issue? I am in a very similar situation. Just switched from smartthings to Hubitat with a ton of devices. I am finding this system to be less reliable than ST. ST was not perfect but I never had situations where switches never responded as I am noticing with Hubitat. Many of my switches are GE non-plus so I fear that is part of the issue but they worked fine on ST

Hello RyanP, welcome to Hubitat.

That is not normal. Hubitat usually works much better than ST.

You are probably correct with this. Older non-plus devices don't report their state due to patents that Lutron held and GE didn't (couldn't?) use. This can be helped by polling these devices. Smartthings apparently poll switches automatically, so you didn't have to do this on your old hub.

Hubitat has a polling app, you could try it on a couple devices and see if it helps. I would be careful using polling on all devices as you could really slow the hub if you are chewing up memory from the constant polling. Pick a couple devices that are important to receive status updates and see if polling makes them report better for you. You can add a couple switches at a time until you seem to be slowing the hub.

Additionally, many people take the opportunity to upgrade to newer devices now that they are on Hubitat. Switches have come down in price, you can get some pretty good switches that have many more features than the older Zwave for about $20-30 lately. Zooz and Inovelli are good examples of this.

@neonturbo Thanks for the quick reply!
I have setup polling and am using it on the non-plus devices (11 total switches/dimmers) but my understanding is that this will just report "current status" back to the hub. The issue I am having is from time to time devices are completely unresponsive. Here are a few more specific examples:

  1. I am using the mirroring app to control a secondary garage switch from the primary (jasco motion switch), the secondary is a GE plus switch. (in this case both are plus devices). Sometimes the automation does not turn on or off the mirrored device. I am not sure how often its happening but its happening enough for me to notice, maybe 10-20% of the time.

  2. Another issue is I have several groups of switches and notice from time to time not all devices in the group go on or off when I turn the group on or off. I have the group set to indicate if any members are on and sometimes it will turn off some of the members and the group will show off but some members will still be on and even the dashboard will reflect those members as on.

I do have quite a few of the zooz switches but all of my main switches in the most heavily used areas of the house are the older non-plus GE ones. I do not want to swap them for the zooz switches becasue most are 3 or 4 way dimmers and to the best of my knowledge you can not control the dimming from secondary's.

It almost sounds like you are having Zwave mesh issues.

Can you post a screenshot of your Zwave details page that shows your device details? What does your Zwave topology map look like, are there lots of blue boxes?

@neonturbo Here are both:

I had similar issues as you are experiencing. I found some helpful advice in another thread suggesting removal of any S0 devices. My only S0 was a Yale 226 door lock. After excluding the lock, everything else became stable and responsive all the time. One of the experts here explained the S0 is very "chatty" on the mesh and can cause random transmission problems.

I noticed you have one device as S0, Maybe try excluding it to see if this helps.


Ok, so look at device 32 (Zooz Double Plug) for a second. Is that one of these below? Nothing is routing through it according to the map. So I suspect this is one of your problems.

I am also a little suspicious about the garage lights, they are slow (9.6K) and they seem to have a pretty weird route to the hub. They go through 17, which goes through 0A, which goes to 0D, then to the hub. That is the max number of hops allowed, and I would think that it might have a better route available than to do all that with this many devices. Maybe a repair of this device or a full repair might encourage it to find a better route?

Same with poolhouse foyer. What a convoluted route that appears to be.

Might be. Would be interesting to see what lock brand/model this garage door lock is to see if it could be included with S2 instead.

1 Like

@neonturbo has given you some excellent advice in his reply.
Can I just add something.
It has been said that it is not good practice to do a full z-wave repair. Individual devices, yes, full no.
Just stuff I've read but have not tried but thought I should mention it.

Not trying to tread on your toes @neonturbo but just thought I would mention it.

1 Like

Not sure what is the best anymore. But with this many weird routes, I was thinking out loud if it would be better to see if they all could find better routes rather than doing individual repairs? But you are right, try the individual ones first.

No worries. The more people who look at these posts the better. Maybe we can get a good consensus of what is going on.

1 Like

i have had the same experience with this (zooz double) device.. 20 feet from the hub it insisted and keeping and setting strange routes.. no matter how many repairs.. that is why i moved it upstairs to an unimportant function just to reboot the hue hub and a camera..

i replaced it as a test switch downstairs 20 feet from hub with the double device shown above in the other thread. this device keeps a correct route with no repeaters as it should.. As i mentioned there is someting wrong with the code in the zooz firmware to set routes.. Interesting other zooz like the single switch with the 2 usb ports don't have this issue and work fine.

Thanks for all the suggestions here. I will try all of them over the next few days and report back.

@neonturbo as for the zooz plug yes that one is an issue and I had an hour long call earlier today with @agnes.zooz about this device and we are currently working through some troubleshooting steps. That device has been added and removed several times at this point and most recently it was re-added about an hour before the screen shot so I assume that is why nothing is routing through it.

As for the other devices that are taking strange routes or having slow 9.6k speed I have done several full network repairs and a bunch of individual device repairs and I can't seem to resolve. Some of the devices just repetitively fail the repair.

The "Garage Service Door Lock" that is S0 is a Yale YRD256-ZW2-619 I am pretty sure this device is non-responsive but I have only been focusing on the switches. This device was also the only one that was really spotty on ST as well.


Hi Ryan,

I did resolve my issue, with the help of Hubitat support. On my logs, I saw a number of devices reporting as "busy", which was locking up the entire system. I uninstalled these devices, and reinstalled them. The problem was with my mesh network. I picked up a couple of Ring range extenders, and placed them strategically between the hub and the devices that were causing me trouble. I then ran a ZWave repair. The system has been very stable ever since.

@ryanp it's far more reliable, and far more flexible, than SmartThings. I too was frustrated for the first few weeks. Hang in there - once you work out the kinks it will run really smoothly.

1 Like

How do you see that a particular device is reporting as busy?

I am having trouble getting a response from Hubitat support so @cjlist I would also be interested in where they pointed you for that information.

I had another strange issue this morning. I added 4 switches and tested each as I was adding them by turning them on and off from the devices page in HE. They were all working fine. Then about an hour later I looked at it again and they had all be removed from the devices page and turned into ghost devices on the zwave details page (1st screenshot below). I was able to exclude and re-add all of them and now they show up correctly in the zwave details page (2nd screenshot). I am really lost and frustrated at this point. Let me know if anyone has any pointers.

It shows up in the logs

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.