Devices don't Respond or Extremely Slow

Hello all,

I just bit the bullet and switched over to a Hubitat C7 from my Smartthings V1 that I have had for five years. I have almost 100 devices so it was no small feat switching over. I was able to get all my switches (legacy Zwave and newer Zwave plus), door locks, Minimote, etc. Removed from Smartthings and included in Hubitat. But now I am wondering what I have got myself into.

I am having a number of issues, but I need to get past this big one to address the others.

All was working fine the first couple of days. But suddenly yesterday all went haywire. Some devices are responding immediately sometimes, or extremely slowly or not at all other times. There seems to be no rhyme or reason to it.

I have tried rebooting the hub, shutting it down completely, and running Zwave repair, all to no avail. I have also set a static IP for my hub.

The irony is that the only thing that works perfectly every time is my Zwave lock, the thing that gave me the most trouble with Smartthings.

Has anybody else had this issue, and is there anything you might suggest? I have opened a ticket with Hubitat in the meantime.


Sounds suspiciously like a mesh issue. Hubitat has smaller antennas than ST, you need a strong mesh.

What are you seeing in the logs?
What are you seeing on the Z-Wave Details page? Anything odd? Any Z-Wave busy messages in logs?

Also, it’s possible that you’ve got a device going nuts or overly chatty. Any power reporting devices?

Not many facts provided to go on.

Check settings, zwave details and the look in the clusters column for any devices with nothing in there. Ignore the first one that's the hub but all other devices should have something.

I have nine nodes with nothing in the clusters column - all say "failed" or " not responding". But none of them are attached to a device. They all say "discover" under the device column. They seem to be ghost nodes that have not been removed.

Thanks for this. It's possible I added too many devices too quickly. I did have to move the hub to capture a few remote switches in the basement, and then move it back. I also added automations before waiting three days.

Zwave logs are empty (no logs at all). Not sure what my options are now. No power reporting devices.

Thanks. I will keep working on getting to the bottom of this.

@lewis.heidrick pointed you in the right direction. You’ve got to remove those ghost nodes for things to work. Do a clean shutdown (from settings), pull the plug once light is red, wait 30 seconds, reboot.

Then remove the ghost nodes. Normally, they get removed overnight, apparently not here, so do it manually.

Generally best to build out your mesh in a spiral out from the hub so it self reinforces as you build it out. Save devices that don't pair easily for last. Moving your hub around should generally be avoided unless they're locks or garage openers using low power mode pairing. Adding repeaters before you start can really help too.

I can't remove them. Some of them don't have "remove" as an option, and for those that do, "remove" does nothing. Even after clean shutdown from settings, and even after overnight. I'll try excluding and reincluding some of the switches that were on the fringes of the range and reincluding them, now that the mesh is established. Fingers crossed.

I suggest picking up a secondary controller USB stick. This will help you get rid of the ghosts. Mouser has the UZB-7 for around 19 bucks usually. Once you get that download the free PC Controller v5 software from SiLabs.

1 Like

Thanks. I have an old Aeon Minimote that I was able to include easily in the Hubitat network. Could I use that? I am not sure I understand how a secondary controller can help me remove nodes.

The secondary controller lets you edit the devices on the primary controller. Can mark as failed and remove those ghost nodes. I don't think the minimote will work but someone else can chime in if they know for sure.

Cool. That would be extremely handy.

@lewis.heidrick’s advice is good. The PC Controller is. part of the free Silicon Labs’ Simplicity Studio software, and I have the USB stick from SiLabs. But you may be able to remove them without it.

You haven’t provided screenshots of your ghost nodes, so I can only speculate based on my memory. You have to click the repair button a few times (wait about a minute between clicks, you can see the progress in the logs as hub tries to access the non-existent node) before the hub decides that the node has failed. When the node indicates FAILED, then the Remove button can be used to remove the node.

See if that helps. The USB Z-stick is guaranteed to work.

Here is a guide:

1 Like

Thanks all - this is extremely helpful. Just ordered the Z-stick. I'm sure it will come in handy regardless. Will try other methods as well. I'm sure I'll get there.

1 Like

Yea, I've used it a couple times already to update the firmware for my Inovelli switches. It's my go to device now for removing pesky devices that won't go away. If I don't get them the first try with the hub I just use the UZB-7 and save me some time.

@cjlist Did you resolve your issue? I am in a very similar situation. Just switched from smartthings to Hubitat with a ton of devices. I am finding this system to be less reliable than ST. ST was not perfect but I never had situations where switches never responded as I am noticing with Hubitat. Many of my switches are GE non-plus so I fear that is part of the issue but they worked fine on ST

Hello RyanP, welcome to Hubitat.

That is not normal. Hubitat usually works much better than ST.

You are probably correct with this. Older non-plus devices don't report their state due to patents that Lutron held and GE didn't (couldn't?) use. This can be helped by polling these devices. Smartthings apparently poll switches automatically, so you didn't have to do this on your old hub.

Hubitat has a polling app, you could try it on a couple devices and see if it helps. I would be careful using polling on all devices as you could really slow the hub if you are chewing up memory from the constant polling. Pick a couple devices that are important to receive status updates and see if polling makes them report better for you. You can add a couple switches at a time until you seem to be slowing the hub.

Additionally, many people take the opportunity to upgrade to newer devices now that they are on Hubitat. Switches have come down in price, you can get some pretty good switches that have many more features than the older Zwave for about $20-30 lately. Zooz and Inovelli are good examples of this.

@neonturbo Thanks for the quick reply!
I have setup polling and am using it on the non-plus devices (11 total switches/dimmers) but my understanding is that this will just report "current status" back to the hub. The issue I am having is from time to time devices are completely unresponsive. Here are a few more specific examples:

  1. I am using the mirroring app to control a secondary garage switch from the primary (jasco motion switch), the secondary is a GE plus switch. (in this case both are plus devices). Sometimes the automation does not turn on or off the mirrored device. I am not sure how often its happening but its happening enough for me to notice, maybe 10-20% of the time.

  2. Another issue is I have several groups of switches and notice from time to time not all devices in the group go on or off when I turn the group on or off. I have the group set to indicate if any members are on and sometimes it will turn off some of the members and the group will show off but some members will still be on and even the dashboard will reflect those members as on.

I do have quite a few of the zooz switches but all of my main switches in the most heavily used areas of the house are the older non-plus GE ones. I do not want to swap them for the zooz switches becasue most are 3 or 4 way dimmers and to the best of my knowledge you can not control the dimming from secondary's.

It almost sounds like you are having Zwave mesh issues.

Can you post a screenshot of your Zwave details page that shows your device details? What does your Zwave topology map look like, are there lots of blue boxes?

@neonturbo Here are both: