[DRIVER] Zooz Smart Plugs Advanced (ZEN04 / ZEN05 / ZEN14)

Zooz Plugs Drivers with the goal of exposing all advanced features and settings.

If you are using this driver PLEASE like :heart: this post so I can get an idea of how many people are using it. It will motivate me to make more/better contributions as well.

Current Driver Version: 0.2.1

Supported Models:

To-Do List:

  • Command to Reset Energy Reporting
  • ZEN25 Double Plug
  • Calculated Metrics?
Features and Tips

Features:

  • All configuration variables available with designated optimized defaults
  • Basic energy monitoring from collected metrics (on available models)

Reporting Issues

Reporting Issues
Please use GitHub to report any issues so each one can have its own conversation and tracking. Please provide as much info as you can including model, firmware and the "configVals" data string. Issues · jtp10181/Hubitat · GitHub


Must PRESS CONFIGURE BUTTON and check all your parameters after any driver changes.

You can find all the drivers on the Hubitat Package Manager (HPM)
HPM Install Guide: HOW TO: Install Hubitat Package Manager (or any other User App)
HPM Docs: https://hubitatpackagemanager.hubitatcommunity.com/

Or manually install from my GitHub Repository:

Donations: Never required, always appreciated! ---->>>> PayPal.Me <<<<----

10 Likes

All - tell me what you want in an energy monitoring plug driver? I have seen some with a whole bunch of extra calculated attributes but personally I do not use any of that. I have seen high/low values, energy over time calculations, etc... Tell me what you use and want, I will add it!

The ZEN05 will be easy to add on to this, so that will be next. The ZEN14 has multiple endpoints so I have to work that out and add it on here, which will take a little more time. After that I will see if the ZEN25 can fit in here also, because why not?

1 Like

I am using the ZOOZ ZEN15 appliance monitoring plugs to monitor power usage on my washer, gas dryer, and sump pump. Would your driver offer any advantages to the Zooz power switch driver I am currently using? Would your driver work with the ZEN15 or would you need to modify the driver to provide that capability?

If the built in driver is working fine, the only advantages I could possibly offer are: Access to all the parameter settings (like the ability to disable the button). Also any sort of calculated metrics if I end up adding any to this driver.

Currently, not very well, because the parameters are not configured for that model. It might be something that could be added though.

1 Like

@jtp10181

Thank you for the driver. My Zen04 just arrived today and when I first added it HE thought it was a Zen34, but after adding your drive it came in right.

Your driver seems to be working great so far. It is nice to see that with this device all of the power reporting. I am also quite impressed with it's tiny size. I put it next to a Wemo and it is so much smaller.

Cannot actually turn off the power reporting. You can set high limits on everything to make it very little though. I am currently watching to see how chatty it is with various settings. Doesn't seem to be too terrible so far.

Something i just noticed is it looks like the Zen04 keep jumping between 0.00 and 0.3/0.4 every 2 seconds. What is strange is the driver is set to a 25 watt power report threshold and a 5 min power report interval. Any idea why it ia going so frequently.

The load is a TV and at this moment is in its lowest power state. No quick start options enabled. I would expect it to be near 0 power.

And this is the power metric? I would report it to Zooz so they can fix it. It should not be reporting those small changes with those settings. Mine would change by 0.1 here and there but it did not seem like it was reporting more than the interval I set. I just put mine on a powered animal watering fountain so it would have a load on it to test with.

Yes. It is the power metric. I have reported it to zooz.

UPDATE:

Added to HPM
Support for ZEN14 should be in the next update after this

[0.1.1] - 2021-07-31

Added

  • Support for ZEN05 Outdoor Plug

Fixed

  • Wrong default for powerFailure

Jeff,

I don't know if this is a driver issue or a HE issue, but when I try to add a basic rule that turns on the Zen04 plug at a given time, I cannot find the device to choose from the drop-down list in the basic rules app. Any ideas?

Thanks!

This is due to the driver, I had not included the "Switch" capability, thinking it was redundant with "Outlet" but apparently it is needed for apps that filter by Switch like that.

If you want to edit the code you can uncomment line 49, to enable the capability. I will change that in the next version.

I made the change. It worked. Thanks.

1 Like

Using this driver and it works great. Thank you.

1 Like

Jeff,

There appears to be four energy/power reporting states:

  • Watts
  • Amps
  • kWh (kilowatt hours)
  • Volts

You explicitly list amps and volts, but the other two are listed in the device settings as "energy" and "power". Suggest you might change the labeling for those two items to be less confusing.

Thanks!

The "Current States" aka attributes, I do not control the names of those, they are designated by the built in capabilities and I am confirming to those names for compatibility. power = Watts and energy = kWh.

If you are talking about the actual parameters, there is no settings for voltage at all, I guess it just reports whenever it feels like, I have no idea really? The rest are labeled with the common term and the units. Example setting for "Power" indicates it is wattage (W).

image

I am happy to change it make it less confusing but can you be more specific as to what exactly is the confusing part?

Almost done with the ZEN14 part of the driver as well, so another update coming soon

UPDATE

The 3 models I primarily wanted to support are now working at a basic level. Going forward I will be looking at adding the ZEN25 (and maybe other plugs?). Also can add any other features or metrics people would like for the power reporting plugs.

[0.2.0] - 2021-08-01

Added

  • Support for creating and managing child endpoints
  • Support for ZEN14 Outdoor Double Plug

Fixed

  • More robust model checking when switching from another driver
  • Added switch capability so it shows in rule setup drop downs
  • Various other minor bugs
2 Likes

There seem to be some strange results when the Zen04 think there is a zero value for something.

It looks like any time the device goes to zero or changes from it for a value immediate reporting of that value are pushed out. It looks like Voltage generally follows the same setting as Power Reporting frequency in the driver. In my case it is very 5 min unless a value of 0 shows up for some reason.

This may be something to be concerned with if you have a device that just sips power in a low power state. My example was a TV that seems to fluctuate from 0 wats to .3/.4 when off. Once I moved the load to a raspberry pi that pulls a consistent 2.5-3 watts reporting stay at the reporting frequency times.

So sounds like a device problem not driver correct? I think you are saying if the device reports a 0 for something the next time it changes even if below the threshold it will report again.

I noticed mine was randomly reporting 0 before for the voltage which is obviously wrong. I need to enable the trace logging and see if the device is really reporting 0 or the driver is making a mistake. I did see that it would report the normal voltage shortly after the 0 so your theory would explain that and point to the device sending the bad report.

Exactly

Zooz Support is looking at it now trying to reproduce the issue. I am not blaming the driver as this was mostly just a FYI to users to be aware this could happen.

Download the Hubitat app