Zen20 Power Strip Options & Native HE Driver

I guess I'm going to have to write this off as an IFM. I turned on the debug command, and we ran the Basic driver, then I reloaded everything and it appeared to accept and keep the preference. All well and good. So I turned off the debugger, to minimize traffic on the network, then I went back to Basic and re-entered everything again, then exited back to the true driver. Suddenly nothing worked again.

I played with this for about 30 minutes, and never got it to work again. Then I turned debug back on, Reloaded the preferences using Basic, then changed the driver back to the native one - - everything worked.

Going to try this on another of my ZEN 20s tomorrow to see if I can replicate what happened.

The debug just logs things, doesn’t hurt much.
If you edit the setting on the zwave tool once you do that you cannot press save preferences on the normal driver. If you save or configure on the normal driver it will set it back again.

@support_team seems like this driver for the zen20 is very broken somehow?

1 Like

I have a power strip that stopped reporting energy a month or so ago. It's out in my shop and keep meaning to look at it, but I just keep forgetting. I may have the same issue. I will be watching to see how this goes.

1 Like

Also, changes made using Basic do not show up in the native driver once you change back to it. I would think that they would show up there if it was working properly.

No, it would not. The menu in the regular driver is driven off a variable in the driver code, not the actual value on the device. For the record I do not know what is contained in the system driver code exactly, but I do code drivers so I know how it works. I would be possible to scan the device for the settings and update the menu but this is a rare feature.

1 Like

Finally looked at my power strip this morning. Had not even thought to look at the driver page. It had no setting for energy reporting, I guess one of the firmware updates changed it. I had not touched the thing in quite some time and it had been working for several months before it quit. The graph below is the energy reporting for the last year. The last time it reported energy was sometime in Dec.

I changed it to 1 minute and it then reported energy. I have since set it to 5 minutes and I will see if it updates. Its all small level power devices so it maintains about 10 watts constant.

Right after posting above, I went back and looked and I realized it now had stopped reporting Power. I updated the power repotting interval and it started up again. Not sure it is reporting energy though now.

@terminal3 so yours is letting you change the settings?
Can you post a screenshot of your State Variables (should have some "configVal#" variables in it.

Also would like to see the Data section at the bottom. And lastly what Type/Driver do you have it set to?

I was basing that assumption on the way other drivers are operating. I make a change, the changes displayed. Maybe the issue is that the native driver is not getting the setting from the device but relying on its own information which isn't reading the device before displaying.

I can change the setting but I am not sure it is sticking. As soon as you leave the page and come back all the drop downs show click to select. I am using stock HE driver.


99% of drivers if you manually make a change using the Basic Zwave tool, that change will not be reflected in when you switch back to the system driver.

If you make a change in the driver itself, in its own menu then yes, it should be reflected in that menu. By your screenshots above though, for some reason the driver is forcibly setting those values BACK to 0. So something strange is happening with that driver. Possibly something else has changed in the firmware that caused that driver to stop working right and they have not even realized it yet?

I was getting the same thing, but I knew it wasn't sticking because it was never reporting anything.

Maybe. I was never really tracking the power usage to begin with but I needed it to Return To Zero when it was turned off then powered back on. I was using it as a trigger. When it was no longer doing that, I knew I had something wrong and started experimenting.

The only way I knew it happens sometime after December 7th was I had gone in for surgery and hadn't been able to get back to that particular room of the house until just recently.

Yeah something really looks broken on this driver.

If you check the advanced settings doc: ZEN20 Power Strip Advanced Settings - Zooz Support Center
You can match up the parameter numbers to the configVals. The driver will save the values reported from the device in those state variables. So you can see what it is set at currently. Its odd that even the Overload is not matching up. **Forgot to mention this only works if the driver reports those values while the driver is active, if the settings are changed by other means the driver may not know about it

In the debug logs posted up above it looks like the driver acknowledges that it was set how OP tried to set it, but then forced it back to 0 for some reason.

Really the only way around it for now would be to set the values manually using the Basic ZWave tool, and then go back to the normal driver but DO NOT press save preferences OR configure!

You could also try my scanner tool to see if the device will respond to parameter info, and then this tool will present them in an easier to adjust way. But being an older device it may not support those commands: [RELEASE] Z-Wave Universal Device Scanner

I will take a look, thank you.

Is the @support_team aware of this issue? I can get the device to report energy if I set the energy reporting time to some value, it will not report automatically at the interval I set however. I have to send a refresh before it will update. It will not report power at all when I have it set to report energy. If I set the power report interval back to say 5 minutes then it will start to report power at the interval I set, but will no longer report energy.

I don't know, it is a repeatable issue. I can say for certain that it started sometime after 7 December. You set one parameter it wipes the rest out. If you use the Z basic tool, and then for any reason change anything using preferences, it wipes everything out again.

There appears to be an internal refresh to zero out every entry if anything is entered.

I've also got 2 of these Zooz Zen20 power strips. Mine are both the newest "version 3" of them.

If I change any parameters on the device related to power reporting, using something like the "Basic Z-wave utility" then the power strip dutifully sends updates as expected. But the built in driver is significantly broken.

It gives this error when I try having it reset the kWh data at midnight each night:
"java.lang.IllegalArgumentException: Command 'parse' is not supported by device 320. on line 660 (method componentReset)"

As described above, none of the settings "stick", and they don't query the device to set their current state when the device driver is initialized, so if you change them with a different driver and switch back, what's displayed is not correct.

The built in driver also logs basically everything that happens on it with "log.info", so it's super duper spammy in the logs and causes more load on the hub than needed.

I can verify that none of this is an issue with the device. The Zen 20 works 100% fine using ZwaveJS. It works fine on Hubitat, but not using the built-in driver. I can use the built-in driver to turn the device and its child relays on/off, but nothing else on the built in driver works.

I'd fix it myself and submit a pull request, but it doesn't look like any of the built-in drivers are available anywhere on GitHub.

1 Like

I wish I could help. I do not have one of these devices for starters which makes testing difficult.
Does it give power metrics for each plug or just for the device as a whole?
What driver/type do the Child device use?

I have a partially completed ZEN25 driver that could probably be adapted to work for the ZEN20 but it is way out of date with the rest of my code base and needs some work. Would probably merge in a bunch of stuff from my plugs driver since it handles the ZEN14 dual plug already. Also the reality is I just don't have a ton of time for this right now.

@support_team @bcopeland
Any chance of getting broken system drivers fixed?

1 Like

@daniel.winks @Pegasus If you are still interested in a fixed ZEN20 driver check out this other thread. I could use some more testers:

I have added this driver to my HPM plugs driver package: