Zen20 Power Strip Options & Native HE Driver

I have 4 Zen20 powerstrips (v2 & 3) that reported power and energy in the past. But at some point, they stopped doing it. All of them. Under Devices I change the "Preferences" and Save but as soon as I leave the page the power/energy settings are reset to "Disabled [DEFAULT]". I've also tried Save Preferences and Save Device and got the same result.

This looks like a duplicate of your other post:


I would delete one or the other so all the responded are consolidated in the same topic/thread. As for the actual problem, I'm not sure, but I have one of every generation so could probably test some things later. "Save Preferences" or "Configure" is what you'd want for these, BTW.

1 Like

Have tried both, and I number of combinations with no luck. I cross-posted because I think it might be the native driver rather than the device itself that has the issue. Since I can duplicate it on several versions and builds up the device. I can't help but wonder if it was something in one of the updates to HE that caused this because it wasn't a problem until recently. I just can't tell when it exactly started but it was somewhere between December 7th and now because that was the last time I know that it worked

Maybe, but people are likely to see the post no matter where you put it--Discourse makes that easier than traditional forum platforms--and you (or a user with a high enough trust level) can always "recategorize" the post later. I wouldn't worry about that too much, and I'd avoid duplicate posting since (besides other issues it can cause) it is against the community guidelines: Community Guidelines

1 Like

I haven't done it before, and probably wouldn't have done it this time except after thinking on the problem I decided it was probably a driver issue more than it was a device issue.

Turn on both logging options on the driver. Change the settings and then save. Should create some debug logs, post a screenshot of the logs.


Changes then Save Preferences


Exit to Device List & ReEnter. Wipes out preferences and records nothing.


Looks like the driver is maybe broken? Unless its not letting you have power Watts and frequency both set. Have you tried just setting one thing at a time?

Can I see the state variables (between commands and settings).

You should be able to set the parameters manually using the Basic Z-Wave tool. All the settings info is in this doc from Zooz: ZEN20 Power Strip Advanced Settings - Zooz Support Center

1 Like

I guess I'm going to have to write this off as an IFM. I turned on the debug command, and we ran the Basic driver, then I reloaded everything and it appeared to accept and keep the preference. All well and good. So I turned off the debugger, to minimize traffic on the network, then I went back to Basic and re-entered everything again, then exited back to the true driver. Suddenly nothing worked again.

I played with this for about 30 minutes, and never got it to work again. Then I turned debug back on, Reloaded the preferences using Basic, then changed the driver back to the native one - - everything worked.

Going to try this on another of my ZEN 20s tomorrow to see if I can replicate what happened.

The debug just logs things, doesn’t hurt much.
If you edit the setting on the zwave tool once you do that you cannot press save preferences on the normal driver. If you save or configure on the normal driver it will set it back again.

@support_team seems like this driver for the zen20 is very broken somehow?

1 Like

I have a power strip that stopped reporting energy a month or so ago. It's out in my shop and keep meaning to look at it, but I just keep forgetting. I may have the same issue. I will be watching to see how this goes.

1 Like

Also, changes made using Basic do not show up in the native driver once you change back to it. I would think that they would show up there if it was working properly.

No, it would not. The menu in the regular driver is driven off a variable in the driver code, not the actual value on the device. For the record I do not know what is contained in the system driver code exactly, but I do code drivers so I know how it works. I would be possible to scan the device for the settings and update the menu but this is a rare feature.

1 Like

Finally looked at my power strip this morning. Had not even thought to look at the driver page. It had no setting for energy reporting, I guess one of the firmware updates changed it. I had not touched the thing in quite some time and it had been working for several months before it quit. The graph below is the energy reporting for the last year. The last time it reported energy was sometime in Dec.

I changed it to 1 minute and it then reported energy. I have since set it to 5 minutes and I will see if it updates. Its all small level power devices so it maintains about 10 watts constant.

Right after posting above, I went back and looked and I realized it now had stopped reporting Power. I updated the power repotting interval and it started up again. Not sure it is reporting energy though now.

@terminal3 so yours is letting you change the settings?
Can you post a screenshot of your State Variables (should have some "configVal#" variables in it.

Also would like to see the Data section at the bottom. And lastly what Type/Driver do you have it set to?

I was basing that assumption on the way other drivers are operating. I make a change, the changes displayed. Maybe the issue is that the native driver is not getting the setting from the device but relying on its own information which isn't reading the device before displaying.

I can change the setting but I am not sure it is sticking. As soon as you leave the page and come back all the drop downs show click to select. I am using stock HE driver.


99% of drivers if you manually make a change using the Basic Zwave tool, that change will not be reflected in when you switch back to the system driver.

If you make a change in the driver itself, in its own menu then yes, it should be reflected in that menu. By your screenshots above though, for some reason the driver is forcibly setting those values BACK to 0. So something strange is happening with that driver. Possibly something else has changed in the firmware that caused that driver to stop working right and they have not even realized it yet?

I was getting the same thing, but I knew it wasn't sticking because it was never reporting anything.