More power!

Have 5 Zooz ZEN15s and the one connected to the gas dryer must have an issue

That equates to around 9000 amps. :flushed:

It's been a known issue with the Zen15's for years. At one time, there was a community driver floating around that filtered the periodic erroneous reports. I'll see if I can find it.

1 Like

I’m done playing with these and have some Tuya Zigbee peanut plugs coming from AliExpress.

These have been reporting correctly for years using the ‘Zooz Power Switch’ driver. What would cause this erroneous reporting all of a sudden?

If they are paired without security it could be a corrupted zwave message. S2 security guarantees better error checking.

My driver will also filter out obviously bogus readings that exceed the capacity of the device: [DRIVER] Zooz Smart Plugs Advanced (ZEN04 / ZEN05 / ZEN14 / ZEN15)


I don't know. Back in 2017, when I got my first one, owners noticed these reports would pop up every now and then. They were followed, within milliseconds, with a realistic power event. @krlaframboise wrote a handler for Smartthings, that was ported to HE, that blocked the bad reports from creating an event.

I don't use that driver any longer and instead of triggering my washing machine rules off of power >xxx watts, I just check the power every 3 minutes.

HA! I was just about to tag @jtp10181 and ask if his driver addresses this. :+1:

Yes, I have hard coded limits. The ZEN04 is susceptible to this problem also. With some testing it was found the ZEN04 is much more reliable using S2 security as well. Leads me to believe some of the bogus reports are from corrupted messages that happen to pass the basic CRC check that is done when not using S2.

I even added low limits of 0, because people were seeing negative reports as well.
The driver logs the error and bogus result in an event and logs, so it can be used in alerts if you want to track it.

@Field static List metersList = [
	[name:"energy", scale:0, unit:"kWh", limitLo:0, limitHi:null],
	[name:"power", scale:2, unit:"W", limitLo:0, limitHi:2400],
	[name:"voltage", scale:4, unit:"V", limitLo:0, limitHi:140],
	[name:"amperage", scale:5, unit:"A", limitLo:0, limitHi:18]
1 Like

A while back I bought a Zooz Z-Stick so I could change the security to none as recommended by someone here. It was s2 until about a year ago. I have a rule that checks the dryer and washer power levels and turns on a ‘Himalayan Salt Lamp’ on the fireplace mantle to signal the clothes are ready. I will change the driver.

It was probably actually S0, I think the ZEN15 is old enough to where some of them only support S0 and not S2, not sure if the new ones can even do S2 or not.

S2 used to cause issues as well but it was due to chip firmware from Si Labs. Seems it has been mostly worked out now and S2 works a lot better on the C7 and C8.

The zigbee plugs don't throw erroneous readings once in a while?
I thought I read a complaint from someone a while ago.

Could have been S0. I’m old and my RAM and ROM are full.

ZEN04 most likely has a firmware problem. About a year+ ago I tried to use ZEN04 as a Power
Meter for the freezer. Every few hours my freezer was off and ZEN04 reported huge over current
surge and automatically turned off. BTW, freezer motor is a very quiet direct drive DC Motor.
After I replaced ZEN04 with Sengled power reporting became very correct and I did not have
any problem over the year. The result is - i hate ZEN04, don't use them anymore and never will be.

ZEN15 has a parameter where you can disable the tripping of the plug due to high amps.
I have no idea why they didn't do it for the ZEN04.


I switched all the ZEN15 devices to the ‘Zooz ZEN Plugs Advanced’ driver and every device is reporting correctly.

1 Like

I try my best.
I don't even have a ZEN15 to test on it, just adjusted the driver per specs and had a few people test it out.

1 Like