Zooz Zen04 Smart Plug Driver and Newone N4003

I setup a Newone N4003 smart plug and it configured with the Zooz Zen04 Smart Plug Driver. I'm having a couple of issues.

Looking at the setup:

How do you reset the values? There are no resets for accumulated Energy, etc. If I look at the Zooz Power Switch, for example, you get the resets and it has a range up to 1000 Watts compared to only 50 Watts for the Zen04.

Any chance of getting those items included in the Zooz Zen04 Smart Plug driver?

I'm also getting excessive reports because the reporting delta is too small at a maximum of 50 Watts but extending the value from 50 Watts to say 100 Watts would take care of that:

dev:782022-12-22 11:01:55.093 AMinfoMedia Center power is: 393W
dev:782022-12-22 11:01:51.930 AMinfoMedia Center power is: 340W
dev:782022-12-22 11:01:51.755 AMinfoMedia Center power is: 289W
dev:782022-12-22 11:01:46.483 AMinfoMedia Center power is: 231W
dev:782022-12-22 11:01:39.730 AMinfoMedia Center power is: 287W
dev:782022-12-22 11:01:32.045 AMinfoMedia Center power is: 228W
dev:782022-12-22 11:01:24.786 AMinfoMedia Center power is: 279W

Any chance for an update? I'm switching the device driver to the Zooz Power Switch when I need to reset at this point but I can't seem to extend or turn off the Watts reporting delta that way.

You can try my custom driver for the ZEN04 but I am not sure how it will work on a different device?
I recently added the option to reset the stats.

Otherwise try the Generic Z-Wave Plus Outlet driver.

Thanks for the suggestions. I tried the Generic driver but that didn't have any of the values or the reset option so was not a step in the right direction. I also tried your driver and it did work okay. I could reset the values and I used the capability to poke parameter values directly which was great. It got me to look at the data sheet at any rate :slight_smile: . So, the range for watts reporting only goes to 50W according to the data sheet. I also tried setting the reporting time parameter. That seems to be the maximum time without a report though because the reports continued with 50W changes. The only downside to your driver was that I lost the high/low values:
Your driver reported:

Current States
amperage : 1.64
energy : 0.043
power : 187.3
switch : on
syncStatus : Synced
voltage : 124.99

Zooz Power Switch driver reported:

Current States
amperage : 3
energy : 0.109
power : 329.5
switch : on
syncStatus : Synced
voltage : 124.79
powerL : 153.4
powerH : 426.2
energyDuration : 18.72 Minutes
currentL : 0.09
currentH : 3.68
current : 2.24
voltageL : 124.79
voltageH : 124.79

The Zooz Power Switch driver gives you all the options and values:

My driver has High/Low tracking, you have to turn it on in the Preferences.

Am I missing something? I don't see that option in the preferences?

I forgot I have a check in there to only show that for the ZEN04.
You could enable it by commenting out the if block (before and after)

     if (state.deviceModel == 'ZEN04') {
            input "accThreshold", "number",
                title: fmtTitle("Accessory State Threshold (Watts)"),
                description: fmtDesc("• Sets accessory status when power is above threshold.<br>• 0 = Disabled"),
                defaultValue: 0, range: 0..2000, required: false
            input "highLowEnable", "bool",
                title: fmtTitle("Enable High/Low Attributes"),
                description: fmtDesc("• Track high and low values in separate attributes"),
                defaultValue: false

Add Comments to top and bottom

//     if (state.deviceModel == 'ZEN04') {
            input "accThreshold", "number",
                title: fmtTitle("Accessory State Threshold (Watts)"),
                description: fmtDesc("• Sets accessory status when power is above threshold.<br>• 0 = Disabled"),
                defaultValue: 0, range: 0..2000, required: false
            input "highLowEnable", "bool",
                title: fmtTitle("Enable High/Low Attributes"),
                description: fmtDesc("• Track high and low values in separate attributes"),
                defaultValue: false
//        }

This came up on another thread so I posted the fix on a Gist for now. I plan on doing something in the driver so it can work for unknown devices with the power reporting more easily.

Thanks for the heads up and for your extra efforts. I'll try out your new driver in the next day or so. Unfortunately, I don't think I can resolve the excessive reports through the driver. I plan to reach out to the devices manufacturer and ask for an update so the power delta can be disabled or at least a 100 Watt delta. Never hurts to ask.

Do you have a link for a manual for this thing? Part of the problem might be you are not setting what you think you are by using the ZEN15 driver. I can give you suggested settings to manually set using my driver. Also, if it is a 700 series device I have a universal scanner driver that might be able to scan and present all the settings for you. [RELEASE] Z-Wave Universal Device Scanner

LOL, I was already uploading it in the other thread.

I have your driver set up and everything looks okay.

Wattage is constantly shifting by more than 50 Watts so the excessive reporting continues. Nothing that can be done about that for now.

What is Accessory State Threshold?

What do you have plugged in that is changing in power draw so frequently, that is not normal.

As I was just looking at the parameters for the ZEN04 I realized, that I think this N4003 is just a clone of it. The ZEN04 has the same limit of 5-50 watts and same parameter number 5 for the power reporting. The original ZEN04 was spamming 0 volts a lot but they fixed it with the 1.20 firmware, is your sending 0 volts reports?

This post explains the accessory attribute and setting: [DRIVER] Zooz Smart Plugs Advanced (ZEN04 / ZEN05 / ZEN14) - #56 by jtp10181

It's got a power strip with AV equipment connected. The main draw is a Denon AVR.

I never had a problem like it before but it wasn't excessive reporting when it was in a different location that I'm aware of.

No zero volts reporting just a lot of Watts reports pretty much just over 50 Watts:

It's not flagged for excessive reports at this moment.

Yeah its not too bad but getting close. Keep an eye on it, going off that often it could cause some delays on your other devices if it has to keep re-routing.

Looking at the setting for the ZEN15 that one you can set the reporting threshold as high as you want or totally disable it, in which case it will only report at the interval set. That might be what you need for this setup.

I wonder if the ZEN04 (and your device) would take a value of 0 for parameter 5 to shut that off despite what the docs say? I will test it on mine shortly and report back.

I haven't noticed any delays as of yet. I'll try using a different brand monitoring plug that was freed up from the Xmas stuff later on and see if the problem follows.

I had tried setting that to a higher value using the ZEN15 but I don't think I tried a zero value.
Edit: Looks like it ignored the value. Reporting continues apace at 50 Watts. Ooops, looks like it went to default 5 Watt reporting rather.

But the ZEN15 driver was trying to set a totally different parameter number, so none of that would have saved to anything anyway.

Anyway, my ZEN04 wont take anything outside of the advertised range of 5-50 so I am guessing yours will be the same.

I used your parameter setting feature but it reset to the default and didn't accept the zero value.

Yes, the same.

I seem to be having an issue with accessing the energyDuration in a tile:

The 6.07 value looks like where the old driver left off before I setup yours.

Yes, I do not have it as an attribute so it cannot be used in a tile. If thats something that is useful I can change it to an attribute in an update.

How do you use the information then? Or is it only available to view in the Device page? If it's not currently usable for tiles or calculations then I'd prefer an attribute personally.