Zooz Zwave devices just quit working

What "other" hubs do you have and how many total zwave devices do you have?
If you have more devices that are closer to the hub, or part way between the hub and further devices, adding those to this hub will increase the mesh strength and give better performance.

As @rlithgow1 said, if the device supports S0 (and not S2) per Si Labs specs Hubitat must pair it as S0 so thats what is probably happening. Its very tricky to pair it another way and requires a secondary controller with developer level software. If you can get it routing better with better neighbors, or less chatty it would help. What is the make/model and firmware version of this C2 outlet that wants to use S0?

There is another way that does not require the use of PC Controller.

Use an Aeotec Minimote to pair a device to a C-7 or C-8. It will pair with no security, which is the desired outcome in this situation. I havenโ€™t tried any other hand-held secondary controllers, but this one certainly works.

1 Like

I don't find it a hassle. When I install a device I track things two ways:

  • I keep a spreadsheet of all devices, where they are, their 5 digit S2 DSK, what battery type they use, links to their instructions and how to include/exclude/re-pair. It's very helpful.
  • For hardwired devices I take a photo of them with the switch plate off. This way I have a picture of all the QR codes/DSKs should I need them in the future.

This helps with upkeep quite a bit and makes things easier to maintain in the future. I'm a fan of S2 and use it on every device that supports it on both ST and HE.


I think it might help with integrity of data reporting.

" What is the make/model and firmware version of this C2 outlet that wants to use S0?"

If I understand your question...
It is a ZooZ Zen15 and looks like firmware is

  • firmwareVersion: 1.6
    I didn't pick the manufacturer or driver, etc., just allowed HE to pick it up.

Post the details screen from the device page... (will be lower left where you see the firmware)

What driver is it using?

I assume the driver is 'type' classification, and that is 'Zooz power switch'.

No, it's above

Yes, the "Type" as he said...

yes. that is the type classification I report- it is zooz power switch.

FYI on use case. I do have the reporting limited on just power . The purpose of the two power plugs are to monitor dual dehumidifiers that I suspect occasionally get stuck in regen mode or not running as expected all the time. So the main goal is to be able to turn dehumes off and to monitor their power signature against humidity levels.

So I checked the manual and it looks like the ZEN15 has two different inclusion methods.
You should be able to get it to None security by excluding it and then including it again by clicking the button 3 times quickly. HOLDING the button puts it into secure inclusion mode!

You may want to use "Swap apps" to move your rules/apps to a temporary virtual device while you exclude and include again.


If you want full access to ALL the settings, you can use this driver instead of the built in one: [DRIVER] Zooz Smart Plugs Advanced (ZEN04 / ZEN05 / ZEN14 / ZEN15)


correct, I tried both. granted i only did the long hold after the power cycle.

Don't know what else to tell you on that subject, it would include with No security if done correctly. Maybe try doing the factory reset sequence AFTER excluding. There are hundreds of people who use the ZEN15 on this forum alone so it would have come up before if it was an issue.

1 Like

I will keep messing with it and working on ghosts, more devices, etc. I will say that getting that one Z0 device out of that routing pattern did relieve some of the delays or inoperability the other devices had. It was just strange how much delay between joining those ZooZ powerplugs and the increased issues. Thank you to everyone for that useful bit of troubleshooting.

IF you have any power reporting going, turn it off and see how things behave

1 Like

Things seem to be flowing better now after several re-pairings. I even got it to finally drop S0 security last night by doing another power cycle. It doesn't have the routing it originally had when I lost control of dimmers (now route is straight to hub it appears) which may be partly why. Even before, the power logs were modest with the original pairing since I had only logged what I wanted. Also, it seems that power type reporting stops when devices are switched off (but still plugged in) which I noticed in logs when troubleshooting. It may be that there is communication going on behind the scenes I can't see, but at least the logging stops.

Turn on debug logging and you should see all the messages even if they are ignored as duplicates by the driver. For sure if you use my driver, not 100% sure what the system driver does but usually they log everything with debug.

thank you. Yes, that just seems to add a per 15 sec metering report to existing logs (whether plug is on or off).

Unless you really need the reporting every 15 seconds I would set that higher. For Power reporting use the wattage threshold so it is reporting when the value changes instead of on a regular interval.

Energy, Voltage and Current all default to 300 seconds which I would set higher even, unless you really need it for something.

Here is all the settings available: ZEN15 Power Switch VER. 1.06 Advanced Settings - Zooz Support Center

If you use the driver I have posted above every single setting is exposed right on the device page.


As I meant to mention earlier, I am using the power info on purpose: to track the power signature graphs for two dehumidifiers that I think at least one is having some regen issues and comparing performance to humidity sensors. But yes, I saw the device options and just set what I needed. Thanks for additional ideas on this (may revert to watt threshold inclusion soon).

1 Like