[DRIVER] Zooz ZEN Switches Advanced (and Dimmers)

I've got one for my garage. The paddle does the light. The relay has no load connected to it, and just acts as a button to open my garage door.


I feel so stupid, that is a brilliant use of that switch. Not too long ago I was thinking of a way to do something like this, and it never occurred to me to use one of these instead of the normal Zooz dimmers that I used on my lights. The light switch is in a perfect spot for the garage door button. I could have spent a couple dollars more and got something infinitely more useful.

chris farley snl GIF


it really is - I hadn't considered this either... I'm just using one in the standard dimmer and fan setting... but given that the relay portion on the ZEN30 can be a dry contact you could use it like a traditional garage door button (which I gather is how @waterboysh is using) or as a controller for a zwave garage door relay :thinking: :grinning:

The garage door opener is connected to a zooz zen16. The relay on the zen30 just uses a button controller rule.


By chance, is there any update on this device the zooz25?

I think it would make a great starting point for a custom driver for the Qolsys Smart socket which is a dual-outlet energy meter socket.

I have my plugs driver but I have not converted it to work on the ZEN25 yet. [DRIVER] Zooz Smart Plugs Advanced (ZEN04 / ZEN05 / ZEN14 / ZEN15)

It does support one device with two plugs but they are not energy reporting so some changes will need to be made to create child devices with energy stats.

I also have this unpublished driver that I put into a bundle and shared on here somewhere else a while ago: Dropbox - ZoozZEN25DoublePlug.zip - Simplify your life

Hello one of my Zen30 switches syncstatus was stuck on 21 pending changes so I used this command to complete the sync. The switch works now but the thing is that it doesn't show all of the available preferences as compared to another one of my Zen30 switches that also uses your driver. Also, I cannot see the firmware on the Zen30 that is missing preferences:

Would a firmware update bring in all of the preferences that I'm missing? If so, do I need to switch back to the native driver before updating firmware?

I removed that Hide Invalid thing a while ago, was not working how I wanted it to. You should run the option to reset it and then update to the current driver.

Once that is done, run a configure and it should pick up the firmware version.
With the current driver and correct firmware version detected it should be able to confirm all the parameters and show it is Synced.

[1.6.0] - 2022-07-24

  • Parameter test/hide code totally removed

I reset it and all the preferences came back along with 21 Pending Changes for the syncStatus. When I checked HPM it shows everything is up to date:


When I go back to hit configure it still doesn't show firmware version. I also tried doing a hub reboot but no luck. Anything else I should try to see the firmware version? Here is the Data section where the firmware version should show up.

If you have the option for "Hide Invalid Parameters" you are not updated. I moved the package json file a while back and if you did not un-match and re-match then HPM probably is throwing errors in the logs every time you try and update. I cannot help you until the driver is updated.

If you want to double check the driver version go to the driver code and edit it, and look at the most recent changelog entry in your driver code.

Also, are you sure that is a ZEN30? The deviceType and deviceID are not matching what I have on record for a ZEN30 (or any other Zooz device I have made drivers for). Is it possibly some new Z-wave 800 LR version of the ZEN30?

In fact I cannot find any record of that deviceId anywhere online...

You're right. It is an old version [1.4.4] - 2021-06-08. I updated the code based on the latest from your github.

As far as the switch. I opened up the decora plate and this is what I see:

Another check I did was I excluded this device to ensure the device that I updated with your driver is the same one. The device that was excluded was in fact the same device:

The only question I have is whether this is a Zen30 V1, V2, or V3 because the firmware files are different.

The next little complication I have is that for some reason I'm not able to add this switch back to my hub via inclusion. It was so simple the first time I did it but now after multiple exclusion and re-inclusion attempts the hub doesn't want to pick it up. it goes as far as to say something like it is adding the device but it never actually does. Lol it's not supposed to be this hard.

In any case, I greatly appreciate your help with all of this.

Edit: I brought my hub into the room with the switch and was able to get it added. This what I see in the data section:

I also checked and it looks like your driver was applied when I onboarded the device so everything is :100:. Thank you. :pray:

Yours is v1 hardware now that I see firmware is 1.05

Glad you got in working. Something was really screwed up with that other device entry so I think you did the best thing by including it again.

I would recommend in HPM that you go into the settings and use the unmatch feature on my zen switch package. Then run the matchup to match it back up to my pack. Then update so it updates everything in that package you have installed already. This should fix the update problem going forward.

@jacobgraf Do you have GE/Jasco z-wave switches?

Yes I have some ge/jasco switches but they are zigbee.

I'm sorry. I meant to reply to a @jacobgraf post from back in March.

@jtp10181 you don't happen to have a Zen32 driver do you?? Trying to automate the LED colors for the buttons but having a difficult time without the LEDs being treated as their own entries.

Since there was already a good community driver I actually assisted with adding that functionality to this one: [RELEASE] Zooz ZEN32 Scene Controller (community driver) . You can set the LED colors and flashing from a custom commend.

I also made a few custom tweaks to that driver on a forked repo: https://github.com/jtp10181/Hubitat-RMoRobert/blob/master/drivers/zooz/zooz-zen32-scene-ctlr.groovy

Thanks, I have that installed, I think my set-up is the hedache or at least I cant seem to figure out how to send the command from Home Assistant to Hubitat. I'm going to give it a try using Node-Red instead and connect directly to Hubitat and see if I can figure out sending the command from there.

I know it works from Rule Machine, if you want to make a new thread about or post on that driver you can tag me I will look. I have never tried sending a custom command from HA or NR though.

I think I actually found the solution, there is a hubitat.send_command service in HA that I never realized, I tried sending commands and I'm seeing good log data in hubitat, just need to physically check when I'm home if the LEDs are changing.

1 Like