Slow Z-wave, repair failing

I've been experiencing a decline in the performance of some of my wave devices recently. I attempted to remedy the situation by conducting a repair since I've moved several devices lately. However, the repair was unsuccessful for more than 90% of nodes. I'm sharing the logs, zwave specifics, and a screenshot of the report below. I would greatly appreciate any help or suggestions from the community on how to address this issue.

Excerpt of some logs but can share all if needed

sys:12023-07-11 05:21:15.939 PMinfoFinished Z-Wave Network Repair
sys:12023-07-11 05:21:10.934 PMwarnZ-Wave Node 1F: Repair failed node unreachable
sys:12023-07-11 05:20:58.730 PMtraceZ-Wave Node 1F: Repair is pinging the node
sys:12023-07-11 05:20:58.726 PMtraceZ-Wave Node 1F: Repair starting
sys:12023-07-11 05:20:56.727 PMwarnZ-Wave Node 3D: Repair failed node unreachable
sys:12023-07-11 05:20:44.514 PMtraceZ-Wave Node 3D: Repair is pinging the node
sys:12023-07-11 05:20:44.510 PMtraceZ-Wave Node 3D: Repair starting
sys:12023-07-11 05:20:43.509 PMwarnZ-Wave Node 3A: Repair failed node unreachable
sys:12023-07-11 05:20:31.304 PMtraceZ-Wave Node 3A: Repair is pinging the node
sys:12023-07-11 05:20:31.300 PMtraceZ-Wave Node 3A: Repair starting
sys:12023-07-11 05:20:29.743 PMtraceZ-Wave Node 36: Repair is done.
sys:12023-07-11 05:19:48.074 PMtraceZ-Wave Node 36: Repair is running
sys:12023-07-11 05:19:36.834 PMtraceZ-Wave Node 36: Repair is pinging the node
sys:12023-07-11 05:19:36.830 PMtraceZ-Wave Node 36: Repair starting
sys:12023-07-11 05:19:35.831 PMwarnZ-Wave Node 30: Repair failed node unreachable
sys:12023-07-11 05:19:23.618 PMtraceZ-Wave Node 30: Repair is pinging the node
sys:12023-07-11 05:19:23.614 PMtraceZ-Wave Node 30: Repair starting
sys:12023-07-11 05:19:22.615 PMwarnZ-Wave Node 1D: Repair failed node unreachable
sys:12023-07-11 05:19:10.402 PMtraceZ-Wave Node 1D: Repair is pinging the node
sys:12023-07-11 05:19:10.398 PMtraceZ-Wave Node 1D: Repair starting
sys:12023-07-11 05:19:09.399 PMwarnZ-Wave Node 1A: Repair failed node unreachable

You got 4 ghosts in there that need to be removed. 0x26, 0x1F, 0x11, 0x12.


0x03 & 0x34 too, right? (Asking because if you don't think it's a ghost, I'd be interested why)

ah, I see now, you told him about the ones that say 'Discover,' not just the ones without routes. I think the above 2 that I mentioned are possible ghosts, but the 4 @aaiyar mentioned are definite ghosts.

They are devices that have not "communicated" with the hub since the last power cycle. Unlikely to be ghosts.


makes sense. I just don't typically see that personally on my non-battery devices, but what you're saying totally makes sense.

1 Like

I was able to remove 3 using device specific repair and then remove, but 0x26 has no repair option (see screenshot). For this last pending one, is there simpler method than using something like this: Removing ghost devices ?

You dont use repair to get the remove button, you use refresh. Click it once and wait for page to reload.

Looks like 0x10 is also a ghost node (not attached a device entry at all).

Looks like your screenshot was done right after a reboot, would like to see another one with at least 12 hours of uptime. Also, do you have any power reporting devices? They will cause issues if the reporting is configured poorly causing lots of traffic.


Thanks for the tip. I tried to refresh 0x26 a few times but it doesn't come back with 'remove' option.

Attached are the latest Zwave stats.

I don't have any explicit device or power meter but I think some of Zooz devices that I have in the mesh has that built in.

Nothing jumps out as being horrible. A lot of those shade controllers have a lot of route changes which is a little concerning (could be leading to your issues, or an effect of other issues).

So I see 0x33 recirculating pump, sounds like maybe that is a plug, ZEN15 possibly?
And then also 0x40 Is the ZEN25.

For the ZEN25 it is known to cause issues when the reporting is left at defaults. If you are not using the info I would set all the reporting intervals / thresholds very high to get minimal reports. There is also a newer parameter you can set to totally shut off the reporting but it is not visible with the system driver. Parameter 18:

If the other is a ZEN15 you can use this driver to see all the settings, save advise as above for the ZEN25 applies: [DRIVER] Zooz Smart Plugs Advanced (ZEN04 / ZEN05 / ZEN14 / ZEN15)


I have cleaned up everything but for one straggler. Any suggestion for this last one? TIA

I would not worry too much about it. You will probably need to use a USB stick with PC Controller to get rid of it.

@yashvind, so did you see my last post above? Have you made any adjustments to those devices?
Any noticed improvements?


@yashvind Can you help me update my Bali Autoview firmware? I tried to message zebra blinds but the support email bounced back and it looks like the website doesn't exist anymore. Also I'm a new member here so I couldn't message you directly.

Zebra blinds is outta business.

That sucks, they were good people.

If they are closed for business, I wonder if their NDA is also no longer valid?

Probably not. Honestly I looked at those at one point and thought they were too expensive. I ended up going to and getting my blinds then using an AM43 to control them. For my lattice blinds I use an iblinds v3 on each one.