Device slowing down C7 hub?

How long it's been since the energy value was reset.

I might have missed it, but did you set the power reporting values to something to other than none, save, then set back to none?

1 Like

I honestly have no idea lol. No use for it either. I just have a rule set, to notify me if the device draws power for more than two minutes, indicating that it failed on and is about to burn itself out.

I just reset all the voltage/energy values this morning, with no change unfortunately.

I'll try this and report back. So change to a different value on each section, save preferences, and then change them back to none, and then save preferences?

If you use my driver the mystery of all the settings will be gone. [DRIVER] Zooz Smart Plugs Advanced (ZEN04 / ZEN05 / ZEN14 / ZEN15)

If you use that, and set your settings as desired, and save, it will set them all and confirm they took correctly.


Gotcha, if I do that will the rules I've made disappear, or the rest of the zwave devices start going nuts?

Gotcha. I think I changed to firmware correctly to yours. It's been a while since I've done anything like that on Hubitat lol.

I'll let the hub sit for a few hours and maybe power it down and back on again to see if that fixes it. It doesn't seem to be reporting energy duration incessantly anymore, but shows 16 pending changes.

It does look like it's still reporting a ton of info and maybe still slowing Hubitat down according to the logs.

That means the driver has not been able to confirm any of the settings, the device is not reporting back. Seems like the device is going haywire.

Try pressing the configure command button, see if that gets any of the settings to take.

Other than that my only other suggestion would be to factory reset the device and then pair it again. You could try using the zwave replace feature to get it back into the same node. That would save all your automations linked to it. DO NOT EXCLUDE it from your hub. [Guide] Updating Firmware and ZWave Replace

I tried configure again, and it showed pending 16 changes still. I tried to "replace" the device after factory resetting it, but I couldn't get it to work and it eventually showed "device not responding" in zwave details.

I force removed it, zwave excluded it, and now re-paired it. It isn't flooding Hubitat with the energy duration now which is great, and all the other devices seem to be responding normally again for the time being. I plugged the device back into the "missing trigger" areas of the rule I set, but wanted to test the device prior to plugging it back into the basement.

I tried plugging a hair dryer in, to see the power draw on the device page of Hubitat, but no values seem to change. I've left all the parameters to stock for now since I didn't want to mess with anything yet.

Long story short, I just need a simple rule that notifies me through Hubitat, and chimes our dome siren in the even power is being drawn for more than one minute.

Again, thanks for all the help, I'm super glad Hubitat is back to functional again for the time being!

1 Like

Double check when you removed it the way you did that you didn't create any ghosts. Please post your z-wave details page in it's entirety so we can make sure your mesh is healthy :slight_smile:

1 Like

Do you still have all the reporting set to none?

Yes as @rlithgow1 stated, unfortunately my instructions may have lead to creating a ghost node since you were not able to get the replace to work. Since it was factory reset the exclusion would not have removed it from the zwave table. It would be in the zwave details and probably have a "Discover" button on it, since you deleted the device entry.

May have been safer to just use swap apps to a placeholder then exclude, sorry. Was trying to save your automations from getting broken, was not sure how much you had tied to that device.

The only goofy looking device I think maybe have been there for a while, but is "SPECIFIC_TYPE_SECURE_BARRIER_ADDON".

No worries at all, everything is still functioning like it used to prior to that plug going nuts. All automations are working this morning, where as prior everything would have been locked up and unresponsive by now. I really appreciate everyone's help

Can you post the whole page? Use windows snip. Hard to see that one and we need to see all the columns

I can see it fine. Node 0x15 (021) looks like an old ghosted node.

You will want to do a refresh on it, click ONCE, wait. Then find it again after page reloads, hopefully it has REMOVE button. Click remove ONCE, wait again (may want to have logs open). If you are lucky it will remove it. May need to try a few times and/or shut down the hub fully, pull power for 10 seconds and restart it (then try again).

Node 0x1C (028) - not sure what this is (siren maybe?) but it does not have a route. May be fine and just has not sent even messages since the last zwave crash / reboot to get a route posted yet.

Looks like you did get rid of the old node from the ZEN15, so that's good.