Zen15 preferences not saving?

Just paired a new Zen15 plug which I bought specifically for power monitoring and reporting a change in power usage when the device is running without reporting on a fixed timeline. Using the built in "Zoos Power Switch" driver. Shows all the relevant preferences I'd expect:

However, when i switch the relevant percentage change setting to 25% and hit save, it shows the setting as expected, then i run the "configure" option for the device and it still looks okay. But if i leave and come back or even just refresh the page without leaving, all the preferences revert back to "No Selection" and the log doesn't report power or indicate that the settings have been changed. Am i meant to be using a different driver? What's up with this?

Mine is acting the same.
Still works, just not as expected.

Weirdly it wasn't reporting when i set percentage change and configuring would reset everything to not reporting. I turned off percentage change and tried absolute power change instead (my power goes from ±2 to ±15 when being used so either would be plenty reliable. With absolute power it works fine!

My prefs dont save too. Here is the debug output. You can see the settings are changed when I click Save but when I click Configure the device doesn't follow.

I have one doing the same thing. A few months ago I started getting excessive usage alerts for the device. It had been working fine up till then. It's connected to my washing Machine, so whenever we use the washing machine I start getting the alerts.

The device reports every change in power no matter how minor, with no delay. I have changed settings, although it shouldn't be doing this with what it currently shows, the changes I make, however, never show on the device. I have been meaning to try a reset and perhaps try a firmware update, but I haven't really looked to see if there is one. There is just two of us in the house now, so we don't have to wash clothes that often. So it hasn't caused an issue other than the alert popping up whenever it starts running. Anyone know if there is a firmware update?

I updated mine to 1.06, but I think the actual issue is caused by the Configure button. If you set the preferences and save, it works. If you hit Configure, it stops working. Configure seems to reset the preferences to defaults. Weird but true.

This appears to still be a problem. I added 6 of the ZEN 15 devices to the C-8 Pro as new on and discovered this problem. @bcopeland or @mike.maxwell , any chance you can look at the code for the "Zooz Power Switch" Built-In Driver that is loaded when the Zooz Zen 15 is discovered? I resolved it for now by using the 3rd Party "Zooz ZEN Plugs Advanced" driver by JTP10181 located here:

Just for now? I mean... you could just use my driver forever :wink: :laughing: , I wont mind.


@bcopeland There is definitely something going on with the built-in driver, at least with certain firmware versions of the Zen15. When I updated from 1.04 to 1.06 over the weekend, one of the outlets kept turning itself on with no apparent reason. There is only a dashboard associated with this plug, no automations otherwise. Oddly enough, it wasn't even showing events when it turned itself on.

This is what fixed things for me. It appears to properly call configure, and allow you to set the parameters correctly. :+1: for Jeff...

1 Like

Yup - this is still an issue with the configure button and the built in driver.