[GUIDE] How to update Leviton z-wave firmware

Leviton has firmware updates available for some of their ZW devices, but (as of Fall '23) the file formats are unfortunately not compatible with HE's built-in updater. But it is possible...

Leviton has a couple help pages on the topic - one here, and a more helpful one here... The latter page is directed at HA, but it includes the update files we HEers need too -- .ota files, specifically.

If you are in Leviton's Beta program (e.g. for the ZW15R), these same overall steps work for those GBL files.

1.) Both pages should identify what Leviton devices currently have updates available. If yours is one, then download the corresponding .ota file at the bottom of the HA help page.

2.) Next, install this updated fork of the original z-wave updater tool: [BETA] Updated binary firmware updater - :gear: Custom Apps and Drivers / Custom Drivers - Hubitat. Note: install this as a Driver (not an App)

3.) Next, add the Leviton .ota file to HE's own "File Manager" tool (found in the HE Settings area).

4.) Once loaded in File Manager, right-click over its name and use "copy link" to copy its local URL path. Paste that in Notepad or something similar -- it'll look like this:

http://your.HE.ip.here/local/DZPA1_v1_23.ota

Now manually add ":8080" at the end of your IP, so it looks like this:

http://your.HE.ip.here:8080/local/DZPA1_v1_23.ota

5.) Go to your Leviton device's Devices page in HE -- change the driver Type to "Z-Wave Firmware Updater" (that's the custom/user driver we installed in Step 2). Then hit "Save".

6.) In the new options at the top of the Device page, there'll be a "Clear Lock" option -- I recommend clicking that. I don't believe that can hurt anything, and it may in fact help a lot.

7.) In the "Update Firmware" option's entry line for binaryFirmwareUrl, copy/paste the 8080 version of the URL you made in step 4.

Click the "Update Firmware" button - the progress should be reflected in the Current States section over to the right. Progress may not be super fast, but it should be steady.

8.) When done, it'll just say "Complete device is flashing..." -- that actually means the update is finished.

9.) You can then swap the device's driver back to its regular driver. If you want to clear out the leftover update-related states on the right side, you can use the Device driver to do that. If you want to double-check the f/w updated for sure, you can use the Basic Z-Wave Tool driver to do that at any time too.

Good luck!

15 Likes

This was really helpful. I could not get the firmware to update with either the built in firmware updater or PC Controller. This method worked perfectly.

1 Like

I'll note here that if you normally connect via https then you need to make sure that you change to use http in your URL as well.

1 Like

Hydro311,

I'll second or third the thanks. The procedure was completely clear and flawless for several of my Leviton DZ6HD devices. Thanks for taking the time to document it.

2 Likes

I’m new to Hubitat. How do I know what version of firmware my installed Leviton devices have?

Welcome! From the "Devices" listing, select the device -- the firmware is usually ID'd near the bottom of the page in the Data section.

But it may be listed near the top of the page in the State Variables section (I'm not sure why some there and other's in the other).

A newly-added device may not populate that info immediately - depending on mains-vs-battery, you can usually use refresh/wake commands to coax it up. Or just wait a day -- it'll show up eventually.

Summary

Thanks, but I’m not seeing that information in either place. It’s a Leviton DZ6HD dimmer, if that helps. It’s a few years old, so I’m sure it could use an update :). Maybe that’s part of the problem…

You can download and install the driver Super basic Z-Wave parameter tool.

You would then change the device driver to this one and click on "Get Version Report". The current firmware version would be listed in the logs.

This driver is meant to allow changing device parameters. See also Basic Z-Wave Tool driver - best practices for more information.

Dont forget to change back to your original driver when you are finished.

1 Like

Okay now that I’ve learned how to install HPM and use the Z-wave updater, I noticed it can query the version. And I successfully updated the firmware and now it shows the version with the regular driver. I guess that was indeed an issue with the old firmware itself.

1 Like

Glad to hear you got it updated! The built-in ZW firmware updater works well for quite a few common brands (Zooz, Aeotec etc) and is easier to use overall, but having familiarity with this older updater can come in handy once in a while (like for Leviton here!)

Hopefully Leviton will continue to add more firmware updates in the future.

Thanks for this post with instructions on how to update the firmware. It was very helpful!

1 Like

@hydro311 ...I just got around to updating the firmware on one of my Leviton DZ15S switches. Actually, I put it off because I was scared to update the firmware. :slightly_smiling_face:

I used your procedure on my new C-8 and it updated the firmware without a problem. It didn't take long and I didn't brick the switch....lt actually worked....Yey!

I may even update the firmware on several other DZ15S switches, but not right now...I am just going to celebrate my success.

Thank you for the write-up of the procedure.

2 Likes

Thanks for posting - glad to hear this still works on the C8, since someone posted earlier this week they were beta testing some Leviton firmware that will hopefully post sometime soon.

It would be great if Leviton could package the f/w so we could just use our built-in updater, but at least we have this workaround.

2 Likes

Thanks for this wonderful step by step instruction set. It worked great for me. First hiccup was using HTTPS instead of HTTP. Second hangup was solved by factory resetting my switch and repeating the installation. Worked for both the Leviton DZ6HD and the DZ15S on my C8 hub.

1 Like

I have several of the DZ6HD dimmers and using the DZ6HD_v1_22.ota file I used this guide to try and update my devices from version 1.20. The download to the device would start and reach 100% but the update would fail for not enough memory. My hub is a C7 with the latest firmware. I was able to update my DZ6HD using the Leviton OTA update software and a Zooz S2 Stick 700.

I have run in to the same insufficient memory issue when trying using my C7 hub. Thanks for letting me know the Zooz stick works.

Hoping for some assistance on a updating a few DZ6HD & DZPD3 devices. Running 1.13 firmware - trying to update to get current as the response can occasionally be laggy. I have tried updating a few different devices - the devices appear to complete the process and I see the line "New image was successfully stored in temporary non-volatile memory. The device will now start storing the new image in primary non-volatile memory dedicated to executable code. Then the device will restart itself." in the device log however when I complete the process and check the FW version it still reflects 1.13.

I do notice in the log " firmwareUpgradable:false" in the line below. Can anyone opine if this the cause of my problems?

FirmwareMDReport: FirmwareMdReport(manufacturerId:29, firmwareId:257, checksum:42276, firmwareUpgradable:false, numberOfTargets:null, maxFragmentSize:null, firmwareIds:[]).

In the log? Or at the bottom of the device page? Some drivers are bad at updating the firmware version on the device page.

The upgradable false seems to be normal, all the Zooz devices report this also but can be upgraded.

1 Like

The firmware version I am citing is from the logs. I get the same result using "get version report" of the Z-Wave Firmware Updater and the Basic Z-wave tool.