[DRIVER] Leviton Dimmers (DZPD3 / DZ6HD)

As a request from @JoeJ I have created a universal Leviton Dimmer driver that works for both the plug style and in-wall. I built this from the foundation of my popular Zooz ZEN Dimmer driver.

If you are using this driver PLEASE like :heart: this post

Supported Models:

How to update Firmware: Guide to updating Leviton z-wave firmware

You get all my typical features:

  • Specifically tuned to this device for max efficiency
  • Events include digital/physical type and avoids duplicate info logging
  • All device parameters settings exposed
  • Brightness Correction: Check HERE for Details from another thread

:lady_beetle: Reporting Issues :beetle:
Please use GitHub to report any issues so each one can have its own conversation and tracking. Please provide as much info as you can including model, firmware and the "configVals" data string. Issues · jtp10181/Hubitat · GitHub

Must PRESS CONFIGURE BUTTON and check all your parameters after changing to this driver.

:eight_spoked_asterisk: Manual Download from GitHub
Direct Import URL: [leviton-zwave-dimmer.groovy]
Full Repository Link: https://github.com/jtp10181/Hubitat/tree/main/Drivers/leviton

:beer: :coffee: Donations: ---->>>> PayPal.Me <<<<----
:money_with_wings: Never required, always appreciated! :money_with_wings:


Just gave it a go on my DZ6HD and all works perfectly. Thanks!


Should this driver only be used for the z-wave plus variants of these devices? Or will it also work with the original z-wave versions of these model numbers?

It will probably work for those also. Not sure if they have the same parameters though? If you have a link to a manual I could check it out. Might have a different fingerprint as will, I would have to add it for all of the settings t show up properly.

Awesome! I don't have manuals but I do have exact product model numbers on the original z-wave models.

  • Plug In: DZPD3-1LW
  • In Wall: VRI10-1LZ

For both of these products, I use the built-in "Leviton DZ6HD Z-Wave Dimmer" device driver. It's the only one that works reliably for them.

For the newer Plug In modules (DZPD3-2BW) I use the built-in "Generic Z-Wave Smart Dimmer". The other drivers don't work properly for them.

Would love to get to a single Leviton-specific driver. Happy to test if you find the manuals and say yours should work.

Joe, new to Leviton and z wave used to use insteaon. What does this driver load on, pc, smart phone?

i have the plug in dimmer and want to set parameters, as i did with the dimmer switches. But the plug in dimmer does not say how to enter parameter mode so wondering if your driver will help.

I am using the native zwave on our alarm system from vintage security. it is called alarm . com (had to space it as your site doesn't allow links

Do you have the device connected to Hubitat or your alarm system? This driver is for the Hubitat hub.

Here is the guide to install custom drivers: How to Install Custom Drivers | Hubitat Documentation

Giving this a go for my dimmer (DZPD3-2BW), will update the wife's if mine works out ok. The built-in Leviton driver doesn't seem to like dimming up and down (at least not very fast, it's almost imperceptible).

Added new driver (brings up blank editor), imported code from RAW view of GitHub file from the repository, Saved the driver.
Went to Devices and pulled up my dimmer, changed device Type to User Driver for Levitan ZWave Plus Dimmer, Saved Device. Then Saved Settings (which brought up all the new settings that come with the driver), reconfigured everything to my liking, then saved settings again.

Everything seems to be updated, so I'll test it out with the daily automation's and my buttons over the next day.

1 Like

Have you updated the DZPD3 firmware (1.22 latest)? If not, steps here.

Not sure how critical that update is, but I don't think it can hurt.

I just recently installed one of these PD3, and I couldn't get the dimming to work smoothly using Jeff's driver here. I admittedly didn't troubleshoot too much -- since Jeff's drivers are usually rockstar options for me, I suspect it was something I screwed up in my haste or perhaps a conflict with the 1.22 f/w.

I ended up trying the stock "Generic Z-wave plus dimmer" driver and that's working well for me (i.e., smooth dimming using "Start/stop raising/lowering" commands in my Pico's Button Controller setup)

1 Like

I just updated the FW and the result is the same, so I'll try another device driver and see if that helps. I will say that this custom driver did allow me to set the Load Type to LED. Not sure what Leviton does with that information in the dimmer itself, but being able to set that is nice.

Can you explain this further?

The PD3 replaced a zigbee version of that same Leviton dimmer plug, so I had Pico already set up to control on/off and dimming (using "hold to start raising/lowering" and "release to stop raising/lowering" commands via Button Controller).

It was admittedly not an exhaustive test, but I updated the (new) PD3 to 1.22 and then tried your driver... When I tried dimming via the Pico, the brightness level would just jump ~5-10% in the intended direction and stop -- it wouldn't scale up or down as I held the button.

I then tried the stock "Generic Z-Wave Plus Dimmer" driver to see if the same would happen, and dimming was smooth there so I just stuck with that.

There are a few ways to do that so can you Post a screenshot of your rule(s). I can test it on my end. That’s not something I usually use or test for. But I actually might if I put this dimmer in place somewhere.

Sure thing -- the PD3 is "Basement Floor" here -- just a few Philips (dumb) LED bulbs in that floor-lamp fixture, so no min-load or bulb-dimming-quality issues.



Fixed the Start Level Change issue. It only happened when the duration was not set and the device default was used (which I found to be 20 seconds). Thanks @hydro311 for pointing it out.

Tested on FW 1.2, then updated to 1.22 and tested again.

[1.0.1] - 2023-04-16

  • Fixed startLevelChange not working when duration left blank

Good to know. I'll circle back around and test this with both drivers, the custom one and the stock one. @jtp10181 Have you thought about adding this to Hubitat Package Manager? HPM Documentation

1 Like

I tried your driver but I still have a max of 10%. I did not have to reset the module to factory first did I?

Not sure how others got it to work. Did you Run the "Configure" command on my driver after switching to it? What firmware are you on?

I did get it to work on me 4 New DZPD3's. I am slowly moving away from Insteaon to ZWave. I am using software from HCA which has a bridge to Hubitat.

I take that back. The modules have a mind of their own. Sometimes it works sometimes the light comes up with the wrong levels. I'll try tonight resetting the Hubtat as described.