[RELEASE] Advanced Zooz Zen22 / Zen21 Central Scene Dimmer and Switch Drivers

Advanced Zooz Zen22 / Zen21 Central Scene Dimmer and Switch Drivers

  • All device configuration variables
  • Central Scene Functions (matching descriptions on zooz website)
  • Normal Dimmer / Switch functions
  • Z-Wave Direct Associations
  • Indicator Capability
  • Pushable Button Capability 8 buttons (matching descriptions from zooz website) These will be different button numbering from the built-in driver.

These drivers are based on new options in the latest firmware versions 3.7 (ZEN22) and 3.4 (ZEN21). It is highly recommended that you be on these versions.

Please let me know of any issues or missing functionality .. Or feature requests.

As usual make sure to hit configure after changing to this driver.

Dimmer Changelog:

2020-05-07: V1.0

  • Initial Commit

Switch Changelog:

2020-05-07: V1.0

  • Initial commit
12 Likes

Nice! I'm outta likes for the day .... so here's a :+1:

3 Likes

:rofl: I thought that was fixed

2 Likes

Come on. We'll get the resource leak fixed before that .... :joy:

1 Like

@bcopeland

Just tried out the Zen21 / Zen22 drivers. Awesome drivers! Very very nice!! Thanks a bunch!!

3 Likes

Real pity Zooz doesn’t build for Au/NZ 220-240v. :slightly_frowning_face:

2 Likes

Driver installed & working with one Zen22 with FW.v.3.07

Two Zen22's & two Zen 21's to go :wink:

Thanks Brian

2 Likes

I'm on firmware 3.1 for my Zen21, so I'll see about getting it updated. But in the meantime, can you explain to a noob how best to install this driver?

Am I just copy/pasting the code into a new driver in my hub? If so, how do I know if an update is available?

Am I importing the code from github? I can't seem to make that work.

Also, can you explain the button numbering? I'm assuming the change will break my existing rules.

On github hit the RAW button, then copy link.

In HE add new driver
Hit the import button
Paste URL
Hit done (I think)
Then hit save

I can’t answer the question about update notifications.

1 Like

I'm using a Zen21. Some feedback.

  1. After I changed to this driver, the auto off and auto on timer fields defaulted to 0 but if I make changes to something and try to save, it tells me the value must be > 0. Indeed, it does say 1-65535 in the description of the preference, but it defaulted to 0. I have the timers disabled. I just changed them to 1 and saved.

  2. I am using this as a scene controller and I had the relay disabled before. The preference was called "manual control enabled" and I had it set to disabled. I don't see the equivalent in your driver. Is it the "enable/disable scene control" option? I'm guessing it's actually the "smart bulb mode" and I want to set it to "physical paddle control disabled". I'm not using it to control a smart bulb, so I don't really like the name of this preference. I'm pretty sure that this switch can't act as a scene controller when the relay is enabled. Or maybe the smart bulb mode doesn't affect the relay at all? I'm actually fairly confused about it.

  3. What does association reports do?

EDIT: I have scene control enabled and physical paddle control disabled under smart bulb mode and I can hear the relay clicking when I toggle the switch. None of the preferences seem to disable the relay, so I'm going to switch back to the built-in driver for now.

:thinking: Checking on that

:point_up_2: That’s the one... I used the naming conventions from the zooz documentation

:thinking: Ok... Gonna have to look at that.. by chance did you take a screenshot of your preferences?


1 Like

Cool.. Thanks.. I’ll verify the config values that these are supposed to produce to make sure I didn’t introduce errors there

Bryan,

The auto timer boxes did the same for me, wanted me to put in a number. I just used 1 minute, and set the timer disabled box to "disabled". It works fine that way, but maybe you could make some default setting? At least make a note in the box to put something in there and select "disabled" in the next box over?

2 Likes

Yup. Noticed this too. Sorry I didn’t mention it.

1 Like

Ok.. sorry I've been away for the past few days.. getting back on this now..

2 Likes

Lol. No apology necessary. It really not a critical item !

1 Like

Bryan, while you are looking at things, I had a tiny issue with Package Manager. It doesn't seem to be identifying any of these Zooz switch drivers. Same for the RGBGenie driver too. See below link for some background.

Glad to provide other details as needed, or try things out.

Hey @bcopeland, it actually might not be your driver that was causing the issue with the relay. When I was testing before, I was on firmware 3.1 and I just used your tool to update to the newest firmware, which is 3.4. Now though, even with the built-in default driver, I can't get the relay to disable.

@agnes.zooz I don't know if this is a bug in the Zen21 firmware or the default HE driver or not.

Another update. Since the built-in driver was not disabling the relay like it should, I tried your driver again and now it's working 100% perfectly and disabling the relay and enabling scene control like it should. So I'm pretty sure there is a bug in the built-in driver.

1 Like