Z-wave

He has some mains powered stuff that is still going bad.

image

image

image

These are the problem devices. Ideally you'd like to see these have a lot of cluster info in them like the other devices so they can have an easier time getting back to hub.

The battery devices could also show as failed but still be good. I have two that always show failed but they are just sleepy devices. They wake up and fire off events whenever they are triggered.

2 Likes

What leads to the clusters?

Having changed nothing yet and working through some of these questions with you I went to do the repair that you suggested, and now I see this - more failed devices, although some of the same that you highlighted...

The battery powered devices don't worry about the mains powered ones are trying to route through devices that are having a hard time.

Then should I repair in a certain order based on the routes?

Zwave plus devices really should fix themselves over time. You can force it to try and find a route by doing a repair but eventually its just going to do it's own thing in the background. Just from what I've seen, 3 or 4 strategically placed repeaters would resolve your issues.

3 Likes

So, an update since yesterday. It does seem as if the mesh seemed to auto repair:

I now have an additional concern. I had tried to make a rule like this (Motion Lighting was not working for me - kept thinking it was on when it was off and vice versa...now as I type that, perhaps I'm seeing the same thing in the rule processing):

(that comes from this topic Using Rule Machine for Motion Lighting)

When I look at my logs, it seems as if my switches and dimmers are not reporting the correct state. So, when the rule gets to the "...and light is on" portion of the ELSE IF, the rule still sees it as off, and the light doesn't turn off.

Again, these are Zooz ZEN21 and ZEN22 devices (they get identified at inclusion as Generic Z-wave Smart Switch and Generic Z-wave Smart Dimmer drivers, and there are not specific drivers for them yet).

Because of the mesh issues, I had done that downgrade to 2.2.3.119. At that time, I did try to repeat the firmware update for the z-wave radio, but it hung at the first step - was about 30 mins into what it said would be 10 mins overall. Then, after other advice (where I neglected to mention the radio attempt), I upgraded back to 2.2.3.148. So now I also don't tend to see the [physical] or [digital] regarding the switches or dimmers, where I had before the mesh issues.

So now I'm not sure if it's the generic drivers, the switches, a result of the mesh repairing I've tried repeatedly, or perhaps something I screwed up (most likely) when downgrading/upgrading the platform.

I realize this isn't basic anymore, but does anyone have any suggestions?

This is the motion lighting app and this works perfectly for me:

Don't feel bad I needed help the first time around too.

If my switches and dimmers aren't reporting their on/off status then it could be why neither the Motion Lighting app, or this rule I tried are working.

So I'm not sure how to troubleshoot the devices, or get them to report correctly. If I go in the device page and refresh, then the hub sees the right state and the rule works. Of course, if I have to refresh the devices for it to run, that's not really automated or "smart".

What switches and dimmers aren't reporting correctly? Do you have the correct driver assigned to them?

It was in my earlier reply:

Make sure you are using the latest firmware and try these.

Another noob question... Does firmware refer to the switches or the hub? If switches, how do I check/update those? Also, do I don't ask questions like this again, did you simply search for those models to find the drivers?

I think the firmware @lewis.heidrick is referring to is the driver that allow HE to communicate with the device.

Not to be confused with the devices firmware or HE's firmware OR (C-7) Z-Wave Chip firmware internal to HE... all of which also can potentially be updated.

1 Like

I figured best to search, and if it's the device firmware, I had found this topic, which mirrors my issue (I'll need to read up on it fully), but it seems some Zooz devices don't always show the firmware to be able to check if it's the version I need for the custom drivers.

If you want newer firmware for your device you can contact Zooz. If there is an update you have to provide a proof of purchase and they will send you the files. You can then use the Firmware Updater driver to update. You might have to exclude and reinclude the updated device though.

1 Like

So, at this point, I don't know if I need newer firmware because the device page doesn't show the firmware (perhaps because it's the generic driver, but I tried using the Basic Z-wave Tool, and it also had no firmware). That link send to show some way to try to determine the firmware from the logs.

Also, it's funny you linked that Z-wave Firmware Updater because I had bookmarked that one too read, too.

1 Like

Well you could just check with @agnes.zooz and see what the most recent firmware is.. you could probably update the firmware anyway if not sure.

1 Like

I guess that's true. Probably doesn't hurt to be current, I guess. Thank you.

@agnes.zooz I'll PM you

1 Like

While waiting (or I guess, technically, not waiting), I installed the drivers from


... and I excluded, factory reset, and included one switch and one dimmer (without selecting S2 unauthenticated). They now both have more clusters and the firmware shows as 4.0 instead of no value visible.

What are the zwaveassociationG[] values?

I returned to my motion sensor switching rule to see if that helped, but found that the rule was still not turning the light on (and then it would seem to lock up and not respond to physical or digital on attempts).

The rule I was trying had a "Set dimmer level per mode" action in it. After restarting the hub, so the switch would respond again, I revised the rule to just a Switch On action. Then the rule worked.

So my additional question @agnes.zooz is whether this means the ZEN22 cannot handle the "Set dimmer level per mode" action, or for anyone else - could it be the driver and the fact @bcopeland wrote it for firmware 3.7 and my dimmer is already at 4.0 (or something else I'm totally missing)?

Yeah. So disregard that. Simplified my test, and only did the dimming by itself with a virtual button, and it worked fine. So here was the rule. Can someone suggest how to troubleshoot it using the logs (if it's the sensor timing, or sending double signals, how could I tell)? Right now, I haven't setup modes yet, which is why only Day is represented.