Zooz switch shows up as a ? on dashboard

got a new zooz 22 switch. just a basic on and off switch. its paired and working fine. but on my dashboard it just shows up as a question mark. no clue why. any suggestions?

What "template" are you using for the Dashboard tile? This affects what you see. For the ZEN22, you probably want to use the "Switch" template, which will allow you to view and control the current switch state (on/off).

If you're not sure what I'm talking about with "template," here's how you change it: click the "three dots" icon in the upper right of a Dashboard tile (assuming you haven't disabled this feature), then choose "Switch" under the "Pick a template:" list:

image

You can edit this after the fact (like now), or you can do it when creating the Dashboard tile.

Hope this helps!

I'm using switch

Then the next question: is the device accurately reporting is states? Check the device page (go to "Devices" on the left, then click/tap into the page for the ZEN22). In the upper right, you should see a "Current States" section, and you should see something for "switch," like "switch: on" or "switch: off":

image

If not, try toggling the switch on/off using the commands (buttons) on this page to see if your device is functional from a hub/Z-Wave perspective. This list of states should update in real time as the hub receives information from the device (which the ZEN22 should send back after it successfully changes state).

Maybe the device driver is the problem. Should I use generic zwave switch. Or zooz central scene switch

"Zooz Central Scene Dimmer" is the recommended stock driver for the ZEN22 (which is a dimmer, not a plain switch; if you have the ZEN21, that is the corresponding Switch driver).

2 Likes

Changing the driver type fixed it

3 Likes

You won't want to hear this, but the stock drivers are OK for some firmwares, but not all. I am not sure what point the stock drivers are "broken" but you may encounter some errors if you use them.

I like Bryan Copeland's drivers, I would encourage you to try them. They are available in Hubitat Package Manager, which makes it real easy to install them, If you haven't tried HPM out, you should. Of course, you can always install the driver standalone (without HPM) if you wish.

4 Likes

Thanks I'll take a look

Download the Hubitat app