Dealing with Zigbee Issues - Gotta love those Crees

I was going to post on the other post, but that one seemed off topic. I was just wondering if anyone else was experiencing slow down? I added two cree light bulbs to my system and ever since, it's been acting buggy. I've powered them off, but it's still acting buggy, so I don't believe it's the cree bulbs. It's affecting everything. Zigbee and zwave.

Have you rebooted? See if that clears it up. Also, any errors in your logs?

It clears up when I reboot. I can check my logs when I get home

I looked in the logs and nothing stands out. there is a debug message on the wifi driver. I don't use it but for one phone, so I removed it from checking mine and my husband's phone. The only thing I did was add two cree bulbs last Saturday. I figured I might feel it a bit, but it's been happening since before I added those two bulbs. Other than that, i can't consciously say that I've changed anything or added anything else in a while. Any ideas? Like, I literally only see my rules evaluating in the logs and no red whatsoever, but everything is firing super slow. Also, I made note that it's happening after the system has set idle for a while. Like arriving home from work or in the morning. Then things will improve a bit after we've been here, but still noticeably slow.

Is still firing slow, or was firing slow before the reboot?

I haven't rebooted. It's delayed yet. I figured I'd wait to reboot in case you wanted to look. I noticed that the most affected times are after the system has set idle. Like after we wake up or arrive home from work. The it improves a bit, but still slow. Last night I got home and opened the pantry about 5 minutes after I arrived home and the light turned on off on off on off about 5 minutes or better after i got into the pantry. then it "caught up". Cuz i closed and opened it a couple of times to see if the light would come one. My husband and I got a chuckle out of it.


That's how I've been resolving it in the past few days. A reboot will clear it up, but I also feel like a reboot hides the issue if someone wanted to look at the hub, so I didn't reboot it since I posted this.

@bravenel did you see this comment?

I've noticed that too! It always happens in the morning or when getting back from being away. It's like zigbee (in my case) has gone to sleep and needs time to wake up.

I have seen, on rare occasion, an issue with Zigbee seeming to queue status updates. I believe this is actually caused by a Zigbee repeater (an Iris 3210-L outlet) that is in a funky state. If I unplug that Iris outlet, and then plug it back in, the queue of events is released and the hub receives them, and acts upon them.

Not exactly the same thing that @april.brandt is seeing, though... April - have you tried a full hub SHUTDOWN yet? A reboot keeps the Zigbee/Z-Wave radios powered on, IIRC. Perhaps the radios needs a power cycle? Just a guess.

I will try that now.

@ogiewon - Ok so I did a safe shutdown. Then, I accidentally forgot about it for about 30 minutes. Powered it back up. Seems everything is responsive again. Since the hub seems to hate mornings most, I'll have to sit on this until tomorrow. Nothing weird in my logs. I hate rebooting this thing so often. I suspected that maybe my zigbee bulbs weren't settling down, but it's affecting everything on zwave and zigbee. They got picky on my network when I added them two years ago, so I just figured that they need some time to find their place in the ranks. It's been a week and it was happening since before I added them. Just not as badly.

1 Like

This was probably a blessing in disguise. Your zigbee mesh should be healing itself right now. If the Cree lights buggered up your mesh, the extended downtime should make your zigbee devices find their best routes again. :crossed_fingers:


Well, (sigh) .. I reworked some of my rules tonight. In testing them, I changed the mode. 10 minutes later it announced the change. No errors in my logs. Today, I noticed little things. The zwave contact sensor didn't turn off my zwave light switch, but when i went back and re-triggered it, then it shut off. Nothing in the logs. These are sensors and rules that I've had in place for almost 2 years. Now they're buggy? It's getting frustrating. Very quickly.

Hey @april.brandt - could I suggest you restore from a backup from before the bulbs went in and see if the system goes back to the way it was ?
maybe add the bulbs back in after a few days / week when you're happy. Maybe keep the backup as a bedrock and test off of that?

i have a lot of cree bulbs. they worked well for a period of time, but then there would always be some funniness. based on the input of many folks here, i moved them to a separate hub (phillips hue). then i connected the hue and HE hubs and everything has been perfect ever since. This theoretically doesn't explain your "all zwave" rules, but things were just a little funny with the cree bulbs. having them on their own hub means everything flies in our house, no delays.

Also, i have about 100 devices total (virtual, zwave, zigbee, cloud). third party apps, about 50 rules spread across SL, ML, RM. Hub Connect (to connect my ST hub for Harmony integration). No slow downs and uptime above 2 weeks on average. I've been tinkering a bit adding zwave and zigbee repeaters and updating HE software, so i haven't had more than 2 weeks of uptime in a while.

Crazy thing is that my cree's have been rock solid. I'll try the restore from backup. But maybe I'm going to sit on it unitl the weekend. Not to be a sh*t but because I don't have time this week to dedicate troubleshooting. Let 's see how it levels out over the coming days. I don't like to reboot and I do have my ST hub I could hook up, so maybe we sit on this and see if things calm down until the weekend?

1 Like

Same thing I noticed about my z-wave after a shutdown or sometime reboot as well. I see your frustration there. I have 100+ z+wave devices so a habit for me now after a reboot is go into setting/z-wave details and look at the "last received" column. If there is no update then I go into the device page and poll/configure that device.

I ended up rebooting tonight. No errors in my logs. very slow response time. Frustrating.