[Withdrawn] Ring Alarm Range Extender 1st and 2nd Generation (Z-Wave Extender with Battery Backup)

Hi, here is a driver for the "Ring Alarm Range Extender" found here and here. The Z-Wave alliance listing is here and and for 2nd gen is not listed yet. Before you tell me there is no reason for this to exist because... "Why would you buy an extender instead of a Z-Wave outlet or plug that extends and is also an outlet or plug?" This has a battery backup so it can be used to detect power outages. It reports change in AC status. Also, because I had an extra that I didn't need to connect to my alarm hub. And, also, just because I can.

Do not confuse this with the unofficial Ring integration I have also written. That integration also includes an extender driver but that driver is for when the extender is connected to the Ring alarm hub and the alarm hub is connected to HE via a websocket. This driver is for when the extender is connected directly to the HE hub and connected via Z-Wave.

The driver supports:

  • Configuring the battery reporting interval
  • Battery Level
  • AC Status
  • Battery Status
  • Power Source

Inclusion Gen 1:

  • Create a new device driver with the code below
  • Put the HE hub in inclusion mode
  • Supply power to the Range Extender to begin Smart Start (inclusion) mode. The device will enter inclusion mode indefinitely and the LED Indicator will blink slowly until it’s included in a system.
  • If the light does not begin blinking after power is supplied exclude the device first and then try again.

Inclusion Gen 2:

  • You may need to re-exclude the extender from HE so you're working from a fresh slate
  • Plug it in. It will start smart inclusion.
  • Start inclusion on Hubitat.
  • Hold the button for 3 to 5 seconds on the Extender Gen 2
  • At this point classic pairing will start. The device will be discovered by HE and HE will be happy.
  • At this point the LED around the button on the extender will switch from 3 green pulses and a wait to more rapid constant green pulses.
  • Eventually, the device gives up waiting for what it wants and shows a solid red LED for a short period of time. This means it failed inclusion. (In this state it won't send notifications and it responds to very little if anything. It needs S2 but we're going to force it to fall back or put it into a weird limbo mode without S2. Don't stop here.)
  • Then, remove it from mains. You have to have some charge in the battery for this part to work.
  • Hit the pinhole (setup) button once. The duration should be short.
  • Send configuration a few times.
  • Test the button to see if it sends the button event. If it doesn't, keep trying these last three steps until you succeed. Once the button event is sent it will also send power events. You can plug it back in at this point and you're good to go.

Let me know how it goes.

https://github.com/codahq/hubitat_codahq/blob/master/devicestypes/ring-alarm-range-extender.groovy

2 Likes

Thanks, I suppose I can create a rule if the acStatus is not connected then send me a text power failure. I have another way to do this but I think this will be better because it has battery.

Interesting alternative "power monitoring solution" I'm gonna grab one of these for testing it. Thanks for posting this!

I have tried including the device twice now and it joins as a "device" and the circle turns red. I can go in and change the device "type" after it installs and I only get battery level (1%). However doing this I do not see...

* AC Status
* Battery Status
* Power Source

Thoughts?

EDIT: After manually switching the driver to this one, I had to unplug the unit and plug it back it to mains. Once I did that the errors went away and it began reporting everything correctly.

I had installed the above driver first. Then pressed for z wave inclusion. At first the Ring extender didn't connect so I tried a second time pressing the button on the side of ring. Instantly it connected AND it automatically chose the above driver and has worked perfectly. I was worried, at first, that nothing was appearing in the status section but within a short time everything in the status field populated after pressing configure and refresh. With the help of many in the Hubitat community, I now have a device that reports a power failure and a rule that shuts down my hub safely after 30 minutes when a power failure has occurred. I feel the Ring zwave extender was worth the $26 on Amazon.

Is it normal for the battery to charge at a snails pace? It has been an hour and still at 1%. Or does it only report in like 25% increments?

EDIT: It says it's charging so I guess I'll give it a few hours and see.

image

I believe when it first was plugged in, it showed battery status of 35% but did take quite a long time to reach 100%. I also noticed when testing my rule for reporting a power failure and hub shutdown that for the few minutes it was unplugged the battery drained 1% but quickly recharged to 100%

Was wondering, did you ever open the back and look at the battery? Wondering if it's replaceable and its size

@tony3286 Thanks it seems to be moving now and reporting better. It does not seem to be repeating yet. I am going to do another zwave repair and give it a while to see how it goes.

It is removable, here you go.

1 Like

I've found this device to charge extremely slowly but also to discharge fairly slowly. I believe I had mine sitting a couple of days unplugged before it ever read less than 100% and then went very slowly from there.

On include if it doesn't ask for battery life I can change that so that it does. I have a feeling it did ask though and your device had just been completely discharged especially now that you see it charging from 1%.

*edit: I checked and I wasn't requesting battery level on configure. I am now. When a device is updated it will call configure. When the device installs it calls updated. Once I push the new code to the repo the device should report battery level immediately on include and every time after somebody hits configure.

2 Likes

@codahq, thanks for this driver! (And the HomeSeer dimmer & fan (and switch :wink: ) drivers, too. I'm a fairly new HE user and they have been a great help in getting me started.)

I ordered one of these extenders and set it up yesterday. I switched to your driver and I am still getting the "not the correct device driver" warning when I press the refresh tile on the device page. It seems to be working correctly otherwise.

If I'm reading your driver code correctly, it appears that some of the identification parameters are different. Here are my device details:

  • deviceType: 1025
  • inClusters: 0x5E,0x85,0x59,0x55,0x86,0x72,0x5A,0x73,0x9F,0x80,0x71,0x6C,0x70,0x7A
  • manufacturerName: Ring
  • deviceId: 513
  • firmware: 3.4
  • MSR: 0346-0401-0201
  • manufacturer: 838

The device signature being different would explain why it didn't pick the correct driver for you. The only reason it would tell you it wasn't the correct device is if the device talked to the hub in a way the driver didn't understand. Would you mind turning on all of the logging (description, debug and trace) and taking a peek to see what type of message isn't handled and what happened right before (and potentially after)?

1 Like

Certainly. Like I said, the driver seems to work fine except for that. I have already set up a rule that notifies me on power loss and restoration, and that rule triggers without an issue in my testing.

The easiest way to get the error is to press the 'Refresh' tile on the device page, and that appears to be a sure-fire way to get it. Beyond that, I have only seen it in the log one other time, and that didn't have any 'outside' events that appeared to cause it, just some sort of reporting it was doing. Here's the error from the Refresh. I'll leave the detailed logs running for now to see if I get the reporting error again.

Weird, I haven't ever seen that before.

That's an undocumented event in the most current Z-Wave certified extender. There are two Ring extender firmwares listed on Z-Wave Alliance's site and neither has mention of event 254 for notification type 8.

I've never seen that fingerprint or firmware either. If you can figure out what event that is or what it means it would be great. Then I can handle the event in the driver.

There must be something different with your hardware as well. I have a few extenders, some connected to Ring's base station, and they've never been updated beyond 2.4 firmware version. That leads me to believe they are different devices physically. I wonder what they changed in your device aka 0346-0401-0201 instead of 0346-0401-0101

1 Like

254 is literally unknown.. It probably at that point didn't have information stored for power management..

From the z-wave spec: "Unknown event/state" 0xFE (254)

Funky firmware glitch?

Just received my Ring z wave the other day from Amazon, as you know, and mine also 0346-0401-0101 and firmware 1.70 with no issues

  • deviceType: 1025
  • inClusters: 0x5E,0x85,0x59,0x55,0x86,0x72,0x5A,0x73,0x98,0x9F,0x6C,0x71,0x70,0x80,0x7A
  • manufacturerName: Ring
  • deviceId: 257
  • firmware: 1.70
  • MSR: 0346-0401-0101
  • manufacturer: 838

Could be. I captured it with a warning for now so that the driver doesn't tell the user it is the wrong driver. I also added a new fingerprint for the 201 device.

If you join that device to a Ring hub it will update to 2.4 I think. My guess is they didn't fix much though. If you look at their new firmwares they've just added parameters to fine tune routing (Supervision Command Class). They may have started doing that. I can't see any functional difference between 1.5, 1.7 and 2.4 on device 101.

2 Likes

@JB_TX Where did you buy yours from? It sounds like a different source other than Amazon and they potentially have new/different stock than everybody else.

@codahq It looks like I got the same batch as @JB_TX.

I did get it from Amazon just this week.

Slightly newer model maybe?

EDIT: Is that why mine came in as "device", and I had to assign the driver manually.

Yes, that should be fixed now though.

2 Likes

Download the Hubitat app