Help pairing Ring Range Extender Gen2

So I have this Ring Gen 2 range extender but I can't get it to pair with my Hubitat. I'm not sure if I am supposed to need something else, but this is the only Ring device I own. I downloaded the Range Extender driver from bcopeland, but my hub doesn't see it. Can somebody give me step by step instructions? I tried doing the exclusion first, but it wasn't seen there either.

I don't have one of these, but generally speaking I do one of a couple things.

Move the device closer, or the hub closer to the device.

If that doesn't work, shut the hub down from the settings tab. Pull the plug, and wait 30 seconds. Power up and try again.

Be sure you don't have any other Zwave hubs in the house. Power down your Wink hub, or Smartthings, or anything like that.

See if any of that helps, and maybe someone who has one of these can give some more specific advice.

I have a Gen 1, and I followed the Ring instructions for 'resetting' the device which put it into pairing mode and used this driver.

I pre-installed that driver so when it connected to HE the fingerprint would pick it, but you can also manually choose that driver.

Have you tried following Ring's instructions for resetting that device?


The 2nd gen Ring devices are going to want to smart include by default which HE does not support at this time. If you look at the top in the comments of my driver that @SoundersDude linked there are very brief instructions to include the 2nd gen extender.

To get the 2nd gen device to start classic inclusion you have to exclude it (if you've played with it at all it requires a fresh exclude). Do that by unplugging it, putting the hub in exclusion mode and pressing the pinhole button on the back of the extender. Once it is excluded successfully you plug it in. You should see it immediately start to blink the LED green. This means it went into smart inclusion. To steer it to classic inclusion you hold the front button down for about 3 seconds. It will pair after that.


Thanks for the help! It's working awesome now :slight_smile:

This is what I had to do to get it working.

I started with this driver and it paired but only as "device" (I tried a dozen times)

Following Soundersdudes advice, I used this driver and it paired right.

I needed the "switch" feature though to make my dashboard view the way I preferred, so I switched back to the first driver by bcopeland and then it worked. Strange, but it worked.

Thanks to the developers here for their hard work. I had a cobbled solution for a power failure before this (using a power failure sensor combined with a water leak detector), but this is an elegant solution now. Very pleased :slight_smile:

1 Like

Just out of curiosity... what is the switch functionality and why? Extenders aren't switches.

It was a feature request.. A component switch option that turns on/off based on mains power status

That doesn't make any sense to me. That's easy to do without adding use-case specific clutter to the driver. You can monitor an attribute in rule machine and toggle a virtual switch. To each his own I guess. :+1:

1 Like

It was a feature request .. I agree it's easy to monitor based on attribute change.. but that's what they wanted..

And I made it an option not the default

1 Like

When I used the Ring Range Extender without the switch function, in my dashboard I couldn't figure out a way to change the tile color to red when the power was out, and have it green when the power was on. With bcopelands driver, I could do it by creating a tile using the switch attribute. If there was another way of doing the same thing, I couldn't figure it out- but this way works perfectly. I'm tickled pink to have this functionality :slight_smile:

1 Like

There's at least two ways to do this.

  • As previously mentioned you can create your own virtual switch using the OOB driver. Then you can create a rule in Rule Machine that drives the switch state based on the acStatus attribute. Then you can show the virtual switch on the dashboard as you have with the child switch device on @bcopeland's driver.
  • The second way is modify the dashboard's attribute template. From the dashboard click the cog settings then "Advanced". In the layout find:

"customColors": [],

And replace it with whatever you want. For example:

"customColors": [
      "template": "attribute",
      "bgColor": "rgb(76,125,19)",
      "iconColor": "",
      "state": "connected"
      "template": "attribute",
      "bgColor": "rgb(108,29,9)",
      "iconColor": "",
      "state": "disconnected"

Then if you put the acStatus in there it shows those colors for those states.

1 Like

Nice. I'm sure I'll be using this tip for something in the future. You guys really know this stuff :slight_smile:

Hi guys, just got one of the green 2 extenders. Using @bcopeland driver. Device paired fine, grabbed Bryan's driver. However since it's paired I don't see anything in the device events, but do see errors in the log, and the button on the front doesn't do anything, like the led is totally off, even after pressing the front button. Is it possible the pairing affected the functionality?

My experience is that Bryan's driver doesn't setup associations reliably (device fault/quirk really, and not really a driver fault).

I tried 10+ times with Bryan's driver, but could only get it to fully communicate when using codahq's driver, and hitting configure repeatedly while waking the device by short pressing the pinhole button on the back.

coadahq and Bryan's driver do very different things in the configure section (namely codahq's tries to re-setup associations every time configure is hit, Bryan's does not), so I don't think that same trick works with Bryan's as currently written.

Thanks, i heard codahq is no longer with us and his git is closed. Where might I find the driver he wrote?

1 Like

Ah, that's the $64,000 question based on other discussions on this forum. :slight_smile:


Installed a Ring Gen2 about 12 hours ago, using System driver, showing 100% battery, but it is not reporting Power Loss when pulled from mains, and that is its main purpose on my system.

Any suggestions appreciated.

Is this on C5 or C7? the Gen2 was always a pain on the C5 it would stop reporting for no apparent reason. Most of Ring’s gen2 stuff if you can get it to pair without S2, it usually doesn’t last long. They work great on C7 if you include it with S2.

I have a C4

Download the Hubitat app