Help pairing Ring Range Extender Gen2

Ah, that's the $64,000 question based on other discussions on this forum. :slight_smile:

3 Likes

Installed a Ring Gen2 about 12 hours ago, using System driver, showing 100% battery, but it is not reporting Power Loss when pulled from mains, and that is its main purpose on my system.

Any suggestions appreciated.

Is this on C5 or C7? the Gen2 was always a pain on the C5 it would stop reporting for no apparent reason. Most of Ring’s gen2 stuff if you can get it to pair without S2, it usually doesn’t last long. They work great on C7 if you include it with S2.

I have a C4

Same deal.. Ring’s gen 2 stuff really doesn’t like not being on S2

1 Like

Removed and excluded device.

Any chance using your driver and these instructions will get the device working on the C4?

I found on my C4 the Ring RE Gen2 was a pain to pair. But eventually I got it and everything worked from power reporting to the button push reporting.

On the C7 though it was much better and joined much easiery. I also don't use encryption so not sure if that made a difference.

What are/were you using for the driver on the C4?

Mine paired by holding the button for a few seconds, but refused to report power.

Not likely.. This device gets stupid in the lack of S2.

I seem to recall one of mine behaving the same way (not reporting power) . I think all I did was unpair and then repair it and then it did. bcopelands driver worked great for me on both my C5 and C7.

1 Like

Got the device working, not quite sure what fixed it. Hopefully it will continue working!

  1. Repaired it
  2. changed it to use bcopeland's driver
  3. Did the pinhole send configuration thing a number of times.
  4. Noticed pressing the button was now showing in the logs
  5. Plugged it in and out a few times and Power switches from Mains to Battery and back again

Thank you all for helping me get this thing working.

Driver question for @bcopeland
What does the "Enable power fail component switch" do? Seems to work fine for my purposes without it.

Update never mind figured it out.

2 Likes

Has anyone else noticed when power returns while the Hub is shutdown, the Ring Extender (gen2) reports "Battery" until such time as the extender is physically removed from power, then plugged back in.

Note: executing a Refresh command did not fix it.
Note2: executing Configure command did not fix it.

tagging @bcopeland

Update: driver Bug report found when setting up wifi power plug with extender, around line 213

void zwaveEvent(hubitat.zwave.commands.notificationv8.NotificationReport cmd) {
    Map evt = [isStateChange:false]
    log.info "Notification: " + ZWAVE_NOTIFICATION_TYPES[cmd.notificationType]

image

I just verified that. Going to let it report "battery" for a little while to see if it corrects. Never noticed this before because I keep my Hub on a UPS that lasts a long time, so I know when the power comes back on.

Edit- so no, even after a a long time, they do not correct and report the power is on.

1 Like

I have an ugly workaround that I really don't want to use, but just in case.......
Place the Ring Extender on a Wifi plug, then manually power cycle it as needed.

Already have a Kasa wifi plug used to manually power cycle the Hub after a graceful shutdown. BTW has anyone figured out how to automate the Hub's power up restart with a Kasa Wifi plug?

Thought Update: Using a second wifi plug direct to mains may be necessary to determine when house power is restored, because the Hub's wifi plug is on the UPS and may have power when both house power is off and the hub is shutdown.

I have an older APC UPS that does not have a Wifi connection for reporting.

Update 2: Implemented the ugly workaround until such time this issue is resolved.

What are you using for this?

When you pair the gen2 range extender, what security option do you select when prompted? Or do you uncheck all options?

I paired it using s2, and its working as a repeater, as I see other z-waves are repeating off this node, but button presses and mains/battery arent triggering so I was going to try the unpair/repair dance. Its already set to use the proper handler, and I've done the rear pinhole press/configure procedure a bunch with the same result.

Thanks.

@arnb I use this UPS. I posted this one other time and I think people thought I was nuts. I may be nuts, but it's a great option and still available if you look. It's designed as a low power UPS and can run a long time- designed for things like networking. I didn't pay that much BTW- I think it's more because it's harder to find. The battery is hot swappable and can be used as a portable power supply too.

https://www.amazon.com/APC-Back-UPS-Connect-Charging-BGE50ML/dp/B013JHYQNC/ref=sr_1_3?dchild=1&keywords=APC+Back-UPS+Connect+Lithium+Ion+UPS&qid=1599356002&s=electronics&sr=1-3

I think this looks like maybe a better option, but I don't own it and can't verify it.

https://www.amazon.com/TalentCell-Uninterrupted-27000mAh-Wireless-Smartphone/dp/B07WLD32RP/ref=sr_1_3?dchild=1&keywords=5v+ups&qid=1599356125&sr=8-3

1 Like

I have 2 of these running at different locations and they've worked out great so far. Note: I have only owned them since July so ymmv but they seem to work well.

Two of what? The Range Extenders or one of the UPS's?

Argh apologies for not being clear - 2 of the TalentCell Mini ups devices.

1 Like

Download the Hubitat app