[RELEASE] Lidl Smart Home Drivers with Device Health Status

These work with generic drivers, but because of my reliance on healthStatus I've rolled my own versions and they're working well.


Search for the keyword "Lidl" on Hubitat Package Manager and you should see "Lidl Drivers from BirdsLikeWires". Requires HPM v1.8.7 or later. Or install manually from the link below.

They work really well, though I have had a relay fail in one of the extensions, which was a bit disappointing. None of these support power monitoring though I believe they do support modifying their power-on behaviour, which I'll investigate one day.


Reserved post just in case.

Found this no-name two-channel no-neutral switch module on eBay before Christmas. Turns out it's a Tuya. :slight_smile:

IKEA Repeater for scale, this thing is tiny, with a removable clip and a capacitor in the box to mitigate flicker if necessary. Very nice. Smaller than the Samotech modules I normally use. I've ended up with this because Samotech don't do a two-channel no-neutral and it's brilliant.

I'll make a driver up for it when I get chance, shouldn't be a big job. Don't think it works as a repeater, but it's solid state while Samotech use physical relays.

NOTE: If you are using the driver from this Lidl set to control this switch module, please take a look at the dedicated Tuya driver instead.

I have a few of these and was wondering if there is a way to have the power draw on the device reported in such a way that I could setup rules with it

eg. have my computer plugged into it and when I shut down and the power draw is close to zero it turns the switch off so that I can then have it trigger to switch on when I enter my office

Any idea if something is possible with these devices?

Did you ever get any of the spotlights that Lidl sold? These lights had 3x zigbee GU10 bulbs and came with a 4 button remote control. The lights added ok to HE but the remote control only added as a 'device' when paired. If the driver was swapped to 'philips dimmer button controller v2' then you could use it but only one of the four buttons worked. It would be nice if all 4 buttons worked.

Unfortunately not, I've found no power reporting in the messages from these devices. If you're in the UK you'd be better off with a Salus SP600. My driver for it supports power reporting and you could set up rules to do as you require.

Ah, you mean this one! That's my other account on here; yes, I still have the remote (it was in the box with their Tuya hub) but no luck getting it to do anything useful due to the points raised in that thread.

I assume that single button only works due to it being a built-in driver, which likely has access to things our user drivers don't. Maybe. You've got further than me in having it do something anyway!

1 Like

Can you post the remote device details 'data' section? We need the Model and Manufacturer IDs, it may turn out that this Lidl remote is a Tuya remote clone that is already supported?

  • endpointId: 01
  • application: 51
  • softwareBuild:
  • inClusters: 0000,0001,0003,0004,1000
  • outClusters: 0019,000A,0003,0004,0005,0006,0008,1000
  • model: TS1001
  • manufacturer: _TYZB01_bngwdjsr

The clusters are the same as TS004F ...
I will send you a PM.

1 Like

Just to recap the findings on the Lild Livarno Lux Remote Control - except the first button, all others use inbound group messaging and at this time the device can not be used in Hubitat.



I have tried the driver for the USB Extension Lead after it did not work with the "Nue switch" driver as proposed by others.
But I have the same problem with both drivers: all buttons always switch on or off at the same time. They even do this no matter if I click "on" or "off". So in fact they all just toggle at the same time no matter what.

I have tried to comment out some stuff in the driver code but no effect at all.

I have tried 2 different Extension Leads, just to make sure, same effect/

Please post the extension lead model and manufacturer (from the device web page 'Data' section).


Thanks for your reply.

Here are the 2 values:

  • manufacturer: _TZ3000_vzopcetz
  • model: TS011F
1 Like

We will need the complete device ‘fingerprint’. Switch temporarily the driver to the HE inbuilt driver named Device’. Then click on ‘Get Info’ button and copy/paste here the fingerprint Info log, that should appear in the life logs.

Did that, got this:

dev:262982023-02-12 14:51:58.567 infofingerprint profileId:"0104", endpointId:"01", inClusters:"0000,0003,0004,0005,0006", outClusters:"0019,000A", model:"TS011F", manufacturer:"_TZ3000_vzopcetz"

1 Like

Hi there. In regards to the USB Extension, I have installed your drivers but all sockets switch together and not individually. The main device is Tuya TY-06338 and the three switches default to Generic Component Switch.
What did I miss?????
Kind regards Chris

Sounds like it's installed fine, but are you using the on/off controls on the individual child switches, or the one on the parent for the whole device?

There could have been a firmware change between the one I have and the one you have, there are so many variations of these things around.

If I go into devices it has the parent device and three child devices. When you turn any if them on they all turn on. Thinking I might return the device as not suitable? Your thoughts?

There may have been a firmware change which alters how the individual sockets are addressed, or it could be running an older firmware. You could try pairing it with a Tuya hub and seeing if it will update, but other than that I can't really troubleshoot it, I'm afraid.

Hi, was there any solution to this in the mean time? I have the Same behaviour AS above so I guess it is Not an individual issued?