Zooz ZEN22 and ZEN30 stopped working for no reason

I have multiple Zooz devices. Yesterday a ZEN22 4.0 and ZEN30 double switch stopped working for no reason. The indicator lights are on. There is not even any local control from the paddles. Is there anything I can do other than remove them from the wall and use something else?

Pull the air gap at the bottom of the switch and wait a few seconds and then put it back. I've had my ZEN30's do that a few times.



Fixed it.

Why tho?

The Zooz Zenxx switches have been very sensitive on the C7 from what I have experienced in my migration from ST.

I have had to exclude and/or factory reset them several times and re-add back on the C7 (inclusion w/ no security). Not sure what is going on here!


You might verify that you have the latest firmware

My Zen21 has been driving me crazy since migrating it to Hubitat. I have upgraded to the latest FW, performed a factory reset and yet it seems very unreliable.

The switch, triggered by open/close sensors, at times, can take forever to turn on. The worst was two days ago. In checking the event log, the switch turned on 1 minute, 4 seconds after the open/close event. The thing is, the problem appears most often if the switch has not been turned on for a long period of time. I first suspected that the open/close sensors were asleep but the logs tell me different. The time span is between the open/close event and the switch on event. Once the switch has been triggered to come on after being idle for a long time, subsequent trigger-on are snappy.

I have tried several drivers as well as different rules (RM, Simple Automation) and the results is always the same. I even moved the hub within 20' from the switch but it made no difference.

I moved to switch back to ST and the problem appears to be gone albeit consistently slow (1-2 seconds).

I am out of ideas on what to do. Leaving it on ST is the least favorable option,

1 Like

If it is paired at s0, use a secondary z-wave stick and pair it with no security and see how that works.

No sure what this means...

So look at your z-wave details page and look at the devices then the security column. If they are paired at s0 security they may be overly chatty and dropping off. Use a scondary z-wave controller paired to hubitat and pair the devices without security to hubitat via the secondary controller then remove the secondary controller. It is caused by some devices not being fully z-wave compliant and the 700 series chip being very compliant.

:grinning: Ah... S0... No, I have it paired at S2 Unauthenticated

Hmm... I think that can cause issues too. Can you pair it with none and see how it runs?

1 Like

Done. Now to wait 24 hours and see what happens :smirk:

1 Like

Let us know!

I have my ZEN21 Hallway light switch paired to C7 with no security. In the mornings, the switch takes a little longer period for it to turn on to the motion detectors on the C7. But during the day, the switch reaction time improves slightly. The C7 has some interesting quirks with Zooz Z-Wave devices.

Can you direct me to where I can get more info on this. I have used secondary controller (on ST) before but I am confused how I get a device from it to Hubitat.

you will need a secondary z-wave stick to pair with.

1 Like
1 Like

Worked like a charm all day yesterday and then this morning......

06:27:00 - HE.Garage/Foyer Door Sensor Ecolink.contact.open
06:27:18 - 	HE.Garage/Foyer Switch.switch.on
06:27:22 - 	HE.Garage/Foyer Door Sensor Ecolink.contact.closed
06:29:22 - 	Garage.Light.Off.Event
06:29:22 - HE.Garage/Foyer Switch.switch.off
06:31:05 - HE.Garage/Foyer Door Sensor Ecolink.contact.open
06:31:42 - 	HE.Garage/Foyer Switch.switch.on
06:31:45 - 	HE.Garage/Foyer Door Sensor Ecolink.contact.closed
06:33:45 - 	Garage.Light.Off.Event
06:33:45 - HE.Garage/Foyer Switch.switch.off
06:36:14 - HE.Garage/Foyer Door Sensor Ecolink.contact.open
06:37:04 - 	HE.Garage/Foyer Switch.switch.on
06:37:09 - 	HE.Garage/Foyer Door Sensor Ecolink.contact.closed
06:39:09 - 	Garage.Light.Off.Event
06:39:09 - HE.Garage/Foyer Switch.switch.off
07:25:05 - HE.Garage/Foyer Door Sensor Ecolink.contact.open
07:26:04 - 	HE.Garage/Foyer Switch.switch.on
07:26:10 - 	HE.Garage/Foyer Door Sensor Ecolink.contact.closed
07:28:10 - 	Garage.Light.Off.Event
07:28:10 - HE.Garage/Foyer Switch.switch.off

Without going into details of all the debugging I went through, I found the problem had nothing to do with the Zen21 switch at all. The problem was related to the Ecolink Contact sensor. After an open/close event of this device ANY zwave device on my network took forever to come on/off for anywhere from 15-60+ seconds after the open/close event. Anything after that period and all my zwave devices worked perfectly until the Ecolink contact opened/closed.

I replaced the contact with an old AEON door/window sensor and now I wait another 24 hours to see how well this setup continues.

UPDATE: Yup, seems there are issues with Ecolink Sensors

I just pulled the airgap and fiddled with it and today it is working for no apparent reason.

Problem solved!

Thanks for the suggestions.


There is a known but in the Generic Z-Wave Contact Sensor driver in 2.2.4 that presents with this kind of behavior (it will be fixed in 2.2.5 release).

1 Like