Zooz 4-in-1 (ZSE40), C7, S0

That's exactly my point the device firmware still causes the device to repeatedly send the events which is what is aiding in the battery drain. The screenshot is to show that the device has a long history of this issue (all you have to do is search Zooz 4-1), and the driver modification only aided in not spamming the logs of the hub which some claimed were causing hub slow downs.

Very hard to make that claim when many others like myself had identical problems on a C-5 without S0

Your frustration is valid, but I think it should be focused on Silicon Labs. Hubitat is following their requirements and specifications in order to be Z-wave certified. They aren’t just making these things up, they are required to follow a set of standards. Based on what I’ve seen the staff write, I’m pretty comfortable saying that if they could change the way these devices join, they would, instead they are stuck/requires to follow the specifications laid out by Silicon Labs and that means S0 currently can’t be forced to downgrade.

I recall people pointing out how Hubitat wasn’t zwave certified and how that was a negative. Well here we are, the device is certified, and as a result there is a 3rd party requirements that must now be follow that perhaps Hubitat could skip in the past (or at least that’s my read on how all of this works).

Now there are certainly other things you could more easily place blame on Hubitat, but I personally fail to understand how a silicon labs requirement is the fault of Hubitat.

1 Like

I’m not totally blaming Hubitat. But as they decided do roll with the 700 chip then the pitfalls of devices that worked before are a hill they will have to climb. I fully get the whole HA/HC has ( even after 40 years ) not matured beyond a niche for those willing to tinker and take their lumps with each “innovation” 35+ years ago I had voice control of lights and an alarm panel that would dial my pager, and turn on the pool pump a a outdoor lights and yet didn’t have a cell phone. The amount of “standards” that aren’t shouldn’t be where we are currently at 35 years later. I could barely get power windows and door locks in my car then and now it will ( almost ) drive itself. My complaint is the “puzzle” is always missing a piece, and every “upgrade” makes something complicated that was easy prior.

Ugh! :zipper_mouth_face: I just bought one of these! I wanted another multi-sensor for my master bedroom. Does anyone know who is selling these? It looks like they support S2:

https://products.z-wavealliance.org/products/3806

These actually look identical to the Zooz ZE40's....

It does look like the Zooz sensor.

That model isn't even showing up on the company's web site:

Based on the information from the Z-Wave alliance site there are a couple issues that make them less than compelling to me:

  1. Light measurement is still reported as 0-50. Which is OK for detecting bright vs dim. But you have to be willing to live with the imprecision of this sensor. Most other light sensors report lux which is a much wider range.
  2. These sensors remain large. In moving to a 700 series chipset the manufacture does not appear to take advantage of reduced power demands and still requires a CR123A battery.

At this point I only buy Zigbee sensors. Unfortunately there aren't any with both luminance and humidity. So I use Hue where I need light and NYCE in places that need humidity.

If you just want light, there's always this...cheap (from $12 to $15) and a community driver available.

Zigbee 3.0, reports lux:
image

If you want to stick with zwave the best alternative would be the sensor from Aeotec:
https://www.amazon.com/Aeotec-Multisensor-temperature-humidity-vibration/dp/B0151Z8ZQY/ref=sr_1_2_sspa?dchild=1&keywords=aeotec+multisensor&qid=1600749469&sr=8-2-spons&psc=1&spLa=ZW5jcnlwdGVkUXVhbGlmaWVyPUFYMlBHSTRQQVJPTCZlbmNyeXB0ZWRJZD1BMDM0NjE1MzNDMDZGNFo2UlVHNFAmZW5jcnlwdGVkQWRJZD1BMDczMDgyNDFPMktMOUwySVQ2QVgmd2lkZ2V0TmFtZT1zcF9hdGYmYWN0aW9uPWNsaWNrUmVkaXJlY3QmZG9Ob3RMb2dDbGljaz10cnVl

Is there a way to add a ZSE40 to hubitat using a secondary controller to force an insecure inclusion?

Yes, post 7 above,

Awesome thanks, sorry I missed that. Sorry for all the questions, new to Hubitat.

Did you have to put the Hubitat hub in inclusion mode to use NWI on the SI software? From there you put the SI software into inclusion mode, added the ZSE40 and unchecked the security functionality?

Just this. No need to do anything on the Hubitat side (other than already have the secondary controller set up). There were no security prompts from the PC Controller software.

One thing I haven't seen directly confirmed - can you pair w/out security using a Z-Wave 700 series secondary controller, or do you have to have a 500 to avoid security?

I just re-paired my sensors to verify my process. Here were the exact steps:

  1. Include the Z-Stick (mine is the Homeseer SmartStick+) as a secondary controller using PC Controller software (I'm using version 5.39). When including to Hubitat include in unsecured mode (uncheck any security boxes that Hubitat prompts)
  2. In the PC Controller software click on the secondary controller line.
  3. Click the 'Add' button.
  4. Push the button on the ZSE40 2-3 times to wake it up and get into inclusion mode. (Have the logging screen open and you will see activity including an 'Add Node completed' message)
  5. Go back to the Z-Wave details page in Hubitat and check to see that it's there. There should be "None" in the Security column.
5 Likes

@bill.d do you have a link?

Here it is: Z-Wave Embedded SDK - Silicon Labs. You have to sign up for an account to download the software. You also need to have a USB Z-Wave stick of some sort. As I said I have the HomeSeer version. Amazon has several that work fine. Nortek, Zooz, Aeotec, etc.

1 Like

I found that but i didn't think it was correct so thanks :smiley: . I'm assuming i download the embedded SDK then PC controller?

Just PC Controller is needed to work with the USB stick. If you need more info on how to get the secondary set up, the directions in this post are pretty thorough

2 Likes

@agnes.zooz Ignorant question on my part... But, would it be possible to add S2 support to the existing HW?... I mean if it's "just" FW, 1's and 0's right? Should be easy enough :wink:

We'll definitely consider it. That may require recertification which will affect the product price but we're not ruling this out. I'll post here if we end up introducing a new firmware version for S2.

3 Likes

seems like a lot of work to pair in non s0 mode. i tried in hubitat no choice .. so or hit the hiway.. anyway i am scrapping mine for this reason