Sonoff snzb-02 - can't control update frequency

Hello everybody!
I am relatively new to the habitat ecosystem and I try to figure out some stuff.
I have 7 Sonoff temperature sensors, which I have successfully set up.
but their reporting frequency is very rare.

I have read similar topics
Wont' update

Humidity related

but I haven't manage to make it report on the resolution that I want.

Typically it sends 1-4 readings per hour (most usualy 1 per hour).
The settings are set to be 0.25C , which is not respected. I usually get 0.5C intervals or more.


even if I make the reporting every 5 minutes it does not send events every 5 minutes.

I have also tried apart from the official "Sofoff Zigbee Temperature/Humidity Sensor"
a)Zigbee - Sonoff Temperature & Humidity Sensor

b)Zigbee Reporting Configuration

with similar results even when these are selected.

I have also tried to remove and re-add the sensors with no particular luck as well.
Batteries are brand new (reporting 100%)

When seeing the events I get something like this

Any idea would be more than welcome.
Thank you in advance!

I do not have first-hand experience with it, but here is a solution from another recent thread.

Try re-pairing but without removing the sensor first.

Unlike many battery-powered Zigbee devices, the Sonoff Zigbee sensors appear to "fully" sleep and are not responsive to commands from the hub (configuration, refresh, etc.) unless they are awake at that moment. From one of the threads linked to above, it seems that pressing the button on the device might wake it (so you can try that around the same time as a Save Preferences or Configure), but re-pairing is another way to make that happen since Configure will run then, too, and they are definitely awake when pairing.

Re-pairing should also give you a clear indication in the UI that the device was re-discovered (instead of needing to guess whether it was awake and the configuration worked). With Zigbee devices, unlike Z-Wave, they'll fall right back into place after a reset/re-pair as long as you don't delete them first--one reason I say not to remove it first, besides the fact that your settings will be there configured how you want, which they won't be if paired like new.

4 Likes

@user3080 see my resent screenshot here . As @bertabcd1234 said, the easiest way to configure the reporting settings is to pair again the sensor to HE, without deleting it.

I can recommend my Tuya driver : ) - in the logs page you can see a confirmation whether the reporting configuration was successful or not :

2 Likes

Thank you for your answer after digging in a bit I think that is what happens, the configuration never gets into the device since it is in a deep sleep mode.
I don't have very clear how could I trigger a "re-pairing". The pressing of the button does not seem to wake it up unfortunately.

Go to Devices -> Add Device -> Zigbee -> Start Zigbee Pairing.
Press and hold the device button for 4..5 seconds until the LED starts blinking. The sensor should pair again to HE as a previously found device.

You are correct, I have edited my previous post for this device only, Other devices will wake up by pressing the pairing button, but SNZB-02 will not.

Another trick to successfully send the reporting configuration to deeply sleeping Zigbee devices is to click on the 'Save Preferences' button a second later after you remove and insert the battery cell back into the sensor.

1 Like

You can try this new version :

Download the Hubitat app