Sonoff snzb-02 Won’t update

Hello, I am new to Hubitat, but have been using first Iris, then ST’s for a number of years. My ST’s ate crap about a week and a half ago, and I couldn’t find a local replacement. I bought my Hubitat about a year ago, and dug it out. The transition from Smartthings to habitat was surprisingly easy, and I am in the final stages of getting things back the way they were. I ordered some new temperature sensors, Sonoff snzb-02, and the install worked as expected. I can see the devices across the system, but they won’t update. Looking in the logs I see where I installed them at 8 o’clock this morning, but at 1:45 this afternoon there’s been no updates. Anyone use these?

And yes I have moved them from room to room and into the refrigerator, still no change…

If you haven't already, I would re-pair it without removing the device from HE. That will usually get zigbee sensors talking again.

1 Like

First thing i would check is the battery connectors, i had exactly the same with a couple of mine. I paired them then proved they were working fine. After a couple of days nothing was coming back. It turned out to be the ill fitting batteries. After tweaking & manipulating the battery holders (gently bent their pins and holder closer together to make the battery fit more snug) they worked great every time.