Temp sensor polling times - Slow

Hello,

I just spent the last 3 days setting up some temp sensors to work with the M4 Pro RF to turn on and of the heating in my van based on temp.

I now have a new problem

SONOFF SNZB-02 ZigBee Temperature & Humidity Sensor

Controlling anything with these random temp updates is not going to work. Look at LAST 27.50c its now 4.30pm. I know it should be 19c thats a big gap and still no update.

Is there something i can change to make the gap less?

Thanks

Depends on the type of sensor and the driver being used. Some have the ability to adjust the reporting based on temperature change, some based on time internal, some both. What kind of sensor are you using and what driver?

1 Like

Added in to the main post

Ah ok. I have not found the Sonoff sensors to be all that reliable. But if you're using the Sonoff driver you should see these options. Any of them should have triggered a report from your device in a shorter timeframe than yours, so not sure how much luck you'll have, but you might try fiddling with the setting and seeing if it makes a difference. Other than that it might be a zigbee mesh issue that is causing the hub to miss some reports, or it might just be the sensor itself. If you do decide to change the driver be sure and hit "configure."

1 Like

You would of thought it would of done a update when it changes from 27.50c to 19c lol. Ok i will try the time setting and see if this works.

Thanks

Yes, I agree. It should have. Honestly if it's critical I might try a different brand sensor. The sonoffs are definitely inexpensive but...

2 Likes

Changed it to 5min and waited 15 no change. I also have the same problem with the other SONOFF temp sensor.

Can you suggest one that might be a little better?

That's a tough one. In my applications I don't care that much about reporting interval. However I personally like the smart things multi sensor but I just checked and it has NO configuration options! It seems to report every 5 min or so. Perhaps others will weigh in also.

I've been very happy with my Zooz zse44, but I only use it for humidity -- but it is snappy & reliable with the humidity inputs I want, so perhaps it is same way with temp too.

My experience matches your log - Sonoff default is to update after a 0.5C change, but not faster than once per 5 minutes. Someone is welcome to tell me that I am wrong, but I would be surprised if you can adjust those parameters in real life. It looks like temperature can swing quite quickly, so this is not the right tool for this job.

Unfortunately, I don't have recommendations for a closed-loop control temperature sensor. None of my applications would change >9C in 5 minutes. Yikes!

I changed 9C in 5 minutes because it was in my hands so i could test it.

You can try the [RELEASE] Tuya Temperature Humidity Illuminance LCD Display with a Clock driver - install the dev. branch version linked to the second post of this thread.

I am able to configure the Sonoff SNZB-02 sensor to send updates as quickly as 10 seconds on 0.1 degrees Celsius change.

Reconfiguring the reporting intervals and delta requires that the sensor is awake at the time when the new settings are sent to the device. You can try pressing the device pair button at the same time when you click on the preferences Save button. EDIT: this does not work for SNZB-02

An alternative way to ensure the new reporting settings are accepted is to pair the sensor again to HE after the settings were saved. This works all the time with my device.

2 Likes

Good to know. Thank you for disproving my skepticism!

I am able to configure the Sonoff SNZB-02 sensor to send updates as quickly as 10 seconds on 0.1 degrees Celsius change.

Please tell me how you set these settings?

Install the driver :
https://raw.githubusercontent.com/kkossev/Hubitat/development/Drivers/Tuya%20Temperature%20Humidity%20Illuminance%20LCD%20Display%20with%20a%20Clock/Tuya_Temperature_Humidity_Illuminance_LCD_Display_with_a_Clock.groovy

Switch on ‚ÄėAdvanced options‚Äô and click Save. Additional options will appear in the Preferences section. Set ‚Äėtemperature sensitivity‚Äô to 0.1 and ‚Äėminimum time between temperature reports‚Äô to 10. Click save.

Then pair the Sonoff sensor again to HE.

1 Like

Download the Hubitat app