Remotec ZRC-90

I have seen my question in another topic; but thought I would ask again. Has anyone figured out how to get the Remotec ZRC-90 to work? Here are data points

  • I already have ONE working since I established my home automation (no issues, no problems)
  • I got my wife a new one for Christmas to use as a control for some automation
  • It pairs just fine using the built in driver.
  • Pushing ant of the eight buttons with debug on only prints the following (no buttons work):

[dev:1409] ( 09:12:42.958 pm info Remotec ZRC battery is 94%
[dev:1409] ( 09:12:42.955 pm debug BatteryReport: BatteryReport(batteryLevel:94)
[dev:1409] ( 09:12:42.952 pm debug parse description: zw device: 5F, command: 8003, payload: 5E

  • I have reset, repaired, made sure the batteries are new and done everything else I can.
  • I have done extensive searches online and find that a few people have the same problem. The only reference I found to the possible issue is that this device cannot have an ID greater than 128? The device ID is (according to the log) 1409. The one that works is 61. Is there a way to change it? Has anyone found a solution?

Thoughts? My wife is ready to kill me over this one... I can return the device, but I have found people who say adding them to a new "network" works great. I would HATE to rebuild everything just for one remote....

I'm pretty new to buttons myself, but have you looked at ABC? That's what I'm using for my smartthings button and it's working great. The default app didn't register my button presses either.

I'll pair mine again in a minute, and see what's up...

Factory reset it, paired it

Working fine

1 Like

The device id in the url is not the zwave network id, that is the device network Id in hex in the driver details.

I'm not aware of a max zwave node id of 128 (0x80) for this device, where are you reading this?

Thanks for taking a look. The “issue” I was referring to was at a homeseer forum where it mentions that adding the remote to a zwave network with “too many nodes” causes an issue. One solution (in the bowels of this forum) is to change the network ID — when it joins. Changing it after breaks it. (Which I confirmed).

Could be trying too hard, but either way I don’t think this is a Hubitat issue....

See Homeseer Link

Update: I got it working. Here is how (and I hate to admit I stooped this low)...

  1. I got out my old, decommissioned ST (ugh)
  2. Paired the remotec to it (used built in drivers)
  3. It did not work until I pressed "Configure"
  4. It worked
  5. Excluded it from ST
  6. Happily powered off ST
  7. Paired it with Hubitat using the same procedure as before
  8. Happy, Happy, Joy, Joy ... it now works.

I am unsure what ST did in the pairing/configure that is different ....

1 Like

Just bought one of these and keen to tie it into my system.
To confirm we can set push / double tap / hold as separate buttons ?

Yes, each of the 8 buttons support push, held and 2xtap.

1 Like

I just bought one of these as well.
Pairing seems to go ok as the hub recognizes the device with the correct naming and reports battery at 91%. In addition, from the device page, all the button presses work and get logged as events. However, physical button presses from the device dont do anything and dont get registered as events as well.
Any help would be greatly appreciated.

Pressing a button from the device page simulates in the driver what would actually happen with a physical button press, but it doesn't require anything from the device itself. It sounds like it may have "fallen off" your network. If you didn't pair it in place, it's possible it can't find a route back to the hub and a Z-Wave repair may help. It's also possible the batteries are low--I know 91% sounds high, but if it's new I'd expect closer to 100, and depending on the battery chemistry, this reporting may not be reliable (it's usually estimated via voltage, which doesn't work well for lithium batteries that experience a sharp decline right at the end of their lifespan but little drop before then).

Pairing it again (after excluding) may help, but I'd also try seeing if it works closer to the hub (or wherever you paired it) and with new batteries (or if you have way to test the voltage yourself and consider them good).

What are you using to drive the buttons, "button controller" app or a rule ?

I am using button controller

Tried all those things but still the same exact result

Any pointers on this. I tried again a few times with same results even moving the ZRC-90US right next to hub.

I had a little trouble with one of mine awhile back. I excluded it, reset it, then re-included it. Resetting it is a little tricky. Press R for 10 sec. and let up then triple click R real fast. Including was just pressing W once when the hub was in inclusion as usual. I was about 3 feet away when I did this and it seemed to work ok.

Thanks. What did seem to work somehow is to put hub in inclusion mode, then hit W and wait for a few seconds before pressing L to complete inclusion. Your suggestion to press W seemed to have helped.

This was the only thing that worked for me .. Pressing "W", then "L".
Immediately was identified by Hubitat.

1 Like