Remotec ZRC-90 buttons not triggering events

I have a Remotec ZRC-90 which I tried setting up today. Pairing the Z-Wave device was straightforward enough and it shows up in my device list. But when I press any of the buttons on the controller, its LED blinks rapidly indicating “operation is invalid” and no events are seen for this device in Hubitat. The only events that appear for the device are “numberOfButtons” and “battery” (right after inclusion). In the debug log, I do see an entry like this for every time I pressed a button:

parse description: zw device: 2F, command: 8003, payload: 64 , isMulticast: true

The payload is the same regardless of which of the 8 buttons is pressed. If I keep a button pressed down while re-loading the device page, the state variables still read “0” for all buttons. I’ve read through the related issues on this site (“Remotec ZRC-90 - discovered but nothing else”, “Remotec ZRC-90”) and they appear to report a similar problem, but nothing I’ve tried gets the buttons working — excluding and re-including the device, creating a secondary controller, creating a primary controller, wake up and listen; the behavior remains the same. The one thing I haven’t tried is pairing the device with SmartThings, because I don’t have one of those. Any other suggestions on how I can troubleshoot and get this working?

works find for me .. what driver does it show under your device panel.. maybe it paired with the wrong driver. or didn;t pair fully

I don‘t see any driver in the device panel. The device type is correctly identified as “Remotec ZRC-90”, with deviceId: 34064 and manufacturer: 21076. The Hubitat software is version 2.3.4.138.

These are tricky to pair.

see here:Remotec ZRC-90 - discovered but nothing else - #13 by juergen

I’ve already seen that thread, as stated in the original post. It didn’t help.

Its not paired correctly as zwave plus as per your device info which is why it isnt working. You will have to follow that thread reset/exclude and re-pair it till your device info looks like what i posted

I had a thought about this - I have two of these Remotec ZRC-90s and I can't get them to activate buttons after pairing. An experiment I wanted to try was pairing them from close proximity to the hub so that an intermediate repeater isn't in the way. Sound plausible to you?

This worked, by the way. Proximity to hub matters.

1 Like

It didn’t work for me. I removed the device and re-added it in the same room as my Hubitat controller; after the device was added, I pressed some buttons and got the same results: the ZRC-90 led blinks rapidly and no events are detected by Hubitat.