Remotec ZRC-90 - discovered but nothing else


I've tried adding my new ZDC-90 about 15 times now. Always the same result - registration does not seem to finish, button presses only get the fast blinking on the ZDC-90 and no events on hubitat log.

Here is what I do

  1. reset the ZDC-90 - 10 seconds of holding R button, then when the led goes off triple click the R button
  2. put hubitat in z-wave discovery mode
  3. press L button on ZDC-90
  4. hubitat reports discovered device, I give it a name and save it
  5. the led on the ZDC-90 keeps blinking for quite some time (30 seconds?)

Anybody know what is going wrong and how I can fix it?

Here is what the logs show:
sys:12019-09-11 03:07:25.815 pm infoZ-Wave Discovery Stopped

sys:12019-09-11 03:07:25.307 pm infoZ-Wave Discovery Stopped

dev:2852019-09-11 03:07:25.302 pm infoRemotec ZRC-90 battery is 96%

dev:2852019-09-11 03:07:25.298 pm debugBatteryReport: BatteryReport(batteryLevel:96)

dev:2852019-09-11 03:07:25.289 pm debugparse description: zw device: 58, command: 8003, payload: 60 , isMulticast: false

sys:12019-09-11 03:07:25.233 pm infoZ-Wave Discovery Stopped

sys:12019-09-11 03:07:25.230 pm infoZ-Wave Device Discovered: Remotec ZRC-90

dev:2852019-09-11 03:07:25.189 pm debugrefresh

dev:2852019-09-11 03:07:25.177 pm infoRemotec ZRC-90 battery is 96%

dev:2852019-09-11 03:07:25.164 pm debugBatteryReport: BatteryReport(batteryLevel:96)

dev:2852019-09-11 03:07:25.160 pm debugparse description: zw device: 58, command: 8003, payload: 60 , isMulticast: false

dev:2852019-09-11 03:07:25.117 pm warnconfigure...

dev:2852019-09-11 03:07:25.085 pm debugrefresh

dev:2852019-09-11 03:07:25.039 pm warnconfigure...

sys:12019-09-11 03:07:23.818 pm infoInitializing Z-Wave Device : 58

sys:12019-09-11 03:07:06.817 pm infoZ-Wave Discovery Running

Since you have already reset it you can skip that part again.

What I did with mine is:

  1. remove batteries, wait 10 sec.
  2. install batteries and wait until led goes off.
  3. put HE in discovery
  4. press L on the unit
  5. wait for HE to finish discovery

After it is discovered then go to the device page and press W on the remote and immediately press Configure on the device page. In a few it should respond correctly.

Thanks razorwing. I did that. Same result and I believe just about the same log (see below).
Note, there are several "Discovery stopped" log entries. I didn't stop the discovery manually. Matter of fact I didn't touch anything for a minute or so - except entering a device name and hit save after the last log message showed up.

sys:12019-09-11 03:45:10.466 pm infoZ-Wave Discovery Stopped

dev:2862019-09-11 03:45:09.802 pm infoRemotec ZRC-90 battery is 96%

dev:2862019-09-11 03:45:09.799 pm debugBatteryReport: BatteryReport(batteryLevel:96)

sys:12019-09-11 03:45:09.792 pm infoZ-Wave Discovery Stopped

dev:2862019-09-11 03:45:09.786 pm debugparse description: zw device: 59, command: 8003, payload: 60 , isMulticast: false

dev:2862019-09-11 03:45:09.755 pm infoRemotec ZRC-90 battery is 96%

dev:2862019-09-11 03:45:09.751 pm debugBatteryReport: BatteryReport(batteryLevel:96)

dev:2862019-09-11 03:45:09.733 pm debugparse description: zw device: 59, command: 8003, payload: 60 , isMulticast: false

sys:12019-09-11 03:45:09.730 pm infoZ-Wave Discovery Stopped

sys:12019-09-11 03:45:09.719 pm infoZ-Wave Device Discovered: Remotec ZRC-90

dev:2862019-09-11 03:45:09.712 pm debugrefresh

dev:2862019-09-11 03:45:09.672 pm warnconfigure...

dev:2862019-09-11 03:45:09.661 pm debugrefresh

dev:2862019-09-11 03:45:09.616 pm warnconfigure...

sys:12019-09-11 03:45:08.474 pm infoInitializing Z-Wave Device : 59

sys:12019-09-11 03:44:57.468 pm infoZ-Wave Discovery Running

I don’t have “Configure” in the device page

I should have looked first. I assumed it would have Configure like all the rest. My bad. So have you tried to press a button and see if it changes on the device page?

A button on the ZRC-90?

Well, pushing any one of the 8 buttons on the front of the ZRC-90 results in fast blinking LED on the device an nothing on the hub - no log entry, no event on the device page, no discernible change.

Sorry for the delay. I have to ask the obvious. How close to the hub were you when you included it? It sounds like the hub is not getting all the info from the remote and therefore it is not getting set up correctly.
Have you done anything with making sure it is set up as a secondary controller? Secondary setup is done by holding W+R until the LED lights up and then release. I would exclude it and re-include it after setting it to Secondary.

I’ll try the setting to secondary before inclusion.
On the distance - less than a foot away.

I have a rather large network with about 60 devices if that makes a difference.

Number of devices won't matter. Also make sure your device type you have selected on the device page is Remotec ZRC-90. Let us know.

Nope. Does not work. It looks from the lock that the Hubitat does not finish the setup. The ZDC-90 keeps blinking in its discovery/learn mode long after the Hubitat logs discovery stopped.

So looks to me this is a Hubitat problem.

There was a question on the distance when including- less than a foot.

Bummer. I bought 4 of these and works with none of them. Going to return them.

Someone should update the supported devices list and remove the ZDC-90.

I am assuming you mean ZRC whenever you say ZDC. That being said, I have had this working since day one and many others have as well. It was a PITA to pair but many have gotten it working with a little vigilance. Removing it from the supported device list would be partially inaccurate.

Have you contacted support on this? May be @mike.maxwell can be of assistance as well. I remember he posted a step by step on pairing these somewhere in the forum.

@stephack - thanks for your reply. You’re of course right about the model being ZRC.

I’d really like to make these work. I’ve tried more than 20 times with more than one (I had ordered 4) and always the same result.

If others got them to work I would love nothing more than learning how to get that done.

@mike.maxwell - can you help?

@juergen I read some more on this device and there are 3 things that I see that may be why it doesn't include. You may have tried them but maybe there is a slight difference in the procedures.

  1. Did you check the slide switch in the battery compartment and make sure it is in the OP direction.
  2. The Reset for this is a little tricky. I read that before inclusion the device batteries should be removed for 20 sec. and then re-installed. Then hold down the R button, and here is the tricky part, the LED will go ON for 5 sec. then it will go OFF at the 10 sec. mark, as soon as it goes OFF they say to click the R button 3 times within 2 sec.
  3. Then they say to put the hub in include mode, within a foot or so, and press the W button, wait till LED goes out, followed by the L button once. The LED will blink slowly for a bit until it finishes being included and then will go Off. If it flashes 6 times fast it has not included correctly and to try again to include.

That's all I know to tell you. Good Luck.

1 Like

Check this post

And this one

1 Like

@juergen look what the cat dragged in.
@bobbyD just posted in a new thread (and via Twitter ) the reset joining processes of compatible devices. Apparently it is part of the hubitat docs. Thanks for the link @bobbyD.

1 Like