ZRC-90 not registering button presses

Just got around to adding my ZRC-90 to Hubitat. It looks like it was properly added:

But when I press any button, the press is not registered:

Events are getting generated though, same three lines no matter which button I press:

It looks good to me. I originally set this up with a custom driver and moved over once it was available officially through Hubitat. Normally I would advise to hot the Configure and save buttons but they don't seem to exist in this driver. Hopefully @mike.maxwell can chime in.

Yup, just found and fixed this problem yesterday. :frowning:
Patch will be in the next release, best bet is to remove it for now as it's in a state that an update won't fix until the device is re joined.


Haha....talk about record response time. :slight_smile:

1 Like

So glad about this, its been driving me nuts!

Glad I'm not crazy! :grin:

I will remove it right now...

Has this update been pushed? I'm having the same problem

So far I've reset the zrc-90
Hit L to put it in pairing mode
hit discover devices. It finds it ok, then joins it no problem
I can see all the device attributes but it will not pay attention to any button presses
I've tried using both steph/eric's and the hubitat drivers

Anything I'm doing wrong? I'm migrating from a ST environment and have about a dozen of these.

Stupid question but did you exclude or reset before pairing? I had a right time with mine before I realised I was hitting the wrong button d’oh.

That said, once I’d paired properly it’s been great.

Do you see anything in the logs when pushing the buttons?

reset it, couldnt exclude because the hub was bricked :frowning:

1 Like

How about the logs, anything showing?

Just double checked, nothing :frowning:

Yeah. That’s very odd, seeing as it’s reporting it’s paired. Are they all like that, or is this the first one?

My Remotec does not report anything in the logs when pushed and it works fine. I believe that's how the driver was built. Do you have the buttons associated with any Button Controller apps...or any apps for that matter?

Even stranger then, just checked mine and it’s logging all buttons used. Although I do have Enable descriptionText logging selected.

thats how the logging option works, the preference settings for logging do not effect the device events, its just as easy to look at the current states in the driver details when pushing a few of the buttons, these are the events that are generated.
The output to live logging is simply a convenience.

1 Like

I did, I had a couple button controller routines built, but they wouldn't respond

tried re-pairing got this

Manufacturer: 5254 Product Name: Remotec ZRC-90 Model Number: Unknown Part Number deviceTypeId: 50

Here's what my Data fields look like.

I also remember having difficult getting this sucker to pair properly. I had to pair within 2 inches from the zwave stick and left it for a minute or so.

I had real issues on the second attempt of pairing, after having to factory reset the hub. New batteries and having the device very close to the hub seemed to resolve it. My settings are identical to @stephack, apart from devicType, mine is 1 . Is it possible the device itself has gone bad?