[RELEASE] IKEA window roller blinds

I personally found the included Ikea smart outlet to be a fairly poor repeater when paired directly to hubitat. To be fair, the blinds worked perfectly for about a year with no repeater nearby at all before they began dropping from the Zigbee mesh. I suspect it's due to some nearby 2.4ghz interference.

After a few weeks of fiddling with the Ikea repeater I ended up just picking up a cheap little Securifi Peanut Smart Plug from Amazon for around $15, paired it to hubitat and placed it in an outlet directly below the 3 Ikea blinds in my Master Bedroom - It's been about a month now & since then they have been solid as a rock.

1 Like

The Ikea repeaters make great repeaters in hubitat. I have even purchased a few more to dot around the house.

I just added one of the repeaters to Hubitat using the reset hole, do I need to do anything else to get Hubitat to use it as a repeater?

If you see it on the Device list and driver type is IKEA Tradfri Signal Repeater, I don't think you need to do anything else.

1 Like

Hitting the configure button resolved the issue of the blind randomly not responding to rule triggers. Thanks!

Is there a way to have groups of these respond to the "open" and "close" commands through Alexa or am I stuck with "set shades to 100%?" I didn't have any luck trying switching the group device to Virtual Shade type, but maybe I missed something. Thanks!

There might be a better way, but I created a group and added the shades as dimmers. I can now tell Alexa to "Turn on study shades" to open and "Turn off study shades" to close.

image

I have the same group thing setup. Setting it to a percentage works fine with voice commands. I didn't know to try off and on for open and close. Thank you for that!

I was just hoping to use more natural language which works for the individual shades, just not when they're grouped.

So I updated the firmware on one of my Fyrtur shades and a handful of the open/close buttons they come with and wanted to share my findings
(Firmware dated 6/5/23 - Release Notes)

  • The shade now reports battery as 200% (after about 2 weeks it dropped to 199%). I tried hitting the configure button, factory reset/re-pair multiple times with the same result. I assume the device code could be modified to address this
  • The batteries in the buttons never lasted more than 24hrs in the past so I never used them. After the update I now have 9 paired without any obvious battery issues going on 3 weeks. Oddly some of the buttons report battery at 100% while others don’t report it at all.

I think there’s a real possibility that the buttons might be a reliable option going forward….we will see how long they last

1 Like

I was able to fix this for my blinds by replacing line 104 and 105 of the blind driver to (make sure to back up your driver by making a copy of it before making changes):

if (debugOutput) log.debug "attr: ${descMap?.attrInt}, value: ${descMap?.value}, descValue: ${(Integer.parseInt(descMap.value, 16)/2)}"
            sendEvent(name: "battery", value: (Integer.parseInt(descMap.value, 16)/2))
3 Likes

I'm having this same issue since updating.

I'm also seeing the blinds break Homekit integration after this update. Still investigating, but I think the blinds are now seen as the "accessory out of compliance" Maybe because of the battery reporting?

Thanks for figuring that out. I will note that for me it was line 105 and 106, plus I had to remove the "Preformatted text" from the end of your code in order for it to let me save.

Also note for other implementing this, you need to hit "refresh" on your blind device page before you'll see the updated battery number.

1 Like

Thanks for that. Oddly, it was lines 103 and 104 in mine and I thought I had the latest, but doesn't matter. It's easy to locate the two lines needing the "/2" and new parens.

1 Like

Hope it helps others searching for knowledge: I also updated 7x Fyrtur blinds to latest FW (24.4.13) and had two problems. 1) 200% battery reporting and 2) Rejoining the blind to Hubitat C8 would not complete. The hub would hear the blind in pairing state but never progress past initializing (so that I could name it, etc) and blind itself stayed in slow blink pairing mode until timeout. Tried a million things, including pulling a blind down and placing it immediately next to the hub to pair but the ultimate fix was to reboot the zigbee radio with power level 16 (was 8). Suddenly all near and far blinds paired quickly and i could get rid of a few repeaters as well.

Noted above, but in case you want to resolve in the driver.

Hopefully someone smarter than me can have the driver detect firmware version and have the battery report correctly on older drivers. Till then, this tweak makes them report properly.

how do I reset the closed position length? I want to have it go down an inch longer than it currently does and when pressing the down button it stops at saved closed position and wont go further.

Do i have to reset them?

You should be able to push the down button and have it continue to its desired length, which you then save by pressing up and down simultaneously.

Since you say that isn't working, are you sure it isn't already at its maximum length? If that's not it, I'd suggest doing a hard open (from the device page) to calibrate it at fully open 0%. Then try again. If all else fails, factory reset it (although the method to do that escapes me at the moment .. perhaps remove battery for a while).

I am not able to bind my blinds to my C8. I had to bind them to my older C5 .. I think it's an issue with the new Zigbee

I had mine drop off (C8) and had to bring them very close to the hub to pair correctly.

1 Like

I will try that.. , its a bit of work, but right now keeping them on the C5 is fine(ish) but thank you

1 Like