[GUIDE] IKEA Firmware Updates

Just updated my IKEA signal repeater from 23070631 to 23086631.
The update took 5 minutes, there was no need to reset or re-pair the device.
There were no changes in the device repeaters and routes records after the update - I am using this driver :


Not sure why I had so many issues, or maybe I just updated too many devices one right after another. (4 tradfri outlets, and 2 repeaters). Either way, it's happy now.

But that driver looks interesting. Gonna bookmark it for later.

1 Like

Have you tried updating these? I have a bunch myself and was looking for more info as to whether or not it’s supported.

Update: updated about a dozen repeaters (came with my blinds) and it all went really well and very quick. I’m in the same room as my HE hub. Directly above the hub on my second floor is my bedroom and one of those blinds. I’m able to update it OTA but it’s SUPER slow—about 10% every 8 minutes or so. It could be distance related so I might bring another blind down next to it and if that’s the case, just temporarily relocate the hub in my bedroom.

Update #2: The update worked, however I’m seeing some strange battery level reporting for the Tredansen Blinds. They’re reporting battery percentages inthe 100s. I think it’s just adding an extra 1 in front of the typical levels so instead of 90%, it’ll read 190%. I’m also on the IKEA Window Blinds driver after switching back from DEvice to update them.

1 Like

not yet :joy:

1 Like

I believe it's because the repeaters are mains powered and so not bothered by power availability, while the blind is on a battery, and is deisgned to conserve power in operation, thus slower in intensive load (like fw update)

1 Like

They values are now doubled. Here’s how to fix it in the driver: [RELEASE] IKEA window roller blinds - #226 by craigspree

1 Like

Thanks. Will investigate later. I’m assuming we’re all likely on the same drivers.

Not sure if anyone else is experiencing this, but I’ve tried adding two E1745 Motion Sensors bought at the end of 2022 via the pairing instructions and both of them are detected as “E1766” Open Close remotes instead. I tried switching the drivers to the correct ones but these do not function.

Wondering if anyone else has any workarounds.

On HA, they import properly BUT I’m having issues trying to update the drivers OTA with it using Zigbe2MQTT (failing.) Was hoping the HE method would work for them as I’ve had pretty good success with this method so far.

UPDATE: Corrected the model of sensors to E1745. I reimported them into HA Z2M and tried the OTA but it reports them as "up to date." So they are current, but when I try to reimport them into HE they're still showing up as E1766 automatically. Switching to a supported driver doesn't work either.

UPDATE 2: Uninstalled Dan's driver for E1766 using HPM after switching my one paired Ikea button to plain "device" temporarily. Retried the Zigbee pairing for E1745 and it found it as empty. Gave it a generic name "IKEA Motion Sensor." I switched to the E1766 driver and hit "update firmware" while hitting the three buttons sequentially from left to right while counting 1, 2, 3 and now the logs are showing up as "updating firmware" after finding a newer version. ALSO, this was performed on a different floor away from my HE hub. So apparently you can update it and you don't have to be right on top of the hub.

1 Like

@dandanache: Thanks again for the link to this thread. Haven't seen it before. Thanks also for the very detailed instruction. One question came up. When I tried to update an E1524 yesterday, I haven't seen any log entries like "Starting firmware update for.....". As you wrote, it can take some time until I see the first entry with 10% progress.
How long does it usually take until the update starts and what to do that the battery powered device isn't going back to sleep. Yesterday I tried to press any button every second for 10 minutes.....

Thanks again for any help

1 Like

Battery powered devices love to sleep, it is their natural state. They wake up only in the following scenarios:

  1. Some of the devices wake up periodically to check with the coordinator (hub) if they have any "mail / messages".

  2. When they need to send something to the coordinator (button was pressed, motion was detected, contact was opened/closed, basically doing their other primary job -- aside from sleeping, of course).

  3. Immediately after they are powered up (remove and insert the batteries) they need to sync with their parent and/or the coordinator and announce their presence.

In all of the scenarios above, after they get what they want, all battery-powered devices want to go back to sleep - but they will keep staying awake for about 3-5 seconds, so this is your receiver window of opportunity.

On the other side of the transmission, when you press the "Update Firmware" button (actually after you dismiss the warning popup), the hub will try to send the update command to the device. There are 2 scenarios:

  1. If the target device is awake (you are within the receiver window of opportunity) -> message is delivered and received, all good!

  2. If the target device is sleeping -> the message is kept by the coordinator for about 7 seconds (the transmitter window of opportunity). If the end device wakes up in this interval, the message is delivered and received, otherwise it will be discarded.

Please note that after it receives the firmware update command ("Starting firmware update for ..." appears in the logs), the device will start to download the file from the coordinator and will not go back to sleep until the update is done, so you do not need to keep pressing any buttons during this period (about 100 minutes).

Hope this help you get into the mind of the little buggers! :slight_smile:


Thanks, @dandanache for the very detailed description and all the hard work on this.
Following your Update description and considering the technical explanation in your response, I tried to update on E1810. I never used this button device before. Bought it long time ago, never used it and it started immediately to receive the update. Will se if it goes through to 100% but currently it looks promising.

Will try the older one and already used E1524 tomorrow. Maybe it will work as well. Now I know thanks to your description how it should work.

Thanks again for all the help :slight_smile:

1 Like

117C-11C4-24040005`|TRADFRI Motion Sensor. I picked one of these up at Ikea in the markdown section. The box had a note about it being an outgoing product. When I first paired it the device selected was the On/off switch E1743. Changed to the correct Motion sensor E1745. Didn't see any motion events after configuring it. Tried the Firmware update and it worked after pressing one of the buttons in the back. After re-pairing the device and configuring I had motion and illumination states.


I have three Ikea wireless dimmer pucks that have different firmwareMT values. Two are white and the other one is black

117C-11C2-23028631|TRADFRI Wireless Dimmer|[ICTC-G-1] - Black puck
117C-11C2-12248572|TRADFRI Wireless Dimmer|[ICTC-G-1] - White pucks

The two white pucks are on softwareBuild: 1.2.248 and work with IKEA Trådfri Puck driver by Joel Wetzal. When I updated the black puck to softwareBuild: 2.3.028 the IKEA Trådfri Puck driver stopped working.

1 Like

Update the E2123 successfully :+1:

Took 90 mins, no re-pairing needed

1 Like

FYI as of this writing the "current" firmware for the Rodret Dimmer E2201 is the release firmware and there is no update available.

"Firmware update for Rodret Dimmer, IKEA of Sweden 117C-11CD-01000047 is not available."

1 Like

@kkossev: How did you update your IKEA signal repeater? The IKEA repeater driver does no have any update button. Did you use the Zigbee Monitor Driver for that?

1 Like

I used the HE inbuilt driver ‘Device’ temporarily for the update.


Just tried it but no update right now. Maybe I have to move the repeater closer to the hub.

1 Like

I updated it in-place... What you are seeing in the live logs - 'Hub'? You may be already on the latest firmware version?

1 Like

I'm currently on firmware version 23079631. This is the only once which the older firmware version. My others are on 23086631.

When I change the device type to "Device" and press the "Config" button, I get the following message in the live logs:
getting device info in 10 seconds...
getting info for unknown Zigbee device...

After pressing "Update Zigbee Firmware" I don't get any update related entries.

1 Like