[RELEASE] Aqara FP1 Human Presence Sensor (RTCZCGQ11LM)

This is a new thread for the Aqara FP1 Human Presence Sensor, which is supported by the Aqara P1 Motion Sensor driver initially published here. As this driver supports several different models of Aqara motion sensors, mixing the updates and the comments for the different devices is somewhat confusing for most of the forum users, so it was decided to split the initial thread into several individual new threads.

The recommended method for installing this custom driver is to use the community Hubitat Package Manager (HPM), search for "Aqara P1 Motion Sensor" or by Tag 'Zigbee'.

For manual installation, the last stable version code is here: https://raw.githubusercontent.com/kkossev/Hubitat/main/Drivers/Aqara%20P1%20Motion%20Sensor/Aqara_P1_Motion_Sensor.groovy

Device Links
Aqara FP1 Human Presence Sensor RTCZCGQ11LM
image
model:"lumi.motion.ac01"
Power supply: 5V USB
Supports: approach distance, monitoring mode, motion sensitivity, power outage count, presence event, reset nopresence status, presence
Aqara site (in Chinese) : link
Manual (in Chinese): link
Review: link

AliExpress: link1
AliExpress: link2
AliExpress: link3
AliExpress: link4
AliExpress: link5
8 Likes

Versions history

3 Likes

Reserved post #3

Aqara FP1 radiation pattern:

2 Likes

@kkossev,
Thanks for this, the driver has been working fine for the last 4 months without any issues.
Just curious, is there any reason why the FP1 does not show up in the Zigbee Route info table?
Note that Aqara P1 is now showing up in the routing table.
Thanks

1 Like

If I'm not mistaken, that's dependent on your Zigbee mesh not the device nor driver. If your FP1 is going through a router that's using another router to get to the hub, then it will not show up.

1 Like

This driver has been working great for me the last 3 months.

1 Like

Thanks for your reply.
I have some smart plugs setup as repeaters. The only device I have not seen in the routing table seems to be the FP1 and some button controllers ... so not sure how they are repeating exactly.

Routing table

Aqara FP1 is not a Zigbee router.
On the positive side, this limits the device power consumption and allows it to eventually run on a USB battery pack.

1 Like

Could anyone that has succesfully paired this device give me some pointers as to the proper order of steps? For context, I have just paired 5 Aqara door/window contact sensors without a hiccup and apart from that have about 30-40 other zigbee devices, among which about a quarter Aqara devices, all paired without a hiccup. This FP1 sensor though, is discovered and hubitat says it is initializing it but then the countdown just runs out and it is not paired. I have tried resetting first and then starting pairing, I have tried starting pairing and then resetting. Nothing. The FP1 is so close to my zigbee dongle it almost touches it. I have 4 (Ikea) repeaters spread throughout the house and so far my zigbee mesh has been rock solid, not a single device disconnect in about 1.5 years. I don't understand what's going on, this is the first device that is giving me these kinds of problems. I hope someone can help :grinning:

edit
I realize now that this might not be the proper thread for questions such as this. Apologies if it isn't, I will repost in the proper thread then

@tomplessers
What zigbee channel are you using?
One of my hubs on channel 21 had a hard time pairing to.

I'm currently on channel 20

Hi @tomplessers ,
This is the right thread for discussing any issues with Aqara FP1 sensor.

When pairing to HE, can you monitor the Zigbee logs ( Settings -> Zigbee Details -> Zigbee Logging) in a browser tab?
Do you see any unknown device there?

Also, I suppose you have already tried rebooting the HE hub first? I have had similar strange issues (with other Zigbee devices) resolved when pairing right after the hub was rebooted.

Two unknown entries appeared in the log during pairing, with confirmed "found a zigbee device" displayed by the hub but countdown expiring without pairing completed. These are the two unknown entries:

00002023-01-14 17:22:07.537 profileId:0x0, clusterId:0x8038, sourceEndpoint:0, destinationEndpoint:0 , groupId:0, lastHopLqi:255, lastHopRssi:0
E8052023-01-14 17:21:56.730 profileId:0x0, clusterId:0x13, sourceEndpoint:0, destinationEndpoint:0 , groupId:0, lastHopLqi:255, lastHopRssi:-27

Most probably this E805 is the FP1 device... If you look back on Settings -> Zigbee Details page and search for "E805", do you see any device? if such exists, you can click on the device name link ..

This still doesn't explain why the Zigbee pairing process does not finish.

No, it is not there. I went over the list and all devices there are known to me, so it isn't listed under another ID either

You could also try moving the hub to a new location away from any other electrical device that maybe causing interference.

It is next to the TV so I will try moving it. I didn't have problems with interference in the past but that doesn't mean it can't happen at all. I will report back after trying that

Added info: I have a second FP1 sensor and it displays the same behavior as the first, I can't pair it

If you are not using the Aqara P1 driver for any other devices, you can temporarily delete the custom code to eliminate half of the unknowns.. then reboot the hub.

The FP1 must first pair stable to HE as a ‘device’.

It is now at least two meters away from the nearest electrical device. I have also made sure to put the zigbee dongle as far away from the hub as the cable allows. Same behavior. Would you advise me to try changing channels? If so, which one worked for you? And, are there any things I need to be aware of concerning my existing mesh, apart from the fact that it will take a long time to propagate? Devices dropping out of the mesh completely, devices not compatible with another channel, more interference on other channels,.....? Apologies for the questions, my technical knowledge of zigbee is pretty limited. Thank you for the help so far, I appreciate it

Understood. I am not using the driver for anything else, I have just added it today. I will try removing the driver and adding the FP1 as a generic "device" and report back. Thank you for the help so far, I appreciate it

1 Like

Download the Hubitat app