[RELEASE] Hubitat Package Manager -- HubitatCommunity

A 1.8.7 version has been pushed to HubitatCommunity. fixes an Update bug

Follow the Hubitat Package Manager installation instructions here for step-by-step:
https://hubitatpackagemanager.hubitatcommunity.com/installing.html
OR, use this Import URL:
https://raw.githubusercontent.com/HubitatCommunity/hubitatpackagemanager/main/apps/Package_Manager.groovy

Original topic:

Documentation has been created at:
HubitatPackageManager Documentation

38 Likes
Hubitat Package Manager (HPM)
[BETA] Hubitat Package Manager
Getting Started - Building a solid foundation
[RELEASE] Rachio Community (with irrigation dashboard!)
[BETA] MowBot Tamer
[RELEASE] Zemismart Zigbee Blind Driver
webCoRE for Hubitat Updates
[RELEASE] Tuya Scene Switch TS004F driver
New User
Migrating from Smartthings
New Aqara Zigbee 3.0 occupancy sensor (FP1) looks interesting
[RELEASE] Tuya Zigbee Multi-Sensor 4 In 1 (PIR motion sensors and mmWave presence radars)
[RELEASE] Tuya Wall Mount Thermostat (Water/Electric Floor Heating) Zigbee driver
Are you new to home automation or Hubitat or coming from a different platform such as Wink, SmartThings or Vera? This may help!
How to Install Device Watchdog
Support for Bond hub
Help please im so lost
[RELEASE] Zemismart Zigbee Blind Driver
Package Manager Error
Smart Home Novice - Where to Start?
Aeotec Multisensor 6
First Days Migrating from Wink to Hubitat, Successes, Failures, and Solutions to Help Others…
Exhaust fan turn on "if" humidity is higher than Thermostat
Sonoff Motion Sensor [Working]
[RELEASE] Xiaomi Aqara and Mijia Drivers with Device Presence
[RELEASE] Xiaomi Aqara and Mijia Drivers with Device Presence
Aqara FP1 and P1 motion sensors
[RELEASE] WyzeHub - Wyze Device Integration (minimal cam support)
[RELEASE] Tuya Zigbee Metering Plug
[BETA] Hubitat Package Manager
MyQ Lite Device Integration
Broadlink IR/RF remotes integration (RM3 Mini, RM Pro, RM4 Mini/Pro)
[RELEASE] Beta 1 - version of Honeywell Home Thermostats (Lyric etc...)
[RELEASE] Sabbath/Holiday Mode Scheduler
Aqara FP1 and P1 motion sensors
Struggling to install Event Engine from BPTWorld
Recommendation on a 4+ buttons remote/switch
About Hubitat Package Manager
[RELEASE] WyzeHub - Wyze Device Integration (minimal cam support)
Where to start?
[Help needed] Fibaro FGK-10x z-wave Door window sensor temperature reporting

Screen Shot 2022-06-10 at 11.36.00 AM

Adds an Un-Match feature to help with Developers that reorganize their code repos. For most, it's a feature that might never get used. Ordinary installs should never need this feature, and it should also be said that it only does half of what might be needed. Usually a Match Up would follow.

1 Like

Just tried the upgrade and get error


Thx

I believe you but this is what I got when I did the upgrade from Dominic's 1.8.2 to 1.8.3:

app:795 2022-05-28 10:24:31.203 am debug Updates complete
app:795 2022-05-28 10:24:24.435 am info  Upgrading Hubitat Package Manager
app:795 2022-05-28 10:24:24.060 am info  Downloading Hubitat Package Manager
app:795 2022-05-28 10:24:23.711 am debug Performing update
app:795 2022-05-28 10:24:21.371 am debug prefPkgVerifyUpdates
app:795 2022-05-28 10:24:19.911 am debug Updates available
app:795 2022-05-28 10:24:15.378 am debug Updates available
app:795 2022-05-28 10:24:14.440 am debug Updates found package for https://raw.githubusercontent.com/dcmeglio/hubitat-packagemanager/master/packageManifest.json -> null (force production: true)
app:795 2022-05-28 10:24:14.437 am debug Updates found for package https://raw.githubusercontent.com/dcmeglio/hubitat-packagemanager/master/packageManifest.json
app:795 2022-05-28 10:24:14.357 am info  Checking for updates for Hubitat Package Manager
app:795 2022-05-28 10:24:13.334 am info  Checking for updates for Honeywell Thermo Parent
app:795 2022-05-28 10:24:13.206 am debug Update chosen

I'm going to delete, go back to DMeglio 1.8.2 and try again...

It proceeds w update, one more error and several manifest errors

Those are in fact, manifest errors that the app owners should fix. The updated Master Manifest on HubitatCommunity has a corrected entry for one that I found and fixed. The other will need to be corrected by the owner.

I was not able to reproduce the error. Again, no disbelief, just recognizing I must be clicking differently :smiley:

An obvious 2nd option to upgrading is just Repair. That copies the same (1.8.3) HPM from either repo. :slight_smile:

Repair seems to be clean
Thanks

FWIW, I got the same error on both my hubs as @starcom.

However, the update was applied. Also, to be complete in the information I've provided, I updated from your version 1.8.2A to 1.8.3.

1 Like

Ah... 1.8.3.A might be the culprit, I did that upgrade test last night and didn't see that error. I can try it again though :slight_smile:

If you're feeling unsure, give Repair a shot, just to get back to: sure.

Just retested and got no error but the repos aren't in the same states when I do a delete-reinstall. Your copy is already "running" with an old list of Manifests. When I delete and reinstall, there are no manifests and so it picks up the 1.8.3 set. So.. no error.

I think the One/Two Punch of an Upgrade and/or a Repair will cover most situations.

2 Likes

Updated, seemed to go fine.
Thanks

2 Likes

Same here, two hubs and both had the error. As far as I could determine I was upgrading from 1.8.2, and not 1.8.2A.

1 Like

Simply FYI I got a different error when updating. My production hub is a C-7, and it updated fine. My C-5 dev hub, when an update was attempted, hung on Installing updates. Doing a repair of HPM went fine and fixed things on the C-5:

Both running 2.3.1.142, both started the update with HPM 1.8.2 from Dominick Meglio’s repository, both now at 1.8.3.

1 Like

I got the same error as starcom did a repair and all seems fine. C-5 hub coming from 1.82.

1 Like

There's a pattern, but most errors have different line numbers. I have to think it's HPM updating itself while it's running... (method performUpdates) is common to all the messages.

I think the pattern of doing a Repair after is probably best.

4 Likes

Updated for me with out any errors at all on both hubs.

1 Like

C7 hub here and it failed (hung forever). But a repair seemed to set things right. Of note I am a Beta tester currently running: 2.3.2.118. I only share that for troubleshooting purposes not to disclose any Beta details...

Same. C7. HPM showed there was an update (for HPM), I've ran it and it's just stuck on the below screen for 10 minutes now:

If you see the

It won’t finish, just go to repair at that point.

3 Likes

My hub update also froze, but seems like the update was completed and now runung 1.8.3.

Error Log
app:32022-05-29 13:52:18.522 debugInstalling HPM Manifest
app:32022-05-29 13:52:18.217 debugGrabbing list of installed apps
app:32022-05-29 13:52:17.904 infoA new repository was added, https://raw.githubusercontent.com/GaryMilne/Hubitat-Tasmota/main/repository.json
app:32022-05-29 13:52:17.899 infoA new repository was added, https://raw.githubusercontent.com/danTapps/Hubitat/master/repository.json
app:32022-05-29 13:52:17.893 infoA new repository was added, https://raw.githubusercontent.com/Vyrolan/iAqualink-Hubitat/main/repository.json
app:32022-05-29 13:52:17.889 infoA new repository was added, https://raw.githubusercontent.com/dlaporte/Hubitat/main/ASH26/packageManifest.json
app:32022-05-29 13:52:17.878 infoA new repository was added, https://raw.githubusercontent.com/sky-nie/hubitat/main/repository.json
app:32022-05-29 13:52:17.457 debugRefreshing repository list
app:32022-05-29 13:44:07.149 errorjava.lang.NoClassDefFoundError: user_app_dcm_hpm_Hubitat_Package_Manager_99$_copyInstalledItemsToNewManifest_closure86 on line 3572 (method performUpdates)
app:32022-05-29 13:43:43.718 infoUpgrading Hubitat Package Manager
app:32022-05-29 13:43:43.273 infoDownloading Hubitat Package Manager
app:32022-05-29 13:43:42.593 debugPerforming update
app:32022-05-29 13:43:36.720 debugprefPkgVerifyUpdates
app:32022-05-29 13:43:34.998 debugUpdates available
app:32022-05-29 13:43:30.907 debugUpdates available
app:32022-05-29 13:43:12.396 debugUpdates available

My main hub HPM went smoothly:

Updates complete
The updates have been installed, click Done to continue.

Great work with transferring the HPM to HubitatCommunity repository @csteele , thank you very much!

2 Likes

Yeah I've done that - all up and running again now - thanks.

Download the Hubitat app