Release broke Schlage locks?

@bcopeland or @bravenel,

I noticed my Schlage BE469 lock was not responding to commands earlier this evening. Am on release

Looking in the logs I only saw this when I tried to lock or unlock the lock:

I rolled back to and the lock is working again.

Anything I should try?


1 Like

We have two of those locks (with Aeotec 6 repeater within a few feet of hub & also within a few feet of each lock), no problem on any of the 2.2.2.x releases including

1 Like

I have the same lock. Same issue. No communication whatsoever. Rolled back and it works again. They're working on it.

1 Like

Perhaps it’s a lock firmware issue. Our two locks are BE469NX, Firmware MAIN_7.1, C-5 Hubitat.

try changing to a different driver then change back.
I'm not at home so I can't do it, but it was a thought


Once upon a time a change was implemented that broke my schlage zwave functionality. Sounds like what you guys describe. At the time chuck tracked it down to a reduced time-out setting. I was the only user reporting the issue.

Speaking of chuck. What happened to that guy?

There is the thread. I don't know if it is same issue or not. Just thought I'd add it in case it was useful.

The update caused my 469 locks to stop working. I rebooted my hub and they started working again (at least for the time being). Perhaps an easy fix?

Same issue. I tried rolling back - only had options for and - still nothing.

I'll get a battery update, but the locked status has not changed. No other communication with the lock seems to be working.

tagging @bobbyD and @mike.maxwell

I fully recognize that this is low priority given:

  1. Officially these locks are no longer supported
  2. There's likely an overwhelming amount of feedback coming in from Wink and other platform migrations and the C-7s getting into the market

Just wanted to make sure y'all saw some of folks were running into issues (potentially) with the Schlage 469s after the update

As always, we appreciate all you do!

1 Like

Nobody likes to hear this, but I haven't had any problems with any of my 3 Schlage locks. I just tried all 3 to verify.

I rolled back to an earlier release and my lock worked. Reinstalled the update and the lock has continued to work so fart........ will continue to monitor it.

A quick idea to try for your lock after you update to latest release. Although we were unable to replicate, some users had success restoring functionality of the lock by changing its type to "Generic Z-Wave Lock", then hitting update and then switching back to the Schlage driver (clicking update and following up by clicking "Configure").


So I was on, and my Schlage lock worked perfectly. Upgraded to and could not lock/unlock from the Device page or a Dashboard tile. Rebooted the Hub - with same result. Rolled back to .116 and it worked 100%. Upgraded to 129 again, with the same problem - lock is now non-functional.

Bottom line - one of the upgrades/hotfixes between 1.116 and 2.129 broke my lock functionality. Please resolve.

Did you try what @bobbyD recommended in the post above yours?

I think (not 100% sure) that @april.brandt got her Schlage locks functional with using the process outlined by @bobbyD.

1 Like

Thanks for the suggestion. I tried it multiple times, with no success. Even the Events and Logs show nothing - no attempt/hanging/delay. Just zilch.

That's really unfortunate. It seems to be mesh and/or firmware dependent because @bobbyD said that Hubitat engineers were unable to replicate the issue.

No I don't buy that. Nothing changed in the Mesh and/or lock firmware from 1.116 to 2.129. I can replicate the issue at will by rolling back/upgrading between the two releases. This is a classic example of HE upgrades breaking something else, and is the reason why I do not upgrade the moment a new release is put out, since it will invariably be followed by x number of hotfixes . . . :frowning:

I'm in the process of moving from SmartThings to Hubitat and I have 2 of the Schlage BE469's. I am on and while I did have some issues with lock code manager that was my error (with a bad error message that made it take awhile for me to figure out) I have moved 1 of the two locks off of ST successfully. I'm migrating devices out from the center of the house so that last lock will be a bit before I get to the last one.

You might try resetting the lock totally and pair it back again dunno if that would make it worse or not.

I don't buy this either. The lock has been working fine for an extended length of time through multiple upgrades - until the most recent - so I fail to see why I should try an resolve something that HE broke. As I mentioned above I can replicate this issue at will by switching between the releases, and it is clear that an upgrade broke it. Yes, Schlage locks have been known to be problematic, but - as I mentioned - mine has been working fine for a long time. So Hubitat needs to provide a hotfix and/or correct whatever it is they broke . . . .

@flotsam1 I have a schlage BE469 on .129 and it works fine. The symptoms mimic that of a weak mesh. If it was working PRIOR to the update, all you have to do is swap the driver to a generic driver/save/configure then swap back to the built in driver/save/configure. I rebooted my lock and gave it a spin a few times manually after doing so and it started communicating. It's a tiny bug that's not on the list just yet because there are much bigger issues.

I worked directly with HE staff, and can confirm this works, but my lock was rock solid PRIOR to the updates. I have 3 Z-Wave locks, 3 repeaters, lots of mains devices and my mesh is stable and solid.

1 Like