Orbit Hose Timer unresponsive

Recently I acquired one of the zigbee Iris Orbit Hose Timers.

It is paired to HE, using the native Orbit Hose Timer Driver.
It is controlled using Simple Irrigation.
I've placed a Sonoff 31-Lite plug, which is supposed to function as a zigbee repeater, on the other side of the wall from where the Hose Timer is installed, so through the wall and about 3' away. There is also a Sylvania Zigbee bulb that is supposed to function as a repeater about 5' (and through the wall) from the Hose Timer (however since the plug is there, the bulb goes through the plug...).

The problem is that about 80% of the time, I get the notification "Hose Timer didn't open after x tries. Please CHECK device"

  • The device screen shows the icon to indicate it is paired.
  • Every time I go to Settings/Zigbee Details/View Device Graph, the Hose Time is initially NOT there, but after 8-12 seconds, it shows up. However, it NEVER goes through either of the nearby repeaters - it always shows connected directly to the HE.
  • The app has the option to set the number of tries, and I had it bumped up to 6 tries. Per the app logs, it tries to open it, then waits 20 seconds, then tries again. The log indicates that when set at 6 tries, it actually tries 7 times...

What am I doing wrong, and what can I do to make this Orbit Hose Timer connect more reliably?
Or should I just get a different timer?

If possible, unplug (remove) the Sylvania Bulb for a few days. I don't think they are good repeaters and will screw things up even when not repeating thru them. My zigbee mesh improved quite a bit after getting rid of them.

I've had one of these for several years. When I moved from the C5 hub to C8, even though it paired it became problematic over time. It would pair and work for a short time and then became sporadic. One of the tell tail signs is the time on the device doesn't update. I spent a great deal of time trying to get it to work. I tried using different zigbee channels, I even paired it to another C8 by itself (no repeaters) and it still wouldn't work correctly. I finally brought out one of my old C5 hubs and it paired up and it rock solid, and has been that way for almost two months now.

1 Like

@an39511
I really appreciate this info. My worst nightmare is getting all excited about a platform upgrade and running into something like this (that gets few folk reporting on it).

I have relied on THREE of those on a C5 through the growing season for a number of years now and it's worked perfectly.

To @calinatl - which hub version and software version are you on? I would not have said any of that mattered had it not been for the @an39511 post above. Oh, and which driver are you using?

I can tell you that one of the furthest connected Orbit's I have tended to go for that direct line to the hub even tho there is at least one repeater along that same line. Others of the group do hop on repeaters. As usual ... it never seems to be logical.

If you are trying to get this to work within 50 feet of the hub and no big metal is in the way...make sure your batteries are fresh for the season (I'm using Li-ion) and follow the advice you've been given to get any sloppy/lazy repeaters out of the way because you should be able to get these to work. I run them closer to 75'.

I'm using a C7 hub...

Per this thread, everyone has that issue because the driver sends GMT to the Orbit rather than local time:

This thread indicates it is something introduced on the HE firmware in 2021, as they displayed the correct time prior to that:

HUB: C7
Software Version (I presume you mean Platform Version): 1.3.9.143
Driver: HE Native Orbit Hose Timer

Within about 25' of hub
No metal in the way
Batteries brand new when installed 2 weeks ago; now at 89%
No sloppy repeaters in the way

I've reverted to three waterings/day with 12 tries each to try to get the d--- thing to actually water. It worked once today...
Just checked and it is now connected through the 2nd furthest away zigbee repeater, a Third Reality Motion Night Light up on the top level of my house...

I should have been more clear. I was not indicating the device clock was not updating because of the GMT issue, I meant the clock was not updating because it never gets set at the time of pairing. The clock display defaults to 12:00 and counts up from that.

1 Like

Just to share, here's some data on mine. And I didn't realize I had two diff firmware versions till now. Running on C5 on 2.3.8.140 and scared to death to upgrade given some things said above, and my other hub running the latest and having some oddities I'm not yet ready to lay blame.

ONE of these-

  • firmwareMT: 111B-0000-00272000
  • manufacturer: Orbit
  • model: HT8-ZB
  • softwareBuild: 00272000

TWO of these-

  • firmwareMT: 111B-0000-33002000
  • manufacturer: Orbit
  • model: HT8-ZB
  • softwareBuild: 33002000

image

Simple Irrigation V 2.0.1 never fails me w/ default multi-attempts rarely if ever needed, but that's not the issue here.

As far as the time the device gets, I think I noticed the discontinuity early on, tried to mess with it and things worked regardless...so ignored due to Simple Irrigation handling things accurately.

EDIT: One more add; I'm using Zigbee Ch20 on the hub with the Orbits and Ch25 on the other. Main repeaters serving the area are TWO Ikea repeaters (sole function). Not saying they are the greatest but they are handy in that a long USB cable allows them to be placed in a plastic box on an exterior wall.

Interesting. Had not thought of the firmware, and am not sure if/how one could upgrade if needed. Fortunately I don't think that is needed. Mine is as follows, which matches two of yours.
image
I'm also using the same driver you are using.

I've upped the tries in Simple Irrigation to 15, and yesterday the afternoon and evening watering sessions triggered, but this morning I got another "didn't open after 15 tries; please check device" notification... Device shows wireless connection icon...and again was not connected when I opened the Zigbee Network Graph, but connected direct to the hub after about 10 seconds.

I think what I need is to switch from Simple Irrigation (which I really like) to rule machine, with an action that causes it to connect, similar to the way it does when I first pull up the Zigbee Network Graph, then an action to wait 10-15 seconds, then run the watering rule. I'm just not sure what action would cause it to connect.

The other option is to just get one of the Tuya devices with similar function off of Amazon, but I can't find any reviews to indicate if those work any better.

The Orbit Hose faucet water timer should be of a much better quality if compared to any Tuya gadget…

Can you temporarily dismount it and run some ‘dry tests’ with the same driver, same irrigation scheduler app, but the device placed temporarily close to the HE hub?

This will show whether it is a Zigbee mesh reliability issue.

1 Like

Great idea. While you are doing that I would totally RESET and RE-PAIR and hit CONFIGURE once you're sure the right driver is selected. I can't recall where/how the FACTORY RESET is done on those.

EDIT ADD:
Yah know, it's really flippin bad when you don't remember being apart of a discussion about the very same things elsewhere....

1 Like

I'll add some more info for you. In that other thread, I was the one who sent my Orbit to mike.maxwell to test. He said he had no problem pairing it on his C8. I found that odd because I have two C8 hubs and under the same hub version it didn't work on either of mine. Why? I have no idea. That's when I stopped wasting more of my time and went back to my C5 hub. Just for S*its and grins I tried pairing it on my C8 giving it another try on the C8 Platform Version 2.3.9.142. Guess what? It doesn't work. Oh well! Back to the C5

FYI:

  • firmwareMT: 111B-0000-00272000
  • manufacturer: Orbit
  • model: HT8-ZB
  • softwareBuild: 00272000
1 Like

I moved 4 of my orbits to the C8-pro from my C5 and have this issue as well. It's definitely not a mesh issue since I also moved 5 of my Xbee3 repeaters over. Only way for me to get them working again is to reboot the C8p hub.
No error log as far as I can see.

  • firmwareMT: 111B-0000-33002000
  • manufacturer: Orbit
  • model: HT8-ZB
  • softwareBuild: 33002000

Meaning.... problem resolved? Or until the next time they disappear?

Good for a day or 2.