Notifications not coming to phone, presence issues

Yeah, totally - great reminder, definitely will be updating each mobile app device item in place, not linking all of the phones to one device ID :slight_smile:

Appreciate the help y'all! I knew the answer was out there.

BTW, Swap Apps Device is one of the most useful things going. What an amazing feature. In previous platforms, replacing a physical switch or two would create hours of reprogramming for want of this.

2 Likes

I still haven't been able to get any notifications on the new app.
I'm on Android 2.0.1 (239). Hub is C7 running 2.3.9.158
I have tried uninstalling the app, changing my DNI, reinstalling the app. I get a duplicate mobile app device created but it won't seem to let me create a new one.
Any suggestions?

Did you try refreshing the device, then testing that notifications work? To refresh, go to mobile app, then More then App Settings. Also, worth checking the app info to make sure the notifications are enabled.

How are you getting a duplicate if it does not let you create a new one?

Filter your devices list on the hub searching for "mobile", post a screenshot, like this:
(I dont know if anything could be done with the DNI so I blurred mine partially to be safe, but I do want to see at least the start/end of the DNIs to see if you have renamed them correctly)

Hi. Bobby,
I did hit the Refresh button under app settings in the Hubitat app, then sent a notification, but it was not received (although I can see it in the logs)

Jeff, here are my mobile devices, as requested.
I haven't renamed my wife's DNI, but I did change mine, latest change was to add _old to the end.
I already deleted my duplicate. Do I have to change all mobile device DNIs for this fix to work?

Should the DNI on the refresh page match the device page (after hitting refresh)? I blurred the middle here, but it's not the same DNI

I cannot see the end of the DNI in your screenshot but it sounds like you created a new device from the app and then deleted it, leaving the _old one on the hub? That is not what my suggestion was.

In order to force the app to ask you to pick a new device (or create a new one) you may need to edit the DNI of the existing one (on the hub side).

  • Go to devices on hub and open the device page for your mobile device.
  • Scroll down and click the edit DNI link.
  • Add something like _OLD to the end of it and save.
  • In the Mobile APP tap your hub name on the home screen then "Switch to another hub".
  • Select your same hub and then it should ask you to select a device, DO NOT select the existing device, create a new one.
  • Back on the hub go to the newly created mobile device and send a test notification.
  • If the test worked, use Settings > Swap Apps to swap your apps (notifications) from the old to the new device.
  • Once you are satisfied this has fixed it, you can delete the old device from the hub.
    (verify it has the _OLD DNI so you don't delete the wrong one)
1 Like

@JD0691 before the step to use the Swap Apps, first test that the notification works on the new device by sending a test message from Device Details page. If you receive the notification, then proceed to swap the device. If the notification doesn't come through, check the permissions for the app.

I added that to my steps above.

1 Like

Jeff,
I followed your steps as follows:
I went to the device page of my mobile app device, and changed the DNI of my mobile app device again. I had previously changed it by adding "_old", this time I changed it to "_older". I saved the device.
In the mobile app, I tapped on my hub name, switch to another hub, selected my hub, hit create a new device, and it said something like saving (it was fast), and took me into the app. It did not allow me to enter a name for a new device. I checked the device list and found it had created a device with the same name.
When I check in the app, where the refresh button is, the DNI displayed matches the newly created mobile device.
I sent a notification, but it didn't work.
I left the duplicate device for now.
So, it seems like the app won't allow me to create a new device. Should I try changing the DNI for both my device and my wife's and repeat?

No... you did create a new device according to what you said above, but the notifications are still not working. It does not ask you for a name, it names it automatically which you can then change on hub side if you want.

From the device page of the newly created device? Like this
image

I am writing this from looking at a Samsung tablet, all android devices may be different.
On your mobile device, go to Settings (of the device not the HE app).
Look for Notifications section
Mine has "Included Apps" with a link under that says "All Apps"
Click that link to open the apps list.
Find the Hubitat app in the list, make sure notifications are not turned off.

Jeff, on my phone, I confirmed that the Hubitat app has notification permission. I go to settings, apps, select Hubitat app, then select permissions.


For the notification, I wrote an app that sends me a test notification. I'm going into the app, actions, and hit Run Actions (I didn't actually trigger it via the Virtual Switch). I then see an entry in the Logs.

Also, in terms of presence, the new mobile device has no current states listed, the old one says not present, but I am present, and the mobile app says I'm inside of Geofence.

I also noticed some log entries from an app called "Mobile App Manager"
image

Keep the new device attached to the mobile app and test it directly from the device page on the new device as suggested, it rules out any other variables.

Those errors could be causing some of the issues, not sure, there is a device you have with an "html" attribute that is too long to display. It might be on one of your dashboards?

1 Like

Jeff,
I tried sending a notification from the device page for the new mobile app device. I didn't receive anything but it did show up under current states.

How would I check my dashboards for entries with an html attribute? I display own tracks Presence, display a lux reading from Open weather, display some air quality readings from my Air things monitor, everything else is a local device or Hub variable.

Thanks,
John

It would be something that is formatted and very long, possibly with images or special text formatting. You would have had to have specifically created the dashboard tile to display the "html" attribute on the tile. You can see if a device has an attribute by going to the device page and looking under "Current States" for one named html.

Do you see the notification on the Notifications page in the Mobile App? If you see it, then the problem is likely with the phone's notification settings. If you don't see it listed, then the problem is with the hub's mobile device.

Bobby, I think the app did receive something.

Jeff, I had a look at my Air things device and it seems to have grabbed the hub startup notification as html.

Any idea how to get rid of this?