Notifications not coming to phone, presence issues

Hi, I'm running the Android app v2(234). Hub is C7 running 2.3.9.157. Two issues:
I'm not receiving notifications to my phone.
Also, in the app under Geofence, it says I'm home (which I am), but my phone device in Hubitat says I'm away.
Normally when I'm at home, I just use a browser on my phone or laptop to get to the hub, and only use the app when I'm away from home. Can I continue to do this with the new app?
Thanks,
John

2 Likes

The two issues are related, your mobile app isn't communicating with the hub's mobile device. Search for additional mobile devices on your hub's Devices page, then remove any that are not in use by any apps. Then force close the Mobile app and when you reopen it, select the existing device. Don't create a new one. If you don't have any additional mobile devices on your hub, please send me a private message along with your hub id.

Thanks Bobby,
I have only 2 mobile app devices, one for me, and one for my wife.
When I did a Force Stop of the Hubitat app from the Android Apps page and restarted the Hubitat app, it didn't prompt me to pick a device, it just went straight back in. Do I have to clear cache or something?

I have the same behavior in IOS... Logging out of the app and then back in, it doesn't let you pick a device... It allows you to pick the hub, but not the device.

I'm going to try to do the reset thing that IOS has from the settings page.

EDIT: The reset button didn't help. Logged back into the app and still the same thing. Lets me select the app but not device.

EDIT #2: I deleted the app, so all data should have been destroyed... Installed again, logged in and it allowed me to pick a hub... But then did not show me a device selection, but "registered" itself. I have 6 users, so 6 existing app devices on my hub... I have no idea...

I can control devices, etc., but no notification and geofence not working correctly...

1 Like

Please check the private message I sent you and @JD0691

No, that will not help. See my private message.

I have this same issue since updating to the 2.0 app. It allowed me to pick a hub when I logged into the new app. But no notifications are sent from my hub to the mobile device. I can see there’s one Mobile App Device per phone still registered to the hub, and the notifications from all my apps/pistons/etc are being sent to that device (i can tell from the hub logs) - but they never reach my phone. Would love some help here, those notifications are critical to me.

For what it’s worth, I am on the iOS app 2.0.0 (274) and a C-7 hub running latest as of this posting, 2.3.9.158

I also have the problem with the new Android app.

I'm having the same issue on iOS. Previously, you could correct this be sending a geo event and it would start working again but, on this new version, I don't see that option.

Yeah, I'd really appreciate it if someone (tagging @bobbyD since you were in this thread, but anyone...) could share some answers or the magical incantation that make this work again? Having lost both presence and notifications all at once with no clear path to restoring them has really damaged not only my own ability to manage my automation, but my faith in my whole system.

1 Like

Please update to the latest version released yesterday. If that doesn't work, the "dirty" way to fix it, is to uninstall the app, then after installing it again create a new device during set up. Once the the new device is created, go to your hub and use the Swap App from Settings to replace the old device(s) in the existing rules.

1 Like

The app links to the virtual mobile device on on the hub via the DNI and this is remembered either on the cloud server or on Android I think it is a hardware UUID. I have found that even after deleting the app it may persist in linking to the virtual device (which is usually a good thing).

Do what @bobbyD suggested above first (make sure app is updated)

And also try this: (coming soon to iOS app)
This refreshes the token and reconnects the app to the hubs virtual device.

Last resort more complicated fix:
What may fix it is letting the app create a new "device" on your hub. In order to force the app to ask you to pick a new device (or create a new one) you may need to edit the DNI of the existing one (on the hub side). Just add something like _OLD to the end of it. Once that is done do the "switch hubs" routine on the Mobile app and it should ask you to select a device, DO NOT select the existing device, have the app create a new one. Once that is done, on the hub use Settings > Swap Apps to swap your apps from the old to the new device.

Once you are satisfied this has fixed it, you can delete the old device from the hub.
(verify it has the _OLD DNI so you don't delete the wrong one)

Thanks, I tried this. Didn't realize the app had updated itself since I posted - am now on 2.0.1(281) and the behavior is the same.

Uninstalling the app and reinstalling it does not prompt to connect to/create devices - just prompts to select a hub.

Notifications still don't work with the new version. I don't get prompted to create a new device as an option so @jtp10181 flow doesn't seem doable either.

I do see the app briefly considering what device to link to, but I don't get the chance to interact with that process.

Selecting/creating a device is the next step after you select the hub.

It is doable if you rename the DNI as I suggested, the app will not link to the existing device. I have tested this myself in the past.

image

I see it happen in the background but it does not give me the chance to interact with the process. I took a screen recording but it won't let me upload video files. I've deleted and redownloaded the app several times and it always prompts me to log in, asks me to select a hub, then just goes to "registering mobile device" as a grayed out overlay with no option to tap the "create new" or select a device.

Then it finishes, and notifications don't work.

Aha, I missed that part. Sorry, reading too many posts at once. Let me give this a try.

Before you do that, go to the mobile app, then select More and App Settings and click refresh.

Oh, saw this too late. I used @jtp10181 steps and it worked perfectly! Kind of a pain but now that I know the steps easy enough to do. Will need to replicate it for my other mobile devices but it's doable.

Thanks all for the help.

1 Like

Make sure you link each different physical mobile device to separate virtual device on the hub to ensure you don't break the notifications / geofencing.

Also BTW The refresh button that was eluded to is only on the Android app (as of right now). For anyone else following these steps to fix, you can try that first on Android.

1 Like