New Xiaomi Aqara Relay 2 channel

And after that it still doesn’t make sense? The IR device was a relay itself and needed a constant supply power. Power cycling one for the other would and sounds like it did, fry them.

Anyone know whether you could use one of these to control your garage door opening? I currently use a Sonoff 4ch which is great except that there is no device handler to get it working in Hubitat without doing firmware upgrades etc and I'm shying away from that atm.

See my post here and the one following it. These give mains voltages across their contacts, so if you’re not closing contacts to send mains voltages to a device, you need to add an extra relay or you will fry your garage door opener circuit.

But once isolated with a second relay, it’s fine for no voltage, or any voltage the attached relay is rated for. I arm and disarm my alarm system with one of these Xiaomi relays, and it never misses a beat.

1 Like

I, like other users, have experienced the relay not responding correctly when utilized with2 hardware wall toggle switches. It seems activating any ONE of the switches, activates BOTH circuits.
However when utilizing zigbee the channels do act independently

I need the wireing diagram for setting up a 2 way switch on the aqara relay. any help on the same would be appreciated.

You mean a 3-way (two switches)?

You can find it in this post

Why doesn't connect the external relay to 'N' and 'L1' but 'In' and 'L1‘?

I know this is dragging up an old thread but I am just researching this device and I think @edenyuanyd is correct in their post above.

The diagram above has live to both terminals of the external relay, one permanent live from the "In" (which is bridged to live), and one switched live from "L1". The external relay would never operate. The external relay coil needs to connect to the "N" terminal and the "L1" or "L2" as below.

Aqara%20Dual%20Relay%20Diagram2

1 Like

Thanks. You are correct and I was contacted via PM, updated that image, but forgot to correct the post with the new image. Appreciate you point out my second error :stuck_out_tongue_winking_eye:

[Edit] Post #76 is now revised with the correct wiring schematic.

1 Like

Hi there,

is it possible to turn LLKZMK11LM relay into monostable switch?
I need a device which is integrated with the aqara app and on pressing - switches on and on releasing - switches off.

Input: monostable switch, output monostable relay.

Hello
I am quite new to Hubitat and the Home Automation world and have recently bought 3 of these double relays (QBKG11LM).
I have an issue with S1 & S2 inputs on these relays behaving strangely.
Out of the box they work fine. S1 and S2 switch L2 and L1 on/off independently. As soon as I pair them to Hubitat either S1 or S2 will switch both L2 & L1 on the simultaneously. Thereafter L1 remains on and L2 can be toggled on or off by either switch. The device drivers where installed as is. No changes or omissions. I presume that's correct?
I can control L1 and L2 independently via Hubitat but the moment I use S1 or S2 again L1 latches on.
Any help would be appreciated.
Thank you
Andrew

QBKG11LM is a different device (wall switch double), did you mean the LLKZMK11LM ?

If you read back from the beginning of this thread you can see that some of us had the same odd experiences with the LLKZMK11LM.

I came to the conclusion that unfortunately these modules only worked acceptably for me if:

  1. I didn't need local control, i.e. just single or double channel control via ZigBee
  2. I needed local control from one switch only, with either one or both output channels operated from a single switch input

At one point I was convinced the different switch behaviour was dependent on the batch (date) of the devices as I did have some that appeared to work fine ...... but when I revisited those devices at a later point to actually use them, they had the same odd behaviour ..... so maybe I was mistaken originally. Kinda got bored with it at that point, as with a lot of Aqara stuff it can be quite frustrating!

I think @SmartHomePrimer was going to look at how they behaved in the Aqara hub at some point, to see if the strange behaviour is a result of pairing to HE or just how they behave in all cases.

2 Likes

Been too long. Don’t recall if it was working as expected. Thought I responded, but will have to test again when I have time.

Thank you for the responses.
Martyn, yes they are LLKZZMK11LM.
If I remove the device/s from Hubitat S1 and S2 then operate L2 and L1 independently again .

Just a heads up on this device as I have been having really weird behaviour from one of my units.

I noticed that the device controlled by one of the relays was often on when it shouldn't be. It is only controlled by 2 simple timed rules - on at 11 am and off at 5 pm, but often it would be on outside these times.

Checking the event logs for the device I could see that it was also getting switched on at random times between about 11pm and 11.30pm every night. This is roughly the time that I turn off a bedside light using a Hue Dimmer so I checked the logs and it turns out it was EXACTLY the time I pressed button 1 on the dimmer!

I checked the button rules and there was no spurious entry for the relay device, but still when I pressed button 1 on the dimmer the relay device switched on. I even paused the button device rule completely so HE wasn't acting on the button press at all and button 1 press still turned the device on. It's almost like it had somehow got a direct pairing with the relay device.

I reset and rejoined the Hue dimmer and the link seems to have been broken and all is OK for now. I will keep an eye on it.

So if anyone gets any odd behaviour from these, check if it is caused by a Hue dimmer inadvertently linked to it.

2 Likes

Is that the new Hue button or the old dimmer? I never had a problem with my Xiaomi relay, but when I recently paired this new Aqara Opple 6 button Zigbee 3.0 controller, I had the same issue. Difference was mine was controlling the relay and both my TRÅDFRI outlets. Seems to be something unforeseen that needs to be worked out with Zigbee 3.0 devices on the hub.

There’s a description of my 1:30am incident at the end of this post

This is the old standard 4 button Hue Dimmer. The one in question has been on my system for a while with no changes to it's rules so quite how it got linked to the Aqara Dual Relay device, which I only installed in the last couple of weeks, is a complete mystery.

I am wondering if it might be that the dimmer began routing through the Relay and somehow commands that the relay is meant to simply transmit are actually being acted on instead. That is possible as they are located fairly close to one another. I re-paired the Hue right next to a Tradfri outlet that should be it's nearest repeater. I will keep an eye on it to see if it does it again. It is a bit worrying because I use one of these dual relays to control my heating boiler and zone valve so I really don't want any other random commands triggering it! Maybe I need to find a non Aqara alternative for that.

1 Like

Prior to that one incident, I had no problems with it. I would have known, because I had it controlling my iSmart Alarm (now up for sale) and it would have beeped when arming or disarming, plus I would have received a notification on my phone.

I’m now using it to trigger a contact sensor so I could use the Aqara gateway as an additional siren. It’s not giving me any trouble aside from that single incident. Might have just been a bad device pairing in your case. It happens sometimes. I’ve experienced that on Wink, SmartThings and Hubitat. Re-pairing has always fixed those type of issues.

I am thinking of controlling 1.5kW baseboard heater, 240V, thoughts?

The above link explains setting interlock command via payload.
But me no programmer yet. So, If any developers on this community set this flag, through the DH, that would be awesome.

Regards.