InfluxDB Logger issue

I have been using InfluxDB Logger to get data into Grafana. I tried to add a new data source to graph and discovered this when I open the app.

Summary

Here is the Status page for it.

Summary






Anybody have any ideas how to fix this? I already tried restoring to the oldest backup from the current Platform Version (2.3.2.128).

I just checked with another hub with InfluxDB Logger and I see the same blank screen for configuring the app. I wonder if this is due to one of the recent platform upgrades.

I see it as well. It seems to be related to when you flip the switch for "Get Access to all Attributes" otherwise it seems to work.

Same problem. Did some testing, rolled back the firmware on the hub. Problem starts with 2.3.2.126 works under 2.3.1.142. Reinstalled, repair nothing seems to fix it.

I have tried a few things to try to understand what is happening here. It looks llke a problem specific to the option to "Get access to all Attributes". Maybe @ogiewon would consider looking at.

If you don't need custom attributes to be handled just turn off that flag.

it's more specifically related to that Section on line 166

comment it out and it doesn't display well, but doesn't have a blank either:

//							section("$deviceName", hideable: true,hidden:false) {
								input name:"attrForDev$deviceId", type: "enum", title: "$deviceName", options: state.options, multiple: true, required: false, submitOnChange: true
//							}

I don't use this app, have no DB setup for it, haven't much interest :smiley:

But I know how to use // comment to narrow it down.

I read in some other topic that "they made dynamicPage less forgiving" as the only details of a fix..

Same here! Thanks @csteele for helping others with this app. I haven't used it in years.

I use this app. I will look at it, tomorrow or the day after unless someone gets to it first.

@ogiewon, do you want a PR or do you want me to fork it and carry on?

1 Like

Since it is in the Hubitat Community Github repo, a PR would make sense. We need to see if someone can give you privs on that repo so you can make changes as you see fit. Perhaps @csteele can add you to the InfluxDB repo so you can make changes on you own?

How does one turn off that flag when you can see it?

App Code.
line 95:

// app?.updateSetting("accessAllAttributes",[value:"false",type:"bool"])

remove the // and save, then open the app.

Go back into the App Code and either put the // back or remove it entirely.

1 Like

I did it first using the Line 166 method. That also works by commenting out that section, then putting it back. Second solution about Line 95 also worked. Thanks!

I spoke too soon. The devices are still selected in the Status Page for InfluxDB, but in the GUI, there are no devices showing selected. Also, I noticed that I am using Custom Attributes.
Is there another solution for getting information into Grafana without using Node Red?

Line 95 is a "trick" to get you out of the blank hole :smiley:

Line 166+168 push the selectors to the bottom.

Then opening a dropdown, I get all the attributes:

This is just wild stabs... I don't use this, don't know what it's supposed to do/look like. :slight_smile:

3 Likes

dennypage has been invited on GitHub for this repo.

2 Likes

I looks like it has issues with nested sections, if you comment out 152 and 172 then it works fine allowing the section on line 166 to work. Don't mind my other modifications in the screenshot, I was trying out various things to see what was going on.

@gopher.ny is this intentional or a possible bug?

1 Like

What exactly is the issue? Nested sections not rendering properly?

Yes, two cases in different apps where a nested section is causing either just a white screen or an error on the page but no error in the logs. Once either the top level or nested section is removed the page will load.

1 Like

Double checked it internally, nested sections are not supported and we have no plans to support them in the future. It will throw a meaningful exception starting with next hotfix.

1 Like

Is this is a new restriction ?

There were two cases that ring a bell regarding a roll back... this is just one.

I'll roll back my Dev Hub to 2.3.1.142 and check...

Screen Shot 2022-06-20 at 8.58.45 AM

Update...
Yes, first quick test indicates it works fine in 2.3.1.142
PM sent

Download the Hubitat app