[RELEASE] Hubitat Package Manager (HPM) -- HubitatCommunity

Unable to reproduce...

This is what I just tried...

  • manually added InfluxDB-Logger.
  • Match Up -- match Yes, but didn't choose up-to-date
  • Update - got offered to update InfluxDB-Logger (as shown below)
  • Accepted the Update.

Screen Shot 2022-06-17 at 9.16.25 AM

resulting in:
Screen Shot 2022-06-17 at 9.09.54 AM

1 Like

Basically what I did and when I go into it it's basically blank. Could something have happened to the code when it was moved to HubitatCommunity

Did you try a repair, this will usually fix this kind of problem.

1 Like

"Will this affect the original code, and more importantly, the confidence in that code?" That's been my #1 test of each and every line of code I touched.

To gain confidence in the migration I very intentionally didn't alter any of the original Apps, Drivers or File pathways in the code.

The downside of keeping my fingers off the original code is... I didn't prevent/correct existing issues either. If HPM had an issue in July of last year, it probably has it still today. :smiley:


Did some more testing, rolled back the firmware on the hub. Problem starts with works under Was just a coincidence that I only noticed it after it being added to HPM. Thanks for all you do for the community.

In case someone finds this topic before the active / specific topic.

I'm seeing a manifest error when I manually run hpm update check. Is there steps to take?

I'm assuming this related to the transition of the seperation of delivery methods. Is there a requirement to uninstall from HPM so that BM has control?
If thats true, is there anyway to leave the apps intact but change the parent management system?


Use Un-Match :smiley:

1 Like

Will it ever end!? :rofl: :rofl: :rofl: :rofl:


Not until it's explained at least one hundred times.
Mind you we are getting close to that number. :joy: :joy: :joy: :joy:




In fairness, I didn't get the unmatch option until I went in and did a repair to HPM even though I was on the latest version. Unmatch wasn't even listed.


I'd need to see that. The only way to see v1.8.6 like this:

Screen Shot 2022-06-22 at 11.55.42 AM

... is if the code, that contains un match was there. The "6" and all the Un Match code are part of a single package of code.

1.8.5 and less didn't have Un Match. If your eyes are like mine, a 5 and a 6 at screen distances are the same. :smiley:

1 Like

I have already fixed it (@bobbles made the suggestion to run a repair on HPM). I was about to head over here for help, but tried his suggestion first. Prior to repair, the settings page ended after repositories.

It was almost like it got hung up somehow. :man_shrugging:

1 Like

Just as a note I was just seeing the same thing, I didn’t even see this current version in the menu, that you are showing in the screenshot and wasn’t seeing unmatch either. The view apps and driver page was showing 1.8.6. I’ve since repair and now it shows up.

Probably not very helpful, but figured I’d give another voice to say I experienced the same thing. :person_shrugging:

1 Like


That's a head scratcher for me, for sure.

Grasping at straws.. maybe a browser cached page didn't display the feature?

Can you force an unmatch @csteele and be done with it, just seems to be causing confusion.

1 Like

There are multiple reasons for a "bad manifest" error, most of which need the developer to resolve on their end, so an auto-unmatch may not be possible.

1 Like

Thanks. I'm resolved. My HPM was .2. HPM Updates did not offer to update HPM so my version was out of whack. When I ran the manual copy paste from github the feature appeared. repair may have also fixed it, but i wanted to be sure I had the latest from the link so did mine manually.
I wonder why HPM update didn't update HPM? odd. Regardless. thanks.

1 Like

I've ran that test more than a few times as I verified that un-match of HPM cured the dual manifest cosmetic issue. I Soft Reset back to a date where 1.8.2 was all I had installed and an upgrade was offered. I tested both waiting for the upgrade offer and just doing a repair, knowing the manifests were pointing at a new version. Both paths worked the same.