[RELEASE] Hubitat Package Manager (HPM) -- HubitatCommunity

Just as a note I was just seeing the same thing, I didn’t even see this current version in the menu, that you are showing in the screenshot and wasn’t seeing unmatch either. The view apps and driver page was showing 1.8.6. I’ve since repair and now it shows up.

Probably not very helpful, but figured I’d give another voice to say I experienced the same thing. :person_shrugging:

1 Like


That's a head scratcher for me, for sure.

Grasping at straws.. maybe a browser cached page didn't display the feature?

Can you force an unmatch @csteele and be done with it, just seems to be causing confusion.

1 Like

There are multiple reasons for a "bad manifest" error, most of which need the developer to resolve on their end, so an auto-unmatch may not be possible.

1 Like

Thanks. I'm resolved. My HPM was .2. HPM Updates did not offer to update HPM so my version was out of whack. When I ran the manual copy paste from github the feature appeared. repair may have also fixed it, but i wanted to be sure I had the latest from the link so did mine manually.
I wonder why HPM update didn't update HPM? odd. Regardless. thanks.

1 Like

I've ran that test more than a few times as I verified that un-match of HPM cured the dual manifest cosmetic issue. I Soft Reset back to a date where 1.8.2 was all I had installed and an upgrade was offered. I tested both waiting for the upgrade offer and just doing a repair, knowing the manifests were pointing at a new version. Both paths worked the same.

Sorry to report some sort of updating bug here:

app:7362022-06-24 14:25:15.555 error java.lang.NullPointerException: Cannot get property 'https://raw.githubusercontent.com/birdslikewires/hubitat/master/generic/libraries/library.zip' on null object on line 2101 (method performUpdates)
app:7362022-06-24 14:25:15.218 info Downloading AlertMe Fob
app:7362022-06-24 14:25:14.979 debug Performing update
app:7362022-06-24 14:25:13.232 debug prefPkgVerifyUpdates
app:7362022-06-24 14:25:11.808 debug Updates available

I released a new version of the Fob driver and the library is a required component in the manifest.

This is where HPM gets stuck, there are no further updates to the installer screen.

A repair will reinstall everything correctly, but incremental updates appear to be broken where there's a bundle to be installed at the moment.

Unable to reproduce.

Screen Shot 2022-06-24 at 9.36.27 AM

Screen Shot 2022-06-24 at 9.36.54 AM

Screen Shot 2022-06-24 at 9.38.42 AM

And after that, I get:
Screen Shot 2022-06-24 at 9.31.33 AM

I check Bundles, which shows:

Screen Shot 2022-06-24 at 9.34.56 AM

Then check Library Code:

Everything looks good, so I uninstall it:

Screen Shot 2022-06-24 at 9.36.01 AM

And the Library bundle goes away, the library code does not, as expected. I manually delete it and have done the whole Install, check, delete cycle 3 times. Worked as expected for ME.

The installations always work perfectly, it’s the point release updates which fail. Install the Fob driver again and I’ll push a fake point release. Then try to upgrade the driver in place.

Oh.. Update.. give me a bit to check that code...

Bug found and fixed in v1.8.7

Screen Shot 2022-06-24 at 2.53.51 PM


I have a C7 hub, and my HPM is 1.8.7. I just installed it but I get an error saying that it can't login to hub and to check my hub security login. I have tried it both with and without Hub Security enabled, but I get the same error.

HPM's switch must match the reality of the hub. If you have a login configured on your hub, then you must tell HPM how to get in by giving it the ID/pw.

If you don't have your hub configured to use a login, then don't tell HPM that you do.

Maybe you were using shorthand but simply enabling hub security won't work. You have to give HPM the correct login and pw.

I believe that I'm doing everything correctly. Here are some screen shots.

Trying to update and getting an error:

Do a repair on it instead and you should be good from that point forward.

Hmmmm it shows up twice on the repair list.

Pick the first one, do a repair; then go to Options and unmatch one of them.


This link is up a few dozen messages, so it might be helpful again, days later...

1 Like

This worked but to clarify

  1. Repair the first Hubitat Entry in the drop down
  2. Once completed, go to Package Manager Settings
  3. At the bottom, click on Remove a Matched Package

I had to click around to get the exact steps above, this removed the entry for v1.8.4 while keeping my v1.8.7

Removed Rachio from HE to use on a different HE controller.
and HPM now gives errors.

Unable to update or repair HPM
What are the steps to repair?
Should I remove HPM?
HPM says update available.