HousePanel Dashboard App for Hubitat


#1

[RELEASE] HousePanel for Hubitat

(Original post updated to reflect current version that works for Hubitat only installations too)

I'm excited to share the availability of HousePanel for Hubitat. HousePanel will interact with both SmartThings, Hubitat, or both. If you only have Hubitat that will work just fine in the current version too.

To obtain the code, download it from the HousePanel GitHub repo found here:

Documentation and detailed installation directions are available here:
http://www.housepanel.net
All things HousePanel can be found here in the future.

For quick install of the server on a rPI, use the new install script as follows:

cd ~
wget https://raw.githubusercontent.com/kewashi/HousePanel/master/install.sh
bash ./install.sh

The only thing you need to do on the Hubitat side is install the HousePanelHubitat.groovy file and name it HousePanel.groovy, Enable OAuth and then install the app as a User App.

** (Note: original information was outdated so it was removed. please refer to the doc file above for detailed installation directions.) **

If you want to run HousePanel with a dual hub setup, you will also need to install the separate HousePanel.groovy file in your SmartThings IDE; otherwise, if you are only using Hubitat you can ignore this file and skip this step.

Once you have the parts installed, load HousePanel into your browser. Here's a screenshot of my office things... nothing visually new other than the fact that the light and motion sensor in the bottom right corner are Hubitat devices.


Support for ActionTiles
Dashboard control panel with floor plan?
Access Hubitat through internet
Looking for advice before move to Hubitat
Multiple Users
The Time has come
#2

Probably relevant is you DO need to locally host a website for this to work. rpi, linux/windows server, something.

Setup instructions are here: House Panel Wiki


#3

Yes - thanks for noting this.


#4

I don’t get an auth key when I install the app, it just logs the devices I’ve chosen on first install of it. OAuth is enabled.

ST auth goes through, lets me select stuff, but after hitting OK it goes back and blank white screen is all I get, refresh and it want’s another re-auth.


#5

Hmmmm I think I know the issue. Will Post fix soon. By the way, the manual auth will also go away.


#6

Any luck in getting this to work? I can get the ST side to work, but not the Hubitat side.


#7

I am having no luck with it also. I have the app installed, and the server setup on my rPi. When I navigate to the webUi all I get is a blank screen that shows:


#8

I pushed an update to branch “hubitat” that I hope will fix this problem. I reset my system and authenticated fine after this fix was implemented. All my Hubitat devices are showing now and auth didn’t repeat as noted in the bug. I wasn’t able to duplicate this so I hope this fixes it.


#9

I am not having any luck. I go to the webUI and all I get is what I showed in my previous post. Something odd is if I look at live logging my accessToken shown there is different then when I look under oauth within the app.

To me it looks like the webUI isn’t authenticating to hubitat to be able to pull back my devices,

Also, clicking on reauthorize throws this error:

The requested URL /HousePanel/ST_WEB/oauth/authorize was not found on this server.

If I look for that directory on my webserver, that path does not exist.


#10

The Hubitat OAUTH flow isn’t set up to work. You have to leave the SmartThings OAUTH Setup intact and have an active ST hub and account. The Hubitat hub for now is only supported as a second device which must have a local IP and device ID plus a hardwired access token provided in the clientinfo.php file. You get those by viewing the Hubitat log while you install the HousePanel groovy app.

I know this is a messy hack for now so I won’t be offended if you decide to wait until I get the OAUTH more refined flow setup. When that happens I will have a visual option of authorizing either or both hubs. I put this out there now because there isn’t any front end available so I thought speed over elegance was better.

Stay tuned for the elegance step. It isn’t hard but I’m just very busy at my paid job these days.


#11

Please try again - but disable OAUTH for now on the Hubitat side.


#12

Update posted that brings Hubitat branch up to date with sliders master branch


#13

I am not getting an access token in my logging. When I tried the first iteration with oath enabled, I would see something labeled access token if I clicked the round blue “I” to the right of the app name at the very bottom of page - not showing at all with this iteration, I am guessing because because oath is not enabled.

I am also not sure about the Hubitat ID. Is this the same Hubitat ID I see under the settings screen of Hubitat? If not, I’m not finding that anywhere else. When I had Oath enabled, the instructions to get the Hubitat ID led me to find the a string that was labeled access token which is contributing to my confusion.

I might be having a logging issue in general as I am not seeing anything in the logs except for an all and clear button.


#14

The log has to be open and live while you operate the site to see anything.


#15

Thank you so much - it’s working great!


#16

Release version 1.5 with working sliders and color picker. Details described in ST post.


#17

I got HP up and running for the ST Hub. I followed your instructions to install in Hubitat. The app in Hubitat sseems to run fine, but the Hubitat devices are not showing up on the Housepanel. I set up an Apache server on an old laptop, local access only.

BTW, another way to get the accessToken is by clicking on the blue “i” icon in the app listing page.

Any ideas why it’s not showing up?


#18

Never mind - I had the wrong IP address for Hubitat


#19

I’ve been playing with the new Hubitat Dashboard and it has its benefits and I have no doubt we are going to see more features added down the road. However, currently I really prefer Housepanel because of its css customization. The only reason I am currently using Hubitat’s Dashboard instead of HP is the problems I have encountered when I try to add Hue lights to HP. Do you have any suggestions for me to resolve other than creating virtual switches as a work around?


#20

What issues are you having? My hue lights were the first I tried in hubitat.

One thing of note is they will show up as many different types of devices. Light, bulb, switch etc. I believe you need to add the one labelled as light tile.