Fibaro FGS-223

Hi Guys,

I'm 90% through porting everything over to Hubitat, but im running into dramas with the DH for the FGS-223. using all the current DH's around, I can only get it to operate the first relay, or none at all.

Has anyone got (or wish to port) a DH from ST? it was working fine on ST before A lighting strike blew up my ST hub

I will say though, that the speed difference here in AUS (comparing to ST) is lightning fast! (no pun intended)


Have a look here:

You can find all sorts of goodies! :slight_smile:
Including a driver for the dual fibaro (223 included)

One thing to note is that you must install the metering switch driver first
Then the driver creates two virtual switches that control the two relays.
Then ignore the β€˜parent’ device and use the two switches.

Works for me!


Apologies for hijacking this thread!

I am very new to Hubitat and am trying to get the Fibaro FGS-223 working. I found the reference to your driver and have installed it within the Drivers Code section of Hubitat, as well as the Metering Switch Driver.

Could you explain in a bit more detail what you mean about the usage of the metering switch driver, and the virtual switches? It's not clear to me which driver you mean creates the virtual switches, and where i'd expect to see those appear.

Let's say I want to use Hubitat Simple Lighting app to make a light come on at a given time. I can see the Fibaro Switch as the controllable device, but in the list of actions I only have one set of "on, off" etc - not the 2 sets I'd expect to see for a dual switch device.

Apologies if this is a dumb question, and please feel free to point me at a WIki or Q&A if it's covered. I did check but couldn't find anything.

Thanks in advance,

Cobra - not able to get this working - the 2 under switches show up as unknown and then not able to add into the virtual device as doesn't see an endpoint.

Posted in another thread as seemed to match but this has the proposed solution

Well behind the scenes I have been working with @ericm to get his Dual Switch 2 FGS-223 driver working.
It reports power on both endpoints and you can also detect the difference between physical and software presses using sceneIds.

The driver can be found here -

If you want to create automations based on a physical up & down press on the switch set the proper scene settings in the device:


You can see from the Button Mappings section:


Also, here is a listing:

Button Mappings for scene functionality:

Toggle Mode
1 pushed - S1 1x toggle
4 pushed - S1 2x toggle
5 pushed - S1 3x toggle

1 held - S2 1x toggle
4 held - S2 2x toggle
5 held - S2 3x toggle

Momentary Mode
1 pushed - S1 1x click
2 pushed - S1 release
3 pushed - S1 hold
4 pushed - S1 2x click
5 pushed - S1 3x click

1 held - S2 1x click
2 held - S2 release
3 held - S2 hold
4 held - S2 2x click
5 held - S2 3x click


Did you use the Virtual device Sync to get the 2 switches in your device list?

You dont need to.
@ericm device handler will generate the Child Endpoints when you Save Preferences

Thanks for doing this. I'll have to give this driver a whirl.

Hmm. I've just tried this on one of my 223's and although it has generated the 2 End Points, I cannot find anywhere where it shows the state of these EP's.
Am I missing something here?
Is there something else I should do?

EDIT: Tried defining a Virtual Switch to track an EP but it doesn't follow the EP. It looks like there is no way of reporting the EP state.

You need to hit Configure after Save Preferences to get things working.
My device is reporting status, power and method of trigger here all ok

Make sure you also have the metering switch child device installed and then hit "Save Preferences" as @nigelmwilliams7 mentioned. You should then see two child devices in the device list:

1 Like

Thanks for info guys.
I already had the Metering Device installed when I tried to get this working months ago.
Got it working now thanks.
Once again, thanks for the pointers guys.

Hi All,

I am struggling with this one; I have just installed the Fibaro Switch 223, but can't work out the instructions from the posts. HE has detected this as a Fibaro Switch, and the physical switches work. However, I have tried the following, but not got where I expected.

  1. I have added the "Metering witch Child Device" Driver, but expected this to give me two child devices, but I get this:

    I expected to get the two virtual switches at this stage. Does anyone know what I am doing wrong?

Hi again,

An update on this one, I now have both switches showing and working; not sure what triggered it. I installed the Fibaro 223 Driver (from above), cycled the lights manually and both children appeared.
It looks like I can control them manually, but the "current status" differs for each; Switch 1 changes, but slowly (the lights react immediately); Switch 2 doesn't update unless I press "Refresh", but again the lights react immediately. Does anyone have any ideas?



Hi @ericm
I'm not sure if you are still supporting your driver for the Fibaro FGS-223 but I've noticed an error in the logs when the switch is turned off.
I'm using the metering device driver.
When I turn one of the switches on and off it's working OK but as I say, an error is generated when the EP is turned off. It doesn't appear to be causing any problems but when I had an issue earlier, support informed of the error and advised I disable the device to see if it is the cause. It wasn't.
Just wondered if you would care to take a look if you are still supporting it and have the time.
Here are the logs.

Shouldn't cause problems, but it has been fixed.

1 Like

Thanks for the super quick response.
I've downloaded the new code and the error has stopped.
Thanks again.

1 Like

I had a similar problem with two FGS-223 switches I was trying to get running. They had worked for months with previous automation hub (OpenHAB) but after they were included, only came up as "unknown" on the dashboard. After cycling the switches a couple of times manually, all of a sudden they were no longer "unknown" and they worked.

This was only the last thing that needed to be done, the instructions above were all followed to get to the point where I had to wake them up by cycling them.

I purchased one FGS 223 for replace a FGS 221 and after installing it with the driver following the instructions, the child devices are created correctly, when I toggle the physical switch it detects the change immediately but I have a long delay when I try to switch on/off any of the child devices, sometimes never work.

Anyone have faced this issue also?

Mine is ok.
What driver are you using?