Fibaro FGS-223

Erocm driver from last version of his git repository.

And the childs:

I'm pretty sure I tried that and had issues with the 223 driver.
I use the 222 driver and the same generic driver.
Give me 10mins and I'll fire up the pc and post it here.

Actually I am using this driver but it has to be used with this child device.
I lose track of what I am doing to be honest. :pleading_face:

 *  Metering Switch Child Device
 *  Copyright 2017 Eric Maycock
 *  Licensed under the Apache License, Version 2.0 (the "License"); you may not use this file except
 *  in compliance with the License. You may obtain a copy of the License at:
 *  Unless required by applicable law or agreed to in writing, software distributed under the License is distributed
 *  on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License
 *  for the specific language governing permissions and limitations under the License.
metadata {
	definition (name: "Metering Switch Child Device", namespace: "erocm123", author: "Eric Maycock") {
		capability "Switch"
		capability "Actuator"
		capability "Sensor"
        capability "Energy Meter"
        capability "Power Meter"
        capability "Refresh"
        command "reset"

	tiles {
		multiAttributeTile(name:"switch", type: "lighting", width: 3, height: 4, canChangeIcon: true){
			tileAttribute ("device.switch", key: "PRIMARY_CONTROL") {
				attributeState "off", label: '${name}', action: "switch.on", icon: "", backgroundColor: "#ffffff", nextState:"turningOn"
				attributeState "on", label: '${name}', action: "", icon: "st.switches.switch.on", backgroundColor: "#00A0DC", nextState:"turningOff"
				attributeState "turningOn", label:'${name}', action:"", icon:"st.switches.switch.on", backgroundColor:"#00A0DC", nextState:"turningOff"
				attributeState "turningOff", label:'${name}', action:"switch.on", icon:"", backgroundColor:"#ffffff", nextState:"turningOn"
        valueTile("power", "device.power", decoration: "flat", width: 2, height: 2) {
			state "default", label:'${currentValue} W'
        valueTile("energy", "", decoration: "flat", width: 2, height: 2) {
			state "default", label:'${currentValue} kWh'
        standardTile("refresh", "device.switch", inactiveLabel: false, decoration: "flat", width: 2, height: 2) {
		    state "default", label:"", action:"refresh.refresh", icon:"st.secondary.refresh"
        standardTile("reset", "", inactiveLabel: false, decoration: "flat", width: 2, height: 2) {
		    state "default", label:'reset kWh', action:"reset"

void on() {

void off() {

void refresh() {

void reset() {

It's the same one you posted.
Did you have the child device handler defined when you first set up the parent device?
If not, you might have to delete and redefine.

Yes, I already had the two drivers installed FG223 and Metering Switch Child Device before to Include the device.

The strange thin is than everything seems to work perfectly, the Child devices receive the notification of the physical changes of the switch. But If I try to on/off from the child device it has like a big lag.

Not sure what to suggest. Mine is working OK.
Maybe try a z-wave repair to see if things clean up.

Tried also without result, also exclude& include and reseting the FGS223 :frowning:

I really don't know what else to suggest apart from removing everything and starting over again making sure both drivers are installed before you pair the z-wave device to the hub.

With mine I can open a dashboard page instance and the child driver page.
Watching both windows I can turn on and off in either window and the other one shows the change within 1 second.
Sorry I could not be more helpful.

I tried with the oficial Fibaro Switch than should be compatible, with the same results, I think than the issue is not in the driver, it's on the device, the hub or zwave network, I will do more tests.

1 Like

Hi all

I am cross posting this to see if anyone else is experiencing this -

The main issue I am observing is Dashboards not reflecting current status as well as Groups (where they are setup to show any on as on).

Any ideas?

I have just checked mine and am having similar symptoms. I have two of these switches and both are making similar reports in the logs. Also, on the devices page for the device, when I switch on, it is clearly operating the lights, but there is no indication in the log that the light has operated and also the switch status remains off. I am also using ericm123's drivers and metered child devices. Just noted that in the release log for 2.2.1 the following:

All Z-Wave drivers: switchBinarySet and switchMultilevelSet commands will replace basicSet for devices that support the switchBinary and or switchMultilevel classes, this is a requirement of Z-Wave certification.

Looking at the driver, there are a number of basicSet commands used, so I assume this is the problem. Not sure how to go about replacing them, though.

Same happening for me too.

Seeing this in the logs for the child devices. (EP-1 & 2).
Tagging @ericm. :grinning:

To resolve this go into the driver code and change all instances of multichannelv3 to multichannelv4.

This fix is courtesy of @christi999 .


Perfect thank you @bobbles for replying and thanks to @christi999.
Where did you find this solution please @bobbles?

Christi999 has re-released his driver for the Fibaro implant.
I decided to take a look at it and in his notes he mentioned it was updated to make it work with the last update.
I asked what he did, tried on the 222 and 223 drivers and it did the trick. :+1:

1 Like

Worked for me, thanks.

1 Like

I am having issues with the update of the swich state when using the wall switch.

It works without problems from the device page, on and off, and the state updates in the dashboard accordingly.

However, if when the light is on, I switch it off from the wall switch, the light in the dashboard and the switch state remains ON. If I switch it off from the device page or the dashboard, the state updates to OFF and the light remains off.

EDIT: If switch on and off from the wall, it updates well in the dashboard, it only fails when switch on from the dashboard and off from the wall. The switch in the dashboard remains ON.

After last system update 2.2.2.X All fibaro switches stopped working for me.
I took the latest version (15 Aug 20) but the new version

  1. has a bug that no handling multichannelv4, anyway - I fixed it.
  2. The activation is not working, so If I click in the driver on Turn Off it shes in the log the ChildOff, but it is not performed and nothing happens. the same occur if I click on the child in the dashboard.
    Any assistance?

Are you on 2.2.2.xx or 2.2.3.xx which is the latest update.
On the latest I have found that Fibaro devices that use custom drivers no longer work correctly.
They either do nothing or do turn on and off but do not update status.
I have 5 which no longer work on the C7 but are ok on my C3.

@Cobra , I have the C3/C4 but it doesn't work. Using the latest driver. (and latest HE)
I analyzed the problem and here are my findings: